summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-07-17 15:12:51 +0000
committerJon Hood <squinky86@gentoo.org>2004-07-17 15:12:51 +0000
commite3d2d9d78b085a88b363d51d76b6b2923f87bd59 (patch)
tree9800b37dab11f487a7a2e5bfb13e096af7486ffa /net-p2p/bittornado
parentRemoved old ebuilds. Marked 0.0.6 stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-e3d2d9d78b085a88b363d51d76b6b2923f87bd59.tar.gz
gentoo-2-e3d2d9d78b085a88b363d51d76b6b2923f87bd59.tar.bz2
gentoo-2-e3d2d9d78b085a88b363d51d76b6b2923f87bd59.zip
add bttrack init script irt #55954
Diffstat (limited to 'net-p2p/bittornado')
-rw-r--r--net-p2p/bittornado/ChangeLog6
-rw-r--r--net-p2p/bittornado/bittornado-0.3.7.ebuild10
-rw-r--r--net-p2p/bittornado/files/bttrack.conf18
-rw-r--r--net-p2p/bittornado/files/bttrack.rc23
-rw-r--r--net-p2p/bittornado/files/favicon.icobin0 -> 1406 bytes
5 files changed, 55 insertions, 2 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
index 6ec477f2c986..855178d38916 100644
--- a/net-p2p/bittornado/ChangeLog
+++ b/net-p2p/bittornado/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bittornado
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.21 2004/07/17 03:18:30 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.22 2004/07/17 15:12:51 squinky86 Exp $
+
+ 17 Jul 2004; Jon Hood <squinky86@gentoo.org> +files/bttrack.conf,
+ +files/bttrack.rc, +files/favicon.ico, bittornado-0.3.7.ebuild:
+ add bttrack init script irt #55954
*bittornado-0.3.7 (16 Jul 2004)
diff --git a/net-p2p/bittornado/bittornado-0.3.7.ebuild b/net-p2p/bittornado/bittornado-0.3.7.ebuild
index 110753db9893..4e4edfab4fb3 100644
--- a/net-p2p/bittornado/bittornado-0.3.7.ebuild
+++ b/net-p2p/bittornado/bittornado-0.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.7.ebuild,v 1.2 2004/07/17 03:22:45 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.7.ebuild,v 1.3 2004/07/17 15:12:51 squinky86 Exp $
inherit distutils eutils
@@ -62,5 +62,13 @@ src_install() {
sed -i '/btdownloadgui/d' ${D}/etc/mailcap
rm ${D}/usr/bin/*gui.py
fi
+ insinto /usr/share/bittorrent
+ doins ${FILESDIR}/favicon.ico
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc bttrack
}
diff --git a/net-p2p/bittornado/files/bttrack.conf b/net-p2p/bittornado/files/bttrack.conf
new file mode 100644
index 000000000000..31772f0d7a05
--- /dev/null
+++ b/net-p2p/bittornado/files/bttrack.conf
@@ -0,0 +1,18 @@
+# /etc/conf.d/bttrack
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/files/bttrack.conf,v 1.1 2004/07/17 15:12:51 squinky86 Exp $
+
+# Change this to this to the port you would like to connect to for the tracker.
+# It is accessible at http://localhost:PORT/ from any web browser.
+PORT=8082
+
+# where to store recent downloader info
+DFILE=/usr/share/bittorrent/tracker.dfile
+
+# path to favicon.ico which many popular web browsers can use
+FAVICON=/usr/share/bittorrent/favicon.ico
+
+# Connection logs are sent to stdout by default, so they should be sent to a
+# file when using this script.
+LOGFILE=/var/log/bttrack.log
diff --git a/net-p2p/bittornado/files/bttrack.rc b/net-p2p/bittornado/files/bttrack.rc
new file mode 100644
index 000000000000..85b830ab862a
--- /dev/null
+++ b/net-p2p/bittornado/files/bttrack.rc
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/files/bttrack.rc,v 1.1 2004/07/17 15:12:51 squinky86 Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting bttrack"
+ start-stop-daemon --start --quiet --background --make-pidfile \
+ --pidfile /var/run/bttrack.pid \
+ --exec /usr/bin/bttrack.py -- --port ${PORT} \
+ --dfile ${DFILE} --favicon ${FAVICON} --logfile ${LOGFILE}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bttrack"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bttrack.pid
+ eend $?
+}
diff --git a/net-p2p/bittornado/files/favicon.ico b/net-p2p/bittornado/files/favicon.ico
new file mode 100644
index 000000000000..0e6136254aa5
--- /dev/null
+++ b/net-p2p/bittornado/files/favicon.ico
Binary files differ