summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-11-08 14:40:05 +0000
committerPeter Volkov <pva@gentoo.org>2010-11-08 14:40:05 +0000
commit181695fc6227618c57bad38d2ee3dda84dd7726c (patch)
treef757d44ed1180e727ab38a351f1bbb7729bb5ad4 /net-p2p/eiskaltdcpp
parentReplaced media-libs/jpeg dep with virtual/jpeg as requested in the dev ml. (diff)
downloadgentoo-2-181695fc6227618c57bad38d2ee3dda84dd7726c.tar.gz
gentoo-2-181695fc6227618c57bad38d2ee3dda84dd7726c.tar.bz2
gentoo-2-181695fc6227618c57bad38d2ee3dda84dd7726c.zip
Version bump, thank Nikoli for this job.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/eiskaltdcpp')
-rw-r--r--net-p2p/eiskaltdcpp/ChangeLog7
-rw-r--r--net-p2p/eiskaltdcpp/eiskaltdcpp-2.1.0.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/net-p2p/eiskaltdcpp/ChangeLog b/net-p2p/eiskaltdcpp/ChangeLog
index e77bb8879347..093c1563f8a3 100644
--- a/net-p2p/eiskaltdcpp/ChangeLog
+++ b/net-p2p/eiskaltdcpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/eiskaltdcpp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/ChangeLog,v 1.15 2010/10/25 13:34:31 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/ChangeLog,v 1.16 2010/11/08 14:40:05 pva Exp $
+
+*eiskaltdcpp-2.1.0 (08 Nov 2010)
+
+ 08 Nov 2010; Peter Volkov <pva@gentoo.org> +eiskaltdcpp-2.1.0.ebuild:
+ Version bump, thank Nikoli for this job.
25 Oct 2010; Peter Volkov <pva@gentoo.org> eiskaltdcpp-9999.ebuild,
metadata.xml:
diff --git a/net-p2p/eiskaltdcpp/eiskaltdcpp-2.1.0.ebuild b/net-p2p/eiskaltdcpp/eiskaltdcpp-2.1.0.ebuild
new file mode 100644
index 000000000000..c58050897759
--- /dev/null
+++ b/net-p2p/eiskaltdcpp/eiskaltdcpp-2.1.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-2.1.0.ebuild,v 1.1 2010/11/08 14:40:05 pva Exp $
+
+EAPI="3"
+
+LANGS="be bg en es fr hu pl ru sr uk"
+CMAKE_MIN_VERSION="2.6.0"
+inherit qt4-r2 cmake-utils
+
+DESCRIPTION="Qt4 based client for DirectConnect and ADC protocols, based on DC++ library"
+HOMEPAGE="http://eiskaltdc.googlecode.com/"
+SRC_URI="http://${PN/pp/}.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +emoticons examples -gnome -gtk -javascript kde libnotify lua +qt4 sounds spell upnp"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/openssl-0.9.8
+ virtual/libiconv
+ sys-devel/gettext
+ lua? ( >=dev-lang/lua-5.1 )
+ upnp? ( net-libs/miniupnpc )
+ gtk? (
+ x11-libs/pango
+ >=x11-libs/gtk+-2.10:2
+ >=dev-libs/glib-2.10:2
+ >=gnome-base/libglade-2.4:2.0
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ gnome? ( gnome-base/libgnome )
+ )
+ qt4? (
+ >=x11-libs/qt-gui-4.4.0:4[dbus?]
+ javascript? (
+ x11-libs/qt-script
+ x11-libs/qtscriptgenerator
+ )
+ kde? (
+ kde-base/oxygen-icons
+ >=x11-libs/qt-gui-4.6.0:4
+ )
+ spell? ( app-text/aspell )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-libs/boost-1.34.1
+ dev-util/pkgconfig
+"
+DOCS="AUTHORS ChangeLog.txt"
+
+src_configure() {
+ # linguas
+ local langs x
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+=" ${x}"
+ done
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ "$(cmake-utils_use lua LUA_SCRIPT)"
+ "$(cmake-utils_use dbus DBUS_NOTIFY)"
+ "$(cmake-utils_use javascript USE_JS)"
+ "$(cmake-utils_use kde USE_ICON_THEME)"
+ "$(cmake-utils_use spell USE_ASPELL)"
+ "$(cmake-utils_use qt4 USE_QT)"
+ "$(cmake-utils_use upnp USE_MINIUPNP)"
+ -DLOCAL_MINIUPNP="0"
+ "$(cmake-utils_use gtk USE_GTK)"
+ "$(cmake-utils_use gnome USE_LIBGNOME2)"
+ "$(cmake-utils_use libnotify USE_LIBNOTIFY)"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
+ "$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use sounds WITH_SOUNDS)"
+ -Dlinguas="${langs}"
+ )
+ cmake-utils_src_configure
+}