summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-20 12:11:37 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-20 12:11:37 +0000
commita599cf664858e435396cb3c7c02a778c7bd3c19c (patch)
tree4544d651de25535e13c3aad190b3454fefbfecbd /net-p2p/mktorrent/mktorrent-1.0.ebuild
parentVersion bump to the latest. (diff)
downloadgentoo-2-a599cf664858e435396cb3c7c02a778c7bd3c19c.tar.gz
gentoo-2-a599cf664858e435396cb3c7c02a778c7bd3c19c.tar.bz2
gentoo-2-a599cf664858e435396cb3c7c02a778c7bd3c19c.zip
Default to largefile support, #358279
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/mktorrent/mktorrent-1.0.ebuild')
-rw-r--r--net-p2p/mktorrent/mktorrent-1.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-p2p/mktorrent/mktorrent-1.0.ebuild b/net-p2p/mktorrent/mktorrent-1.0.ebuild
index f9403b72468a..2e1070a2a7e7 100644
--- a/net-p2p/mktorrent/mktorrent-1.0.ebuild
+++ b/net-p2p/mktorrent/mktorrent-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-1.0.ebuild,v 1.5 2010/10/10 18:44:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mktorrent/mktorrent-1.0.ebuild,v 1.6 2011/05/20 12:11:37 jlec Exp $
EAPI=1
inherit toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="threads +largefile +ssl debug"
+IUSE="threads +ssl debug"
RDEPEND="ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}"
@@ -20,8 +20,8 @@ DEPEND="${RDEPEND}"
src_compile() {
tc-export CC
MAKEPARAM="USE_LONG_OPTIONS=1"
+ MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
- use largefile && MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
use ssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"