summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Walls <malverian@gentoo.org>2003-03-24 23:26:50 +0000
committerPhilip Walls <malverian@gentoo.org>2003-03-24 23:26:50 +0000
commit3feea97555929de74a60342be02e41835e03be4a (patch)
tree88718f5a1d3ea299cdec0b2cf45e76669354cfe5 /net-p2p/pysoulseek
parentsimplify modutils dependency so that a virtual can satisfy it (diff)
downloadgentoo-2-3feea97555929de74a60342be02e41835e03be4a.tar.gz
gentoo-2-3feea97555929de74a60342be02e41835e03be4a.tar.bz2
gentoo-2-3feea97555929de74a60342be02e41835e03be4a.zip
version bump w/ new hyriand patch
Diffstat (limited to 'net-p2p/pysoulseek')
-rw-r--r--net-p2p/pysoulseek/ChangeLog10
-rw-r--r--net-p2p/pysoulseek/files/digest-pysoulseek-1.0.3.12.72
-rw-r--r--net-p2p/pysoulseek/pysoulseek-1.0.3.12.7.ebuild42
3 files changed, 53 insertions, 1 deletions
diff --git a/net-p2p/pysoulseek/ChangeLog b/net-p2p/pysoulseek/ChangeLog
index 819714d40905..c194452ad726 100644
--- a/net-p2p/pysoulseek/ChangeLog
+++ b/net-p2p/pysoulseek/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/pysoulseek
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/pysoulseek/ChangeLog,v 1.11 2003/03/16 17:31:00 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/pysoulseek/ChangeLog,v 1.12 2003/03/24 23:26:50 malverian Exp $
+
+*pysoulseek-1.0.3.12.7 (24 Mar 2003)
+
+ 24 Mar 2003; Philip Walls <malverian@gentoo.org>
+ pysoulseek-1.0.3.12.7.ebuild, files/digest-pysoulseek-1.0.3.12.7 :
+ Version bump. ebuild also now automatically fetches and hyriand patch
+ based on package version after the pysoulseek-MAJOR.MINOR.REVISION. In
+ this case, the hyriand-12.7 patch is downloaded and patched automatically.
*pysoulseek-1.0.0-r1 (16 Mar 2003)
diff --git a/net-p2p/pysoulseek/files/digest-pysoulseek-1.0.3.12.7 b/net-p2p/pysoulseek/files/digest-pysoulseek-1.0.3.12.7
new file mode 100644
index 000000000000..09302450d3a9
--- /dev/null
+++ b/net-p2p/pysoulseek/files/digest-pysoulseek-1.0.3.12.7
@@ -0,0 +1,2 @@
+MD5 7afb37f9696e284420b66f384b33e49e pyslsk-1.0.3.tar.gz 90807
+MD5 2b5cd10b5a9d42a5eb8d81340b22555e pyslsk-1.0.3-hyriand-12.7.patch 96963
diff --git a/net-p2p/pysoulseek/pysoulseek-1.0.3.12.7.ebuild b/net-p2p/pysoulseek/pysoulseek-1.0.3.12.7.ebuild
new file mode 100644
index 000000000000..30af389f63fa
--- /dev/null
+++ b/net-p2p/pysoulseek/pysoulseek-1.0.3.12.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/pysoulseek/pysoulseek-1.0.3.12.7.ebuild,v 1.1 2003/03/24 23:26:50 malverian Exp $
+
+IUSE="oggvorbis"
+
+inherit eutils
+
+MY_PN="${PN/soulseek/slsk}"
+
+# Main pysoulseek Package-Version
+MY_P=${MY_PN}-${PV%.*.*}
+
+# Hyriand Patch Version
+MY_HV=${PV#*.*.*.}
+
+DESCRIPTION="client for SoulSeek filesharing"
+HOMEPAGE="http://www.sensi.org/~ak/pyslsk/"
+SRC_URI="http://www.sensi.org/~ak/pyslsk/${MY_P}.tar.gz http://thegraveyard.org/pyslsk/${MY_P}-hyriand-${MY_HV}.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+
+DEPEND=">=dev-lang/python-2.1
+ >=dev-python/wxPython-2.4.0.1
+ ~x11-libs/wxGTK-2.4.0
+ oggvorbis? ( media-libs/pyvorbis media-libs/pyogg )"
+
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ epatch ${DISTDIR}/${MY_P}-hyriand-${MY_HV}.patch
+ python setup.py build || die "compile failed"
+}
+
+src_install() {
+ python setup.py install --prefix=/usr --root=${D} || die "install failed"
+ dodoc CHANGELOG KNOWN_BUGS MAINTAINERS MANIFEST PKG-INFO README TODO VERSION
+}