summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-17 19:15:20 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-17 19:15:20 +0000
commitd133d4bcbe31946d36321a10e6add679e6dffadf (patch)
tree87355e6802b9fc16952a84f8152eea5d53cbeeee /net-p2p/qbittorrent
parentVersion bump, remove old. (diff)
downloadgentoo-2-d133d4bcbe31946d36321a10e6add679e6dffadf.tar.gz
gentoo-2-d133d4bcbe31946d36321a10e6add679e6dffadf.tar.bz2
gentoo-2-d133d4bcbe31946d36321a10e6add679e6dffadf.zip
Update live ebuild. Implement Qt5 support (bug #515692).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/metadata.xml3
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild53
3 files changed, 48 insertions, 16 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 05234148eb7e..327d9a9b2475 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/qbittorrent
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.237 2014/12/05 17:16:42 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.238 2015/02/17 19:15:20 yngwin Exp $
+
+ 17 Feb 2015; Ben de Groot <yngwin@gentoo.org> metadata.xml,
+ qbittorrent-9999.ebuild:
+ Update live ebuild. Implement Qt5 support (bug #515692).
*qbittorrent-3.0.11-r2 (05 Dec 2014)
diff --git a/net-p2p/qbittorrent/metadata.xml b/net-p2p/qbittorrent/metadata.xml
index 9eec7fece0f5..0c56b695e958 100644
--- a/net-p2p/qbittorrent/metadata.xml
+++ b/net-p2p/qbittorrent/metadata.xml
@@ -7,4 +7,7 @@
<email>hwoarang@gentoo.org</email>
<name>Markos Chandras</name>
</maintainer>
+ <use>
+ <flag name='webui'>Enable the Web UI</flag>
+ </use>
</pkgmetadata>
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 998208764009..892e8ba5aa18 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,30 +1,48 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.18 2014/10/19 00:23:31 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.19 2015/02/17 19:15:20 yngwin Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
-inherit python-r1 qt4-r2 git-r3
+inherit python-r1 qmake-utils
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
-EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+MY_P=${P/_}
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-
-IUSE="dbus debug geoip +X"
+IUSE="+dbus debug geoip +qt4 qt5 webui +X"
+REQUIRED_USE="^^ ( qt4 qt5 )
+ dbus? ( X )
+ geoip? ( X )"
# geoip and python are runtime deps only (see INSTALL file)
CDEPEND="
dev-libs/boost:=
- dev-qt/qtcore:4
- >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[X?]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[X?,qt4?,qt5?]
>=net-libs/rb_libtorrent-0.16.17
- dbus? ( dev-qt/qtdbus:4 )
- X? ( dev-qt/qtgui:4 )
+ sys-libs/zlib
+ qt4? ( dev-qt/qtcore:4
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+ )
+ qt5? ( dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ X? ( dev-qt/qtgui:4
+ dev-qt/qtwidgets:5 )
+ )
"
DEPEND="${CDEPEND}
virtual/pkgconfig
@@ -34,6 +52,7 @@ RDEPEND="${CDEPEND}
geoip? ( dev-libs/geoip )
"
+S=${WORKDIR}/${MY_P}
DOCS=(AUTHORS Changelog README.md TODO)
src_configure() {
@@ -41,15 +60,21 @@ src_configure() {
local myconf=(
./configure
--prefix="${EPREFIX}/usr"
- --with-libboost-inc="${EPREFIX}/usr/include/boost"
--with-qtsingleapplication=system
$(use dbus || echo --disable-qt-dbus)
$(use debug && echo --enable-debug)
$(use geoip || echo --disable-geoip-database)
+ $(use qt5 && echo --with-qt5)
+ $(use webui || echo --disable-webui)
$(use X || echo --disable-gui)
)
echo "${myconf[@]}"
"${myconf[@]}" || die "configure failed"
- eqmake4
+ use qt4 && eqmake4
+ use qt5 && eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
}