summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-08-02 13:31:39 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-08-02 13:31:39 +0000
commitfcfec90aa225daab6f00c59c59fcbf62c51b1758 (patch)
tree237a062eb90ef35a0cb79193994e4c1659955094 /net-p2p/tribler
parentDrop old versions. (diff)
downloadgentoo-2-fcfec90aa225daab6f00c59c59fcbf62c51b1758.tar.gz
gentoo-2-fcfec90aa225daab6f00c59c59fcbf62c51b1758.tar.bz2
gentoo-2-fcfec90aa225daab6f00c59c59fcbf62c51b1758.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p/tribler')
-rw-r--r--net-p2p/tribler/ChangeLog8
-rw-r--r--net-p2p/tribler/files/tribler-6.2.0-fix-desktop.patch12
-rw-r--r--net-p2p/tribler/tribler-6.2.0.ebuild82
3 files changed, 101 insertions, 1 deletions
diff --git a/net-p2p/tribler/ChangeLog b/net-p2p/tribler/ChangeLog
index 10bb764ba039..b39a3fbe592f 100644
--- a/net-p2p/tribler/ChangeLog
+++ b/net-p2p/tribler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/tribler
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.47 2013/05/10 01:32:31 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.48 2013/08/02 13:31:39 blueness Exp $
+
+*tribler-6.2.0 (02 Aug 2013)
+
+ 02 Aug 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/tribler-6.2.0-fix-desktop.patch, +tribler-6.2.0.ebuild:
+ Version bump
*tribler-6.1.0 (10 May 2013)
diff --git a/net-p2p/tribler/files/tribler-6.2.0-fix-desktop.patch b/net-p2p/tribler/files/tribler-6.2.0-fix-desktop.patch
new file mode 100644
index 000000000000..23689bf2fb4d
--- /dev/null
+++ b/net-p2p/tribler/files/tribler-6.2.0-fix-desktop.patch
@@ -0,0 +1,12 @@
+diff -Naur usr.orig/share/applications/tribler.desktop usr/share/applications/tribler.desktop
+--- usr.orig/share/applications/tribler.desktop 2013-05-09 20:47:46.000000000 -0400
++++ usr/share/applications/tribler.desktop 2013-05-09 20:49:03.000000000 -0400
+@@ -5,5 +5,5 @@
+ Icon=tribler
+ Terminal=false
+ Type=Application
+-Categories=Application;Network;P2P
+-MimeType=x-scheme-handler/ppsp;x-scheme-handler/tswift;x-scheme-handler/magnet
+\ No newline at end of file
++Categories=Network;P2P;
++MimeType=x-scheme-handler/ppsp;x-scheme-handler/tswift;x-scheme-handler/magnet;
diff --git a/net-p2p/tribler/tribler-6.2.0.ebuild b/net-p2p/tribler/tribler-6.2.0.ebuild
new file mode 100644
index 000000000000..891c867147cd
--- /dev/null
+++ b/net-p2p/tribler/tribler-6.2.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/tribler-6.2.0.ebuild,v 1.1 2013/08/02 13:31:39 blueness Exp $
+
+EAPI="5"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+
+inherit eutils python unpacker
+
+DESCRIPTION="Bittorrent client that does not require a website to discover content"
+HOMEPAGE="http://www.tribler.org/"
+SRC_URI="
+ http://dl.tribler.org/tribler_6.2.0ubuntu1_all.deb
+ x86? ( http://dl.tribler.org/tribler-swift_6.2.0ubuntu1_i386.deb )
+ amd64? ( http://dl.tribler.org/tribler-swift_6.2.0ubuntu1_amd64.deb )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vlc"
+
+RDEPEND="
+ dev-python/apsw
+ dev-python/feedparser
+ dev-python/m2crypto
+ dev-python/netifaces
+ dev-libs/openssl
+ dev-python/wxpython
+ net-libs/rb_libtorrent
+ vlc? (
+ media-video/vlc
+ media-video/ffmpeg
+ )"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/lib/tribler/swift"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-log2homedir.patch"
+ epatch "${FILESDIR}/${P}-fix-desktop.patch"
+
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ #Remove a dead sym link
+ rm usr/share/tribler/Tribler/Main/webUI/static/mootools.js
+
+ #Rename the doc dir properly
+ mv usr/share/doc/${PN} usr/share/doc/${P}
+
+ #Move the readme to the doc dir
+ mv usr/share/${PN}/Tribler/readme.txt usr/share/doc/${P}
+
+ #Remove the licenses scattered throughout
+ rm usr/share/doc/${P}/copyright
+ rm usr/share/${PN}/Tribler/*.txt
+ rm usr/share/${PN}/Tribler/Core/DecentralizedTracking/pymdht/LGPL-2.1.txt
+
+ #Copy the rest over
+ cp -pPR usr/ "${ED}"/
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}"usr/share/${PN}
+}