summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2015-03-14 09:39:07 +0000
committerRyan Hill <rhill@gentoo.org>2015-03-14 09:39:07 +0000
commit04da8ec80092030bbeafac2b563ccae9ab6b2dc2 (patch)
tree74a88bbd54d27d41f679d03a176f8c26d4582c4d /net-p2p/vuze
parentMove tools from sbin to bin so we can start supporting unprivileged containers (diff)
downloadgentoo-2-04da8ec80092030bbeafac2b563ccae9ab6b2dc2.tar.gz
gentoo-2-04da8ec80092030bbeafac2b563ccae9ab6b2dc2.tar.bz2
gentoo-2-04da8ec80092030bbeafac2b563ccae9ab6b2dc2.zip
Long overdue version bump. Drop cache size patch as requested by Bobby Kent.
Strip DOS line endings from source to stop upstream from breaking our patches every release. Signed-off-by: Ryan Hill <rhill@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'net-p2p/vuze')
-rw-r--r--net-p2p/vuze/ChangeLog15
-rw-r--r--net-p2p/vuze/files/build.xml136
-rw-r--r--net-p2p/vuze/files/vuze-5.3.0.0-cache-size.patch11
-rw-r--r--net-p2p/vuze/files/vuze-5.3.0.0-java5.patch16
-rw-r--r--net-p2p/vuze/files/vuze-5.3.0.0-remove-classpath.patch14
-rw-r--r--net-p2p/vuze/files/vuze-5.6.0.0-commons-lang-entities.patch51
-rw-r--r--net-p2p/vuze/files/vuze-5.6.0.0-invalid-characters.patch26
-rw-r--r--net-p2p/vuze/vuze-5.3.0.0.ebuild12
-rw-r--r--net-p2p/vuze/vuze-5.6.0.0.ebuild145
9 files changed, 325 insertions, 101 deletions
diff --git a/net-p2p/vuze/ChangeLog b/net-p2p/vuze/ChangeLog
index ae7c92506984..9e9f839f4d97 100644
--- a/net-p2p/vuze/ChangeLog
+++ b/net-p2p/vuze/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-p2p/vuze
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/ChangeLog,v 1.63 2014/08/09 12:10:15 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/ChangeLog,v 1.64 2015/03/14 09:39:07 rhill Exp $
+
+*vuze-5.6.0.0 (14 Mar 2015)
+
+ 14 Mar 2015; Ryan Hill <rhill@gentoo.org> vuze-5.3.0.0.ebuild,
+ +vuze-5.6.0.0.ebuild, -files/vuze-5.3.0.0-cache-size.patch,
+ files/vuze-5.3.0.0-java5.patch, files/vuze-5.3.0.0-remove-classpath.patch,
+ +files/vuze-5.6.0.0-commons-lang-entities.patch,
+ +files/vuze-5.6.0.0-invalid-characters.patch, files/build.xml:
+ Long overdue version bump. Drop cache size patch as requested by Bobby Kent.
+ Strip DOS line endings from source to stop upstream from breaking our patches
+ every release.
09 Aug 2014; Agostino Sarubbo <ago@gentoo.org> vuze-4.8.1.2-r1.ebuild:
Stable for ppc, wrt bug #432146
diff --git a/net-p2p/vuze/files/build.xml b/net-p2p/vuze/files/build.xml
index ee83cf995f63..7b060c14b2f2 100644
--- a/net-p2p/vuze/files/build.xml
+++ b/net-p2p/vuze/files/build.xml
@@ -1,68 +1,68 @@
-<?xml version="1.0"?>
-
-<!--
-
-NOTE: You may need to set the ANT_OPTS="-Xmx512m" env prop in order to compile this project successfully.
-
--->
-
-
-<project default="jar" name="Azureus" basedir=".">
-
- <property name="root.dir" value="." /> <!-- REMINDER: this needs to be "." for public source -->
- <property name="libs.dir" value="build/libs" />
- <property name="dist.dir" value="dist" />
-
- <property name="generic.excludes" value="**/*.jar **/*.txt **/*.jardesc **/.classpath **/.project **/aereg.lib **/aereg.dll" />
- <property name="dist.jar.excludes" value="${generic.excludes} **/*.java " />
- <!-- <property name="dist.source.excludes" value="${generic.excludes} **/*.class" /> -->
-
-
- <target name="init" >
- <echo message="Building Azureus2.jar..." />
-
- <tstamp/>
-
- <!-- <condition property="libs.dir" value="build/libs">
- <not> <isset property="libs.dir" /> </not>
- </condition> -->
-
- <mkdir dir="${root.dir}/${dist.dir}" />
- </target>
-
-
- <target name="compile" depends="init" >
- <path id="libs.classpath">
- <fileset dir="${root.dir}/${libs.dir}" includes="**/*.jar" />
- </path>
-
- <javac srcdir="${root.dir}" destdir="${root.dir}" nowarn="yes" source="1.4" target="1.4" includeAntRuntime="no" debug="true" debuglevel="lines,vars,source" >
- <classpath refid="libs.classpath" />
- </javac>
- </target>
-
-
- <target name="jar" depends="compile" >
- <jar destfile="${root.dir}/${dist.dir}/Azureus2.jar" basedir="${root.dir}" excludes="${dist.jar.excludes}" >
- <manifest>
- <attribute name="Main-Class" value="org.gudy.azureus2.ui.common.Main" />
- <attribute name="Class-Path" value="Azureus2.jar apple-extensions.jar commons-cli.jar log4j.jar swt.jar swt-win32.jar swt-osx.jar" />
- </manifest>
- </jar>
-
- <!-- <zip destfile="${dist.dir}/Azureus2_source.zip" basedir="." excludes="${dist.source.excludes}" /> -->
-
- </target>
-
-
- <target name="clean" >
- <delete quiet="true" >
- <fileset dir="${root.dir}/com" includes="**/*.class"/>
- <fileset dir="${root.dir}/org" includes="**/*.class"/>
- </delete>
-
- <delete dir="${root.dir}/${dist.dir}" />
- </target>
-
-</project>
-
+<?xml version="1.0"?>
+
+<!--
+
+NOTE: You may need to set the ANT_OPTS="-Xmx512m" env prop in order to compile this project successfully.
+
+-->
+
+
+<project default="jar" name="Azureus" basedir=".">
+
+ <property name="root.dir" value="." /> <!-- REMINDER: this needs to be "." for public source -->
+ <property name="libs.dir" value="build/libs" />
+ <property name="dist.dir" value="dist" />
+
+ <property name="generic.excludes" value="**/*.jar **/*.txt **/*.jardesc **/.classpath **/.project **/aereg.lib **/aereg.dll" />
+ <property name="dist.jar.excludes" value="${generic.excludes} **/*.java " />
+ <!-- <property name="dist.source.excludes" value="${generic.excludes} **/*.class" /> -->
+
+
+ <target name="init" >
+ <echo message="Building Azureus2.jar..." />
+
+ <tstamp/>
+
+ <!-- <condition property="libs.dir" value="build/libs">
+ <not> <isset property="libs.dir" /> </not>
+ </condition> -->
+
+ <mkdir dir="${root.dir}/${dist.dir}" />
+ </target>
+
+
+ <target name="compile" depends="init" >
+ <path id="libs.classpath">
+ <fileset dir="${root.dir}/${libs.dir}" includes="**/*.jar" />
+ </path>
+
+ <javac srcdir="${root.dir}" destdir="${root.dir}" nowarn="yes" source="1.4" target="1.4" includeAntRuntime="no" debug="true" debuglevel="lines,vars,source" >
+ <classpath refid="libs.classpath" />
+ </javac>
+ </target>
+
+
+ <target name="jar" depends="compile" >
+ <jar destfile="${root.dir}/${dist.dir}/Azureus2.jar" basedir="${root.dir}" excludes="${dist.jar.excludes}" >
+ <manifest>
+ <attribute name="Main-Class" value="org.gudy.azureus2.ui.common.Main" />
+ <attribute name="Class-Path" value="Azureus2.jar apple-extensions.jar commons-cli.jar log4j.jar swt.jar swt-win32.jar swt-osx.jar" />
+ </manifest>
+ </jar>
+
+ <!-- <zip destfile="${dist.dir}/Azureus2_source.zip" basedir="." excludes="${dist.source.excludes}" /> -->
+
+ </target>
+
+
+ <target name="clean" >
+ <delete quiet="true" >
+ <fileset dir="${root.dir}/com" includes="**/*.class"/>
+ <fileset dir="${root.dir}/org" includes="**/*.class"/>
+ </delete>
+
+ <delete dir="${root.dir}/${dist.dir}" />
+ </target>
+
+</project>
+
diff --git a/net-p2p/vuze/files/vuze-5.3.0.0-cache-size.patch b/net-p2p/vuze/files/vuze-5.3.0.0-cache-size.patch
deleted file mode 100644
index 16f9ffa7374d..000000000000
--- a/net-p2p/vuze/files/vuze-5.3.0.0-cache-size.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/org/gudy/azureus2/core3/config/COConfigurationManager.java
-+++ b/org/gudy/azureus2/core3/config/COConfigurationManager.java
-@@ -52,7 +52,7 @@ COConfigurationManager
- public static final int CONFIG_CACHE_SIZE_MAX_MB;
-
- static{
-- long max_mem_bytes = Runtime.getRuntime().maxMemory();
-+ long max_mem_bytes = Math.min (Runtime.getRuntime().maxMemory(), 64*1024*1024);
- long mb_1 = 1*1024*1024;
- long mb_32 = 32*mb_1;
- int size = (int)(( max_mem_bytes - mb_32 )/mb_1);
diff --git a/net-p2p/vuze/files/vuze-5.3.0.0-java5.patch b/net-p2p/vuze/files/vuze-5.3.0.0-java5.patch
index 9b19015f3b36..b6d2a59c43a2 100644
--- a/net-p2p/vuze/files/vuze-5.3.0.0-java5.patch
+++ b/net-p2p/vuze/files/vuze-5.3.0.0-java5.patch
@@ -1,11 +1,11 @@
--- a/build.xml
+++ b/build.xml
@@ -36,7 +36,7 @@ NOTE: You may need to set the ANT_OPTS="-Xmx512m" env prop in order to compil
- <fileset dir="${root.dir}/${libs.dir}" includes="**/*.jar" />
- </path>
-
-- <javac srcdir="${root.dir}" destdir="${root.dir}" nowarn="yes" source="1.4" target="1.4" includeAntRuntime="no" debug="true" debuglevel="lines,vars,source" >
-+ <javac encoding="8859_1" srcdir="${root.dir}" destdir="${root.dir}" nowarn="yes" includeAntRuntime="no" debug="true" debuglevel="lines,vars,source" >
- <classpath refid="libs.classpath" />
- </javac>
- </target>
+ <fileset dir="${root.dir}/${libs.dir}" includes="**/*.jar" />
+ </path>
+
+- <javac srcdir="${root.dir}" destdir="${root.dir}" nowarn="yes" source="1.4" target="1.4" includeAntRuntime="no" debug="true" debuglevel="lines,vars,source" >
++ <javac encoding="8859_1" srcdir="${root.dir}" destdir="${root.dir}" nowarn="yes" includeAntRuntime="no" debug="true" debuglevel="lines,vars,source" >
+ <classpath refid="libs.classpath" />
+ </javac>
+ </target>
diff --git a/net-p2p/vuze/files/vuze-5.3.0.0-remove-classpath.patch b/net-p2p/vuze/files/vuze-5.3.0.0-remove-classpath.patch
index 607b84a46d51..290b902203a8 100644
--- a/net-p2p/vuze/files/vuze-5.3.0.0-remove-classpath.patch
+++ b/net-p2p/vuze/files/vuze-5.3.0.0-remove-classpath.patch
@@ -1,10 +1,10 @@
--- a/build.xml
+++ b/build.xml
@@ -46,7 +46,6 @@ NOTE: You may need to set the ANT_OPTS="-Xmx512m" env prop in order to compil
- <jar destfile="${root.dir}/${dist.dir}/Azureus2.jar" basedir="${root.dir}" excludes="${dist.jar.excludes}" >
- <manifest>
- <attribute name="Main-Class" value="org.gudy.azureus2.ui.common.Main" />
-- <attribute name="Class-Path" value="Azureus2.jar apple-extensions.jar commons-cli.jar log4j.jar swt.jar swt-win32.jar swt-osx.jar" />
- </manifest>
- </jar>
-
+ <jar destfile="${root.dir}/${dist.dir}/Azureus2.jar" basedir="${root.dir}" excludes="${dist.jar.excludes}" >
+ <manifest>
+ <attribute name="Main-Class" value="org.gudy.azureus2.ui.common.Main" />
+- <attribute name="Class-Path" value="Azureus2.jar apple-extensions.jar commons-cli.jar log4j.jar swt.jar swt-win32.jar swt-osx.jar" />
+ </manifest>
+ </jar>
+
diff --git a/net-p2p/vuze/files/vuze-5.6.0.0-commons-lang-entities.patch b/net-p2p/vuze/files/vuze-5.6.0.0-commons-lang-entities.patch
new file mode 100644
index 000000000000..c58d475995ee
--- /dev/null
+++ b/net-p2p/vuze/files/vuze-5.6.0.0-commons-lang-entities.patch
@@ -0,0 +1,51 @@
+diff --git a/org/gudy/azureus2/core3/util/AddressUtils.java b/org/gudy/azureus2/core3/util/AddressUtils.java
+index 6691951..38f14ee 100644
+--- a/org/gudy/azureus2/core3/util/AddressUtils.java
++++ b/org/gudy/azureus2/core3/util/AddressUtils.java
+@@ -494,11 +494,11 @@ AddressUtils
+ try{
+ // unfortunately we have an incompatible base64 standard in i2p, they replaced / with ~ and + with -
+
+- char[] encoded = to_decode.toCharArray();
++ byte[] encoded = to_decode.getBytes();
+
+ for ( int i=0;i<encoded.length;i++){
+
+- char c = encoded[i];
++ byte c = encoded[i];
+
+ if ( c == '~' ){
+ encoded[i] = '/';
+diff --git a/org/gudy/azureus2/pluginsimpl/local/utils/xml/simpleparser/SimpleXMLParserDocumentImpl.java b/org/gudy/azureus2/pluginsimpl/local/utils/xml/simpleparser/SimpleXMLParserDocumentImpl.java
+index a67a8a2..da4a46c 100644
+--- a/org/gudy/azureus2/pluginsimpl/local/utils/xml/simpleparser/SimpleXMLParserDocumentImpl.java
++++ b/org/gudy/azureus2/pluginsimpl/local/utils/xml/simpleparser/SimpleXMLParserDocumentImpl.java
+@@ -25,7 +25,7 @@ package org.gudy.azureus2.pluginsimpl.local.utils.xml.simpleparser;
+ import javax.xml.parsers.*;
+
+ import org.xml.sax.*;
+-import org.apache.commons.lang.Entities;
++import org.apache.commons.lang.StringEscapeUtils;
+ import org.gudy.azureus2.core3.util.AENetworkClassifier;
+ import org.gudy.azureus2.core3.util.Constants;
+ import org.gudy.azureus2.core3.util.Debug;
+@@ -656,17 +656,8 @@ SimpleXMLParserDocumentImpl
+ replacement = new String( buffer, 0, buffer_pos );
+
+ }else{
+-
+- int num = Entities.HTML40.entityValue( ref );
+-
+- if ( num != -1 ){
+-
+- replacement = "&#" + num + ";";
+-
+- }else{
+-
+- replacement = new String( buffer, 0, buffer_pos );
+- }
++
++ replacement = StringEscapeUtils.escapeHtml(ref);
+ }
+
+ char[] chars = replacement.toCharArray();
diff --git a/net-p2p/vuze/files/vuze-5.6.0.0-invalid-characters.patch b/net-p2p/vuze/files/vuze-5.6.0.0-invalid-characters.patch
new file mode 100644
index 000000000000..ee3b07047eca
--- /dev/null
+++ b/net-p2p/vuze/files/vuze-5.6.0.0-invalid-characters.patch
@@ -0,0 +1,26 @@
+diff --git a/com/aelitis/azureus/core/metasearch/impl/DateParserRegex.java b/com/aelitis/azureus/core/metasearch/impl/DateParserRegex.java
+index 34e898c..2e5bcaa 100644
+--- a/com/aelitis/azureus/core/metasearch/impl/DateParserRegex.java
++++ b/com/aelitis/azureus/core/metasearch/impl/DateParserRegex.java
+@@ -49,17 +49,17 @@ public class DateParserRegex extends DateParser {
+
+ private static final String[] MONTHS_LIST = new String[] {
+ " january janvier enero januar",
+- " february fevrier f�vrier febrero februar",
+- " march mars marzo marz marz m�rz" ,
++ " february fevrier febrero februar",
++ " march mars marzo marz marz",
+ " april avril abril april ",
+ " may mai mayo mai",
+ " june juin junio juni",
+ " july juillet julio juli",
+- " august aout ao�t agosto august",
++ " august aout agosto august",
+ " september septembre septiembre september",
+ " october octobre octubre oktober",
+ " november novembre noviembre november",
+- " december decembre d�cembre diciembre dezember"};
++ " december decembre diciembre dezember"};
+
+ public DateParserRegex() {
+ this("GMT-7",true,null);
diff --git a/net-p2p/vuze/vuze-5.3.0.0.ebuild b/net-p2p/vuze/vuze-5.3.0.0.ebuild
index e38825ce8b2c..26b3970ffdc2 100644
--- a/net-p2p/vuze/vuze-5.3.0.0.ebuild
+++ b/net-p2p/vuze/vuze-5.3.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-5.3.0.0.ebuild,v 1.1 2014/03/09 07:38:47 rhill Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-5.3.0.0.ebuild,v 1.2 2015/03/14 09:39:07 rhill Exp $
EAPI="5"
@@ -28,12 +28,12 @@ RDEPEND="
dev-java/json-simple
dev-java/log4j
dev-java/swt:3.8[cairo]
- >=virtual/jre-1.6"
+ >=virtual/jre-1.6:*"
DEPEND="${RDEPEND}
app-arch/unzip
dev-util/desktop-file-utils
- >=virtual/jdk-1.6"
+ >=virtual/jdk-1.6:*"
PDEPEND="~net-p2p/vuze-coreplugins-${PV}"
@@ -55,7 +55,9 @@ src_unpack() {
}
java_prepare() {
- epatch "${FILESDIR}"/${P}-cache-size.patch
+ # upstream likes randomly changing a subset of files to CRLF every release
+ edos2unix $(find "${S}" -type f -name "*.java")
+
epatch "${FILESDIR}"/${P}-java5.patch
epatch "${FILESDIR}"/${P}-remove-classpath.patch
epatch "${FILESDIR}"/${P}-disable-shared-plugins.patch
diff --git a/net-p2p/vuze/vuze-5.6.0.0.ebuild b/net-p2p/vuze/vuze-5.6.0.0.ebuild
new file mode 100644
index 000000000000..5f21ee825db6
--- /dev/null
+++ b/net-p2p/vuze/vuze-5.6.0.0.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-5.6.0.0.ebuild,v 1.1 2015/03/14 09:39:07 rhill Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2 versionator
+
+MY_PV=$(replace_all_version_separators "")
+MY_SRC="Vuze_${MY_PV}"
+
+DESCRIPTION="BitTorrent client in Java, formerly called Azureus"
+HOMEPAGE="http://www.vuze.com/"
+SRC_URI="mirror://sourceforge/azureus/${PN}/${MY_SRC}/${MY_SRC}_source.zip"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# bundles parts of http://www.programmers-friend.org/
+# bundles bcprov - 1.37 required but not in the tree
+RDEPEND="
+ dev-java/commons-cli
+ dev-java/commons-lang:2.1
+ dev-java/json-simple
+ dev-java/log4j
+ dev-java/swt:3.8[cairo]
+ >=virtual/jre-1.6:*"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/desktop-file-utils
+ >=virtual/jdk-1.6:*"
+
+PDEPEND="~net-p2p/vuze-coreplugins-${PV}"
+
+pkg_pretend() {
+ if ! has_version dev-java/swt:3.8[webkit]; then
+ echo
+ ewarn "dev-java/swt:3.8 was built without webkit support."
+ ewarn "Web features such as Vuze HD Network will be disabled."
+ fi
+}
+
+src_unpack() {
+ mkdir -p "${S}" && cd "${S}"
+ unpack ${A}
+
+ # build.xml disappeared from 4.4.0.0 although it was there in 4.3.1.4
+ [[ -f build.xml ]] && die "upstream has build.xml again, don't overwrite"
+ cp "${FILESDIR}"/build.xml "${S}" || die "failed to copy build.xml"
+}
+
+java_prepare() {
+ # upstream likes randomly changing a subset of files to CRLF every release
+ edos2unix $(find "${S}" -type f -name "*.java")
+
+ epatch "${FILESDIR}"/${PN}-5.3.0.0-java5.patch
+ epatch "${FILESDIR}"/${PN}-5.3.0.0-remove-classpath.patch
+ epatch "${FILESDIR}"/${PN}-5.3.0.0-disable-shared-plugins.patch
+ epatch "${FILESDIR}"/${PN}-5.3.0.0-disable-osx.patch
+ epatch "${FILESDIR}"/${PN}-5.3.0.0-disable-updaters.patch
+ epatch "${FILESDIR}"/${PN}-5.3.0.0-unbundle-commons.patch
+ epatch "${FILESDIR}"/${PN}-5.3.0.0-unbundle-json.patch
+ epatch "${FILESDIR}"/${PN}-5.6.0.0-commons-lang-entities.patch
+ epatch "${FILESDIR}"/${PN}-5.6.0.0-invalid-characters.patch
+# epatch "${FILESDIR}"/${P}-use-jdk-cipher-only.patch # bcprov
+
+ # OSX / Windows
+ rm "${S}"/org/gudy/azureus2/ui/swt/osx/CarbonUIEnhancer.java
+ rm "${S}"/org/gudy/azureus2/ui/swt/osx/Start.java
+ rm "${S}"/org/gudy/azureus2/ui/swt/win32/Win32UIEnhancer.java
+
+ # Tree2 file does not compile on linux
+ rm -rf "${S}"/org/eclipse || die
+ # Bundled apache
+ rm -rf "${S}"/org/apache || die
+ # Bundled json
+ rm -rf "${S}"/org/json || die
+ # Bundled bcprov
+ # currently disabled - requires bcprov 1.37
+ #rm -rf "${S}"/org/bouncycastle || die
+
+ rm -rf "${S}"/org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
+ mkdir -p "${S}"/build/libs || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="swt-3.8,json-simple,log4j,commons-cli-1 commons-lang-2.1"
+
+src_compile() {
+ local mem
+ use amd64 && mem="320"
+ use x86 && mem="192"
+ use ppc && mem="192"
+ use ppc64 && mem="256"
+ use sparc && mem="320"
+ export ANT_OPTS="-Xmx${mem}m"
+ java-pkg-2_src_compile
+
+ # bug #302058 - build.xml excludes .txt but upstream jar has it...
+ jar uf dist/Azureus2.jar ChangeLog.txt || die
+}
+
+src_install() {
+ java-pkg_dojar dist/Azureus2.jar
+ dodoc ChangeLog.txt
+
+ java-pkg_dolauncher "${PN}" \
+ --main org.gudy.azureus2.ui.common.Main -pre "${FILESDIR}/${PN}-4.1.0.0-pre" \
+ --java_args '-Dazureus.install.path=/usr/share/vuze/ ${JAVA_OPTIONS}' \
+ --pkg_args '--ui=${UI}'
+ dosym vuze /usr/bin/azureus
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=204132
+ java-pkg_register-environment-variable MOZ_PLUGIN_PATH /usr/lib/nsbrowser/plugins
+
+ newicon "${S}"/org/gudy/azureus2/ui/icons/a32.png vuze.png
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ use source && java-pkg_dosrc "${S}"/{com,edu,org}
+}
+
+pkg_postinst() {
+ ewarn "Running Vuze as root is not supported and may result in untracked"
+ ewarn "updates to shared components and then collisions on updates"
+ echo
+ elog "Vuze was formerly called Azureus and many references to the old name remain."
+ elog
+ elog "After running Vuze for the first time, configuration options will be"
+ elog "placed in '~/.azureus/gentoo.config'."
+ elog
+ elog "If you need to change some startup options, you should modify this file"
+ elog "rather than the startup script. You can enable the console UI by"
+ elog "editing this config file."
+ echo
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}