summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-07-29 21:01:53 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-07-29 21:01:53 +0000
commit3064907e1c8174dbccc7d8d6e64c5a1b3486f555 (patch)
treeea476321d042a7446f1b5fb07fb39de98fa47267 /net-p2p
parentChangeLog (diff)
downloadgentoo-2-3064907e1c8174dbccc7d8d6e64c5a1b3486f555.tar.gz
gentoo-2-3064907e1c8174dbccc7d8d6e64c5a1b3486f555.tar.bz2
gentoo-2-3064907e1c8174dbccc7d8d6e64c5a1b3486f555.zip
Add missing patch
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-qt/ChangeLog6
-rw-r--r--net-p2p/bitcoin-qt/files/0.9.0-sys_leveldb.patch34
2 files changed, 39 insertions, 1 deletions
diff --git a/net-p2p/bitcoin-qt/ChangeLog b/net-p2p/bitcoin-qt/ChangeLog
index 6cc8304b6c46..50e71ea12138 100644
--- a/net-p2p/bitcoin-qt/ChangeLog
+++ b/net-p2p/bitcoin-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoin-qt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.80 2014/07/29 19:35:56 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.81 2014/07/29 21:01:53 blueness Exp $
+
+ 29 Jul 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/0.9.0-sys_leveldb.patch:
+ Add missing patch
29 Jul 2014; Anthony G. Basile <blueness@gentoo.org>
bitcoin-qt-0.9.2.1.ebuild:
diff --git a/net-p2p/bitcoin-qt/files/0.9.0-sys_leveldb.patch b/net-p2p/bitcoin-qt/files/0.9.0-sys_leveldb.patch
new file mode 100644
index 000000000000..60e9f2b20941
--- /dev/null
+++ b/net-p2p/bitcoin-qt/files/0.9.0-sys_leveldb.patch
@@ -0,0 +1,34 @@
+commit c38e0af3e021eb0b2aba846c77b06ca71de06b11 (personal-github/sys_leveldb, sys_leveldb)
+Author: Luke Dashjr <luke-jr+git@utopios.org>
+Date: Mon Sep 9 03:06:17 2013 +0000
+
+ configure: Add unsupported --with-system-leveldb configure flag
+
+diff --git a/configure.ac b/configure.ac
+index 3ed4549..5a5852d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -332,10 +332,22 @@ AC_TRY_COMPILE([#include <sys/socket.h>],
+ [ AC_MSG_RESULT(no)]
+ )
+
++dnl Check for leveldb, only if explicitly requested
+ LEVELDB_CPPFLAGS=
+ LIBLEVELDB=
+ LIBMEMENV=
+-AM_CONDITIONAL([EMBEDDED_LEVELDB],[true])
++AC_ARG_WITH([system-leveldb],
++ [AS_HELP_STRING([--with-system-leveldb],
++ [Build with system LevelDB (default is no; DANGEROUS; NOT SUPPORTED)])],
++ [system_leveldb=$withval],
++ [system_leveldb=no]
++)
++if test x$system_leveldb != xno; then
++ LEVELDB_CPPFLAGS=
++ LIBLEVELDB=-lleveldb
++ LIBMEMENV=-lmemenv
++fi
++AM_CONDITIONAL([EMBEDDED_LEVELDB],[test x$system_leveldb = xno])
+ AC_SUBST(LEVELDB_CPPFLAGS)
+ AC_SUBST(LIBLEVELDB)
+ AC_SUBST(LIBMEMENV)