summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-06-17 13:12:56 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-06-17 13:12:56 +0000
commit37ab6e38ac2f2ea173f2472f14420e597925b893 (patch)
tree7c98751c6a76daa8171a3b5542d6224978574291 /net-p2p
parentNew version, closes bug #22605 (diff)
downloadgentoo-2-37ab6e38ac2f2ea173f2472f14420e597925b893.tar.gz
gentoo-2-37ab6e38ac2f2ea173f2472f14420e597925b893.tar.bz2
gentoo-2-37ab6e38ac2f2ea173f2472f14420e597925b893.zip
New version, closes bug #22605
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey/ChangeLog7
-rw-r--r--net-p2p/mldonkey/Manifest4
-rw-r--r--net-p2p/mldonkey/files/digest-mldonkey-2.5.31
-rw-r--r--net-p2p/mldonkey/mldonkey-2.5.3.ebuild69
4 files changed, 78 insertions, 3 deletions
diff --git a/net-p2p/mldonkey/ChangeLog b/net-p2p/mldonkey/ChangeLog
index 5d3c2be9d1dd..caf92f1d01a4 100644
--- a/net-p2p/mldonkey/ChangeLog
+++ b/net-p2p/mldonkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/mldonkey
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.14 2003/06/02 18:51:41 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/ChangeLog,v 1.15 2003/06/17 13:12:43 caleb Exp $
+
+*mldonkey-2.5.3 (17 Jun 2003)
+
+ 17 Jun 2003; Caleb Tennis <caleb@gentoo.org> mldonkey-2.5.3.ebuild:
+ Version bump to 2.5-3. E-Build submitted by Gregorio Guidi (bug #22605).
*mldonkey-2.5-r1 (02 Jun 2003)
diff --git a/net-p2p/mldonkey/Manifest b/net-p2p/mldonkey/Manifest
index a16c8819827d..0998b831364c 100644
--- a/net-p2p/mldonkey/Manifest
+++ b/net-p2p/mldonkey/Manifest
@@ -1,8 +1,8 @@
MD5 c4d372a7573c6d362e92953779c20d1a mldonkey-2.5-r1.ebuild 1864
MD5 e5094a1dcf4979cf15ba78d435da09c7 mldonkey-2.02-r1.ebuild 2217
MD5 30816597e1a86056add83a1894e2c683 mldonkey-2.04_rc1.ebuild 1870
-MD5 324bf0ef714d81052caddfe88dbccb2a mldonkey-2.5.3.ebuild 1697
-MD5 c20d2c60441485aed5f581943e1290b3 ChangeLog 2682
+MD5 15614910d4f041d68a5d3935014f749d mldonkey-2.5.3.ebuild 1797
+MD5 5cb2a169e2235d258f544a815abc814c ChangeLog 2682
MD5 73773e015826112913003dbfe0ab8e6a mldonkey-2.5.ebuild 1900
MD5 42fb9dc4604cbd74f00ef7e9528533fe files/digest-mldonkey-2.04_rc1 77
MD5 d7470a0d99aae3be1ce3859c14e51b2b files/digest-mldonkey-2.5-r1 75
diff --git a/net-p2p/mldonkey/files/digest-mldonkey-2.5.3 b/net-p2p/mldonkey/files/digest-mldonkey-2.5.3
new file mode 100644
index 000000000000..a3f450f18754
--- /dev/null
+++ b/net-p2p/mldonkey/files/digest-mldonkey-2.5.3
@@ -0,0 +1 @@
+MD5 d11504a6dd1e8b5f955951d1f73236ed mldonkey-2.5-3.sources.tar.gz 2373194
diff --git a/net-p2p/mldonkey/mldonkey-2.5.3.ebuild b/net-p2p/mldonkey/mldonkey-2.5.3.ebuild
new file mode 100644
index 000000000000..8f60a3a826a2
--- /dev/null
+++ b/net-p2p/mldonkey/mldonkey-2.5.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.5.3.ebuild,v 1.1 2003/06/17 13:12:43 caleb Exp $
+
+IUSE="gtk"
+
+MY_PV=${PV%.*}-${PV#*.*.}
+MY_P=${PN}-${MY_PV}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="mldonkey is a new client to access the eDonkey network. It is written in Objective-Caml, and comes with its own GTK GUI, an HTTP interface and a telnet interface."
+HOMEPAGE="http://www.nongnu.org/mldonkey/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/release-${MY_PV}/official/${MY_P}.sources.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="gtk? ( >=lablgtk-1.2.4 )
+ >=dev-lang/ocaml-3.06
+ dev-lang/perl"
+
+src_compile() {
+ use gtk || export GTK_CONFIG="no"
+
+ # the dirs are not (yet) used, but it doesn't hurt to specify them anyway
+ econf \
+ --sysconfdir=/etc/mldonkey \
+ --sharedstatedir=/var/mldonkey \
+ --localstatedir=/var/mldonkey \
+ --enable-ocamlver=3.06
+
+ emake || die
+}
+
+src_install() {
+ dobin mlnet
+ use gtk && dobin mlchat mlgui mlguistarter mlim mlnet+gui
+ dobin ${FILESDIR}/mldonkey
+
+ cd ${S}/distrib
+ dodoc AUTHORS BUGS COPYING ChangeLog ed2k_links.txt INSTALL TODO
+ dohtml FAQ.html
+
+ insinto /usr/share/doc/${PF}/scripts
+ doins kill_mldonkey mldonkey_command mldonkey_previewer
+
+ insinto /usr/share/doc/${PF}/distrib
+ doins directconnect.ini servers.ini
+
+ cd ${S}/docs
+ dodoc *.txt *.tex
+ dohtml *.html
+
+ cd ${S}/docs/developers
+ dodoc *.txt *.tex
+
+ cd ${S}/docs/images
+ insinto /usr/share/doc/${PF}/html/images
+ doins *
+}
+
+pkg_postinst() {
+ echo
+ einfo "Running \`mldonkey' will start the server inside ~/.mldonkey/"
+ einfo "If you want to start mldonkey in a particular working directory,"
+ einfo "use the \`mlnet' command."
+ echo
+}