summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 15:08:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 15:08:51 +0000
commit4a3677fd3f1fc1bd21d84190f8e17aac29f373e5 (patch)
treef4f65a03e6bc9eb34bdb173b77649d60037b8bab /net-p2p
parentRemoved pkg-config in RDEPEND (see bug #217278) (diff)
downloadgentoo-2-4a3677fd3f1fc1bd21d84190f8e17aac29f373e5.tar.gz
gentoo-2-4a3677fd3f1fc1bd21d84190f8e17aac29f373e5.tar.bz2
gentoo-2-4a3677fd3f1fc1bd21d84190f8e17aac29f373e5.zip
Add patch by Philipp to build with GCC 4.3 (bug #212833).
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog6
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.8.0+gcc-4.3.patch58
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.0.ebuild9
3 files changed, 71 insertions, 2 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index d29503a5c116..b7e180653b4c 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.106 2008/03/01 11:17:24 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.107 2008/04/21 15:08:51 flameeyes Exp $
+
+ 21 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/rtorrent-0.8.0+gcc-4.3.patch, rtorrent-0.8.0.ebuild:
+ Add patch by Philipp to build with GCC 4.3 (bug #212833).
*rtorrent-0.8.0 (01 Mar 2008)
diff --git a/net-p2p/rtorrent/files/rtorrent-0.8.0+gcc-4.3.patch b/net-p2p/rtorrent/files/rtorrent-0.8.0+gcc-4.3.patch
new file mode 100644
index 000000000000..d95e6d3e414c
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.8.0+gcc-4.3.patch
@@ -0,0 +1,58 @@
+diff -Nurp rtorrent-0.8.0.old/rak/functional.h rtorrent-0.8.0/rak/functional.h
+--- rtorrent-0.8.0.old/rak/functional.h 2008-03-09 15:56:18.000000000 +0100
++++ rtorrent-0.8.0/rak/functional.h 2008-03-09 16:04:47.000000000 +0100
+@@ -37,6 +37,7 @@
+ #ifndef RAK_FUNCTIONAL_H
+ #define RAK_FUNCTIONAL_H
+
++#include <cstddef>
+ #include <functional>
+
+ namespace rak {
+diff -Nurp rtorrent-0.8.0.old/src/command_ui.cc rtorrent-0.8.0/src/command_ui.cc
+--- rtorrent-0.8.0.old/src/command_ui.cc 2008-03-09 15:56:18.000000000 +0100
++++ rtorrent-0.8.0/src/command_ui.cc 2008-03-09 16:05:36.000000000 +0100
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <ctime>
++
+ #include <rak/functional.h>
+ #include <rak/functional_fun.h>
+ #include <sigc++/adaptors/bind.h>
+
+diff -Nurp rtorrent-0.8.0.old/src/display/text_element_value.cc rtorrent-0.8.0/src/display/text_element_value.cc
+--- rtorrent-0.8.0.old/src/display/text_element_value.cc 2008-03-09 15:56:18.000000000 +0100
++++ rtorrent-0.8.0/src/display/text_element_value.cc 2008-03-09 16:07:39.000000000 +0100
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <ctime>
++
+ #include "globals.h"
+ #include "text_element_value.h"
+
+diff -Nurp rtorrent-0.8.0.old/src/rpc/exec_file.cc rtorrent-0.8.0/src/rpc/exec_file.cc
+--- rtorrent-0.8.0.old/src/rpc/exec_file.cc 2008-03-09 15:56:18.000000000 +0100
++++ rtorrent-0.8.0/src/rpc/exec_file.cc 2008-03-09 16:04:14.000000000 +0100
+@@ -36,6 +36,7 @@
+
+ #include "config.h"
+
++#include <cstring>
+ #include <string>
+ #include <unistd.h>
+ #include <rak/path.h>
+diff -Nurp rtorrent-0.8.0.old/src/rpc/parse.cc rtorrent-0.8.0/src/rpc/parse.cc
+--- rtorrent-0.8.0.old/src/rpc/parse.cc 2008-03-09 15:56:18.000000000 +0100
++++ rtorrent-0.8.0/src/rpc/parse.cc 2008-03-09 16:04:29.000000000 +0100
+@@ -36,6 +36,7 @@
+
+ #include "config.h"
+
++#include <cstring>
+ #include <locale>
+ #include <rak/path.h>
+ #include <torrent/exceptions.h>
diff --git a/net-p2p/rtorrent/rtorrent-0.8.0.ebuild b/net-p2p/rtorrent/rtorrent-0.8.0.ebuild
index a192fd249739..7ac0527fd3ef 100644
--- a/net-p2p/rtorrent/rtorrent-0.8.0.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.0.ebuild,v 1.1 2008/03/01 11:17:24 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.0.ebuild,v 1.2 2008/04/21 15:08:51 flameeyes Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -20,6 +20,13 @@ RDEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
xmlrpc? ( dev-libs/xmlrpc-c )"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}+gcc-4.3.patch"
+}
+
src_compile() {
replace-flags -Os -O2
append-flags -fno-strict-aliasing