summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-06-28 18:18:38 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-06-28 18:18:38 +0000
commitaeaf64b43f9e3ddd7b5dd9d89be4d1aabd7b490a (patch)
tree2ca08fcc96267617da6e64f04bb7647ecc98f1f9 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-aeaf64b43f9e3ddd7b5dd9d89be4d1aabd7b490a.tar.gz
gentoo-2-aeaf64b43f9e3ddd7b5dd9d89be4d1aabd7b490a.tar.bz2
gentoo-2-aeaf64b43f9e3ddd7b5dd9d89be4d1aabd7b490a.zip
Version bump
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog7
-rw-r--r--net-p2p/deluge/deluge-0.5.2_rc1.ebuild53
-rw-r--r--net-p2p/deluge/files/digest-deluge-0.5.2_rc13
3 files changed, 62 insertions, 1 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 59aa2f9cdf70..d8d67df6ce3f 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.16 2007/06/17 14:23:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.17 2007/06/28 18:18:38 armin76 Exp $
+
+*deluge-0.5.2_rc1 (28 Jun 2007)
+
+ 28 Jun 2007; Raúl Porcel <armin76@gentoo.org> +deluge-0.5.2_rc1.ebuild:
+ Version bump
17 Jun 2007; Raúl Porcel <armin76@gentoo.org> -deluge-0.5.0.ebuild,
deluge-0.5.1.1.ebuild, deluge-9999.ebuild:
diff --git a/net-p2p/deluge/deluge-0.5.2_rc1.ebuild b/net-p2p/deluge/deluge-0.5.2_rc1.ebuild
new file mode 100644
index 000000000000..2349c26a5f1e
--- /dev/null
+++ b/net-p2p/deluge/deluge-0.5.2_rc1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-0.5.2_rc1.ebuild,v 1.1 2007/06/28 18:18:38 armin76 Exp $
+
+inherit eutils distutils
+
+MY_P="${PN}-0.5.1.90"
+
+DESCRIPTION="BitTorrent client in Python and PyGTK."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/testing/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="libnotify"
+
+DEPEND=">=dev-lang/python-2.3
+ dev-libs/boost"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2
+ dev-python/pyxdg
+ dev-python/dbus-python
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+}
+
+src_compile() {
+ if use amd64 || use ia64 || use ppc64; then
+ CFLAGS="${CFLAGS} -DAMD64"
+ fi
+ distutils_src_compile
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "Please note that Deluge is still in it's early stages"
+ elog "of development. Use it carefully and feel free to submit bugs"
+ elog "in upstream page."
+ elog
+}
diff --git a/net-p2p/deluge/files/digest-deluge-0.5.2_rc1 b/net-p2p/deluge/files/digest-deluge-0.5.2_rc1
new file mode 100644
index 000000000000..141bc035d373
--- /dev/null
+++ b/net-p2p/deluge/files/digest-deluge-0.5.2_rc1
@@ -0,0 +1,3 @@
+MD5 76968f9b1bf91827055a0e5c1cd42f76 deluge-0.5.1.90.tar.gz 656890
+RMD160 920a1792713d0b6b4b510914965484e870fe4336 deluge-0.5.1.90.tar.gz 656890
+SHA256 977f1e6a589107ce025feafcb6526bcfb59e4a540f426870072922f17ba83f0a deluge-0.5.1.90.tar.gz 656890