summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-11-26 22:41:25 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-11-26 22:41:25 +0000
commite8e652c6ea9d2ed424c9c4bb7cb00c9fd64c4450 (patch)
tree2abae30a25185864181f8dde3c337dc5c2c9f76a /net-p2p
parentUpdate bugs-to. (diff)
downloadgentoo-2-e8e652c6ea9d2ed424c9c4bb7cb00c9fd64c4450.tar.gz
gentoo-2-e8e652c6ea9d2ed424c9c4bb7cb00c9fd64c4450.tar.bz2
gentoo-2-e8e652c6ea9d2ed424c9c4bb7cb00c9fd64c4450.zip
Fix build issue when USE=-utp, bug #290737.
(Portage version: 2.2.0_alpha78/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog6
-rw-r--r--net-p2p/transmission/files/transmission-2.41-noutp.patch14
-rw-r--r--net-p2p/transmission/transmission-2.41.ebuild5
3 files changed, 23 insertions, 2 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index be92306d261d..1a72193d8fe7 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.158 2011/10/19 11:49:53 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.159 2011/11/26 22:41:25 eva Exp $
+
+ 26 Nov 2011; Gilles Dartiguelongue <eva@gentoo.org> transmission-2.41.ebuild,
+ +files/transmission-2.41-noutp.patch:
+ Fix build issue when USE=-utp, bug #290737.
19 Oct 2011; Peter Volkov <pva@gentoo.org> transmission-2.41.ebuild:
Drop noexistent configure options.
diff --git a/net-p2p/transmission/files/transmission-2.41-noutp.patch b/net-p2p/transmission/files/transmission-2.41-noutp.patch
new file mode 100644
index 000000000000..141102162809
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-2.41-noutp.patch
@@ -0,0 +1,14 @@
+--- third-party/libutp/utypes.h.orig Wed Sep 28 19:46:15 2011
++++ third-party/libutp/utypes.h Wed Sep 28 19:47:06 2011
+@@ -36,7 +36,11 @@ typedef const char * cstr;
+ typedef char * str;
+
+ #ifndef __cplusplus
++#ifdef HAVE_STDBOOL_H
++#include <stdbool.h>
++#else
+ typedef uint8 bool;
++#endif
+ #endif
+
+ #endif //__UTYPES_H__
diff --git a/net-p2p/transmission/transmission-2.41.ebuild b/net-p2p/transmission/transmission-2.41.ebuild
index 62d60442840b..701596fc6545 100644
--- a/net-p2p/transmission/transmission-2.41.ebuild
+++ b/net-p2p/transmission/transmission-2.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.41.ebuild,v 1.2 2011/10/19 11:49:53 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.41.ebuild,v 1.3 2011/11/26 22:41:25 eva Exp $
EAPI=4
inherit eutils fdo-mime gnome2-utils qt4-r2 autotools
@@ -49,6 +49,9 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-2.33-0002-config.in-4-qt.pro.patch"
epatch "${FILESDIR}/${P}-0003-system-miniupnpc.patch"
+ # Fix build failure with USE=-utp, bug #290737
+ epatch "${FILESDIR}/${P}-noutp.patch"
+
# Upstream is not interested in this: https://trac.transmissionbt.com/ticket/4324
sed -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' -i libtransmission/Makefile.am || die