summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-06-10 15:20:34 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-06-10 15:20:34 +0000
commitc7b267f226148ddecbde3fcad7e9361cda00cb76 (patch)
treebc45b0f8f9c99a4d6b862930713a553c5932acdf /net-print/gnome-cups-manager/gnome-cups-manager-0.33.ebuild
parentVersion bump from Sunrise's portage-review. Remove unnecessary USE flag X and... (diff)
downloadgentoo-2-c7b267f226148ddecbde3fcad7e9361cda00cb76.tar.gz
gentoo-2-c7b267f226148ddecbde3fcad7e9361cda00cb76.tar.bz2
gentoo-2-c7b267f226148ddecbde3fcad7e9361cda00cb76.zip
Bump to 0.33. Bug #218085 Thanks Peter
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-print/gnome-cups-manager/gnome-cups-manager-0.33.ebuild')
-rw-r--r--net-print/gnome-cups-manager/gnome-cups-manager-0.33.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-print/gnome-cups-manager/gnome-cups-manager-0.33.ebuild b/net-print/gnome-cups-manager/gnome-cups-manager-0.33.ebuild
new file mode 100644
index 000000000000..bef62ad402ec
--- /dev/null
+++ b/net-print/gnome-cups-manager/gnome-cups-manager-0.33.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/gnome-cups-manager-0.33.ebuild,v 1.1 2008/06/10 15:20:34 dang Exp $
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="GNOME CUPS Printer Management Interface"
+HOMEPAGE="http://www.gnome.org/"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-patches-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.3.1
+ >=dev-libs/glib-2.3.1
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonobo-2
+ >=net-print/libgnomecups-0.2.3
+ gnome-base/gnome-keyring
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28"
+RDEPEND="${DEPEND}
+ x11-libs/gksu"
+
+
+DOCS="ChangeLog NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+ cd ${S}
+
+ export EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_MULTI_MSG="Applying Ubuntu patches (enhancements) ..."
+ epatch
+}
+
+src_install() {
+ gnome2_src_install
+ #Debian-specific.
+ rm "${D}"/usr/sbin/gnome-cups-switch
+}