summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 13:05:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 13:05:15 +0000
commit2de5a6b5e319e4d51f58a176f021c246b83fadb3 (patch)
tree54b3f4f212d50938327fae50fbf618658b1d95e6 /net-print/gnome-cups-manager
parentAdd patch to build with GCC 4.3. Thanks to Marek Miller in bug #225479. (diff)
downloadgentoo-2-2de5a6b5e319e4d51f58a176f021c246b83fadb3.tar.gz
gentoo-2-2de5a6b5e319e4d51f58a176f021c246b83fadb3.tar.bz2
gentoo-2-2de5a6b5e319e4d51f58a176f021c246b83fadb3.zip
Add patch from upstream to build with GCC 4.3. Thanks to Jose daLuz for reporting and Arun Raghavan for providing the patches. Closes s bug #225501.
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-print/gnome-cups-manager')
-rw-r--r--net-print/gnome-cups-manager/ChangeLog11
-rw-r--r--net-print/gnome-cups-manager/files/gnome-cups-manager-0.31+gcc-4.3.patch64
-rw-r--r--net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild8
3 files changed, 78 insertions, 5 deletions
diff --git a/net-print/gnome-cups-manager/ChangeLog b/net-print/gnome-cups-manager/ChangeLog
index f5d3a5efdb65..7e7b8270fbed 100644
--- a/net-print/gnome-cups-manager/ChangeLog
+++ b/net-print/gnome-cups-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/gnome-cups-manager
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.73 2007/12/18 16:20:11 dang Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.74 2008/06/09 13:05:14 flameeyes Exp $
+
+ 09 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/gnome-cups-manager-0.31+gcc-4.3.patch,
+ gnome-cups-manager-0.31-r2.ebuild:
+ Add patch from upstream to build with GCC 4.3. Thanks to Jose daLuz for
+ reporting and Arun Raghavan for providing the patches. Closes s bug
+ #225501.
18 Dec 2007; Daniel Gryniewicz <dang@gentoo.org>
gnome-cups-manager-0.31-r2.ebuild:
diff --git a/net-print/gnome-cups-manager/files/gnome-cups-manager-0.31+gcc-4.3.patch b/net-print/gnome-cups-manager/files/gnome-cups-manager-0.31+gcc-4.3.patch
new file mode 100644
index 000000000000..37c7d7f8aca0
--- /dev/null
+++ b/net-print/gnome-cups-manager/files/gnome-cups-manager-0.31+gcc-4.3.patch
@@ -0,0 +1,64 @@
+Index: gnome-cups-manager-0.31/libgnomecups/snmpkit/snmpkit
+===================================================================
+--- gnome-cups-manager-0.31.orig/libgnomecups/snmpkit/snmpkit
++++ gnome-cups-manager-0.31/libgnomecups/snmpkit/snmpkit
+@@ -31,6 +31,7 @@
+ #include <netdb.h>
+ #include <pthread.h>
+
++#include <cstring>
+ #include <string>
+ #include <list>
+ #include <functional>
+Index: gnome-cups-manager-0.31/libgnomecups/snmpkit/structfill.C
+===================================================================
+--- gnome-cups-manager-0.31.orig/libgnomecups/snmpkit/structfill.C
++++ gnome-cups-manager-0.31/libgnomecups/snmpkit/structfill.C
+@@ -28,7 +28,8 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+-#include <iostream.h>
++#include <iostream>
++#include <ios>
+ #include <algorithm>
+
+ #include "snmpkit"
+@@ -91,22 +92,22 @@ int SNMP_structFiller::fillStruct(OidSeq
+ counters or large ints */
+ if(curber->type()==INT_TAG && cur->type==COUNTER_TAG)
+ // these errors are minor enough and simple enough to fix
+- cerr << "Warning: Counter returned when Integer expected for "
++ std::cerr << "Warning: Counter returned when Integer expected for "
+ << cur->oidstr << " Buggy firmware?\n";
+ else if(curber->type()==COUNTER_TAG && cur->type==INT_TAG)
+ // these errors are minor enough and simple enough to fix
+- cerr << "Warning: Integer returned when Counter expected for "
++ std::cerr << "Warning: Integer returned when Counter expected for "
+ << cur->oidstr << " Buggy firmware?\n";
+ else{
+- ios::fmtflags opts=ios::hex;
+- opts=cerr.flags(opts);
+- cerr << "Warning: Printer returned a value of type 0x"
++ std::ios::fmtflags opts=std::ios::hex;
++ opts=std::cerr.flags(opts);
++ std::cerr << "Warning: Printer returned a value of type 0x"
+ << static_cast<long unsigned int>(curber->type())
+ << " when a value of 0x"
+ << static_cast<long unsigned int>(cur->type)
+ << " was expected for " << cur->oidstr
+ << " Buggy firmware? Skipping.\n";
+- cerr.flags(opts);
++ std::cerr.flags(opts);
+ retval=0;
+ break;
+ }
+@@ -177,7 +178,7 @@ void *SNMP_structFiller::get(void *tobef
+ throw SNMPNoResponseException();
+
+ if(!fillStruct(retseq,(unsigned char*)tobefilled)){
+- cerr << "Warning: printer did not respond with a value for one of the "
++ std::cerr << "Warning: printer did not respond with a value for one of the "
+ << "OIDs. Buggy firmware?\n";
+ return NULL;
+ }
diff --git a/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild b/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild
index 4b2a8868a3b8..7d3ca6902db8 100644
--- a/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild
+++ b/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild,v 1.15 2007/12/18 16:20:11 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild,v 1.16 2008/06/09 13:05:14 flameeyes Exp $
inherit eutils gnome2 flag-o-matic
@@ -52,13 +52,15 @@ src_unpack() {
# scripts fixing bug 147972 (removes LAN browsing detection)
sed -i \
-e '/^---.*ui_browse_share_ctl.patch/,/^---/{/^---.*ui_browse_share_ctl.patch/!d;}' \
- ${WORKDIR}/gnome-cups-manager_0.31-1.1ubuntu14.diff
+ ${WORKDIR}/gnome-cups-manager_0.31-1.1ubuntu14.diff
epatch ${WORKDIR}/gnome-cups-manager_0.31-1.1ubuntu14.diff
# gksudo does not always work
sed -i "s:gksudo:gksu:" debian/patches/change-su-command.patch
cd ${S}
epatch ${WORKDIR}/ubuntu/debian/patches/*
+ epatch "${FILESDIR}"/${P}+gcc-4.3.patch
+
# bug 141929
use amd64 && replace-flags -O* -O0
}