summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-04-30 09:15:31 +0000
committerSimon Stelling <blubb@gentoo.org>2005-04-30 09:15:31 +0000
commitc5eed9156a4d5ae1f3e242a1a2d7bff9b866f21d (patch)
treed7713ee18c917b360a38530deccb47d7618cbda2 /net-print
parent~ia64 keyword, bug 90910. (diff)
downloadgentoo-2-c5eed9156a4d5ae1f3e242a1a2d7bff9b866f21d.tar.gz
gentoo-2-c5eed9156a4d5ae1f3e242a1a2d7bff9b866f21d.tar.bz2
gentoo-2-c5eed9156a4d5ae1f3e242a1a2d7bff9b866f21d.zip
79791
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog6
-rw-r--r--net-print/cups/cups-1.1.23-r1.ebuild3
-rw-r--r--net-print/cups/files/cups-gcc4-amd64.patch12
3 files changed, 19 insertions, 2 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index 2c0044cbef55..1f8440f009de 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/cups
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.127 2005/04/28 14:38:15 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.128 2005/04/30 09:15:31 blubb Exp $
+
+ 30 Apr 2005; Simon Stelling <blubb@gentoo.org>
+ +files/cups-gcc4-amd64.patch, cups-1.1.23-r1.ebuild:
+ added DieMumiee's patch to fix bug #79791
28 Apr 2005; Heinrich Wendel <lanius@gentoo.org> files/cupsd.rc6:
revert 'use samba' again, it was the wrong way around
diff --git a/net-print/cups/cups-1.1.23-r1.ebuild b/net-print/cups/cups-1.1.23-r1.ebuild
index 12080086dce8..dba0c9941ae0 100644
--- a/net-print/cups/cups-1.1.23-r1.ebuild
+++ b/net-print/cups/cups-1.1.23-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.23-r1.ebuild,v 1.8 2005/02/07 03:44:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.23-r1.ebuild,v 1.9 2005/04/30 09:15:31 blubb Exp $
inherit eutils flag-o-matic
@@ -36,6 +36,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/disable-strip.patch
+ use amd64 && epatch ${FILESDIR}/cups-gcc4-amd64.patch #79791
( cd pdftops; epatch ${FILESDIR}/xpdf-goo-sizet.patch )
( cd pdftops; epatch ${FILESDIR}/cups-1.1.22-xpdf2-underflow.patch )
( cd pdftops; epatch ${FILESDIR}/xpdf-pl3.patch )
diff --git a/net-print/cups/files/cups-gcc4-amd64.patch b/net-print/cups/files/cups-gcc4-amd64.patch
new file mode 100644
index 000000000000..4cb8692255ee
--- /dev/null
+++ b/net-print/cups/files/cups-gcc4-amd64.patch
@@ -0,0 +1,12 @@
+diff -Npaur cups-1.1.23/pdftops/GfxFont.cxx cups-1.1.23-patched/pdftops/GfxFont.cxx
+--- cups-1.1.23/pdftops/GfxFont.cxx 2004-02-02 23:41:09.000000000 +0100
++++ cups-1.1.23-patched/pdftops/GfxFont.cxx 2005-01-28 02:04:15.613249488 +0100
+@@ -969,7 +969,7 @@ Gushort *Gfx8BitFont::getCodeToGIDMap(Tr
+ if ((nameToGID = ff->getNameToGID())) {
+ for (i = 0; i < 256; ++i) {
+ if (!map[i] && (charName = enc[i])) {
+- map[i] = (Gushort)(int)nameToGID->lookup(charName);
++ map[i] = (Gushort)(long)nameToGID->lookup(charName);
+ }
+ }
+ delete nameToGID;