summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-22 20:51:25 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-22 20:51:25 +0000
commita3250683ef367d43e71e5f986de0412b57e68a7b (patch)
tree50b57b928ad313471bbf2b9dbce8d173fb98ed4d /net-proxy/dante/files
parentStable on ppc. (diff)
downloadgentoo-2-a3250683ef367d43e71e5f986de0412b57e68a7b.tar.gz
gentoo-2-a3250683ef367d43e71e5f986de0412b57e68a7b.tar.bz2
gentoo-2-a3250683ef367d43e71e5f986de0412b57e68a7b.zip
net-misc/dante -> net-proxy/dante
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-proxy/dante/files')
-rw-r--r--net-proxy/dante/files/dante-1.1.15-bindresvport.patch17
-rw-r--r--net-proxy/dante/files/dante-1.1.15-getipnodebyname.patch12
-rw-r--r--net-proxy/dante/files/dante-1.1.15-optionalpam.patch317
-rw-r--r--net-proxy/dante/files/dante-1.1.15_pre1-socksify.patch16
-rw-r--r--net-proxy/dante/files/dante-sockd-conf14
-rw-r--r--net-proxy/dante/files/dante-sockd-init45
-rw-r--r--net-proxy/dante/files/digest-dante-1.1.15-r11
7 files changed, 422 insertions, 0 deletions
diff --git a/net-proxy/dante/files/dante-1.1.15-bindresvport.patch b/net-proxy/dante/files/dante-1.1.15-bindresvport.patch
new file mode 100644
index 000000000000..58535ae31037
--- /dev/null
+++ b/net-proxy/dante/files/dante-1.1.15-bindresvport.patch
@@ -0,0 +1,17 @@
+--- dante-1.1.14/capi/socks.h.agriffis 2003-07-02 08:13:28.000000000 -0400
++++ dante-1.1.14/capi/socks.h 2003-12-08 15:29:13.000000000 -0500
+@@ -47,6 +47,14 @@
+ #include <sys/socket.h>
+
+
++/*
++ * The definition of bindresvport below conflicts with line 336 of
++ * <netinet/in.h> ... best workaround seems to be to make sure the
++ * file is included prior to the #define
++ */
++#include <netinet/in.h>
++
++
+ #define accept Raccept
+ #define bind Rbind
+ #define bindresvport Rbindresvport
diff --git a/net-proxy/dante/files/dante-1.1.15-getipnodebyname.patch b/net-proxy/dante/files/dante-1.1.15-getipnodebyname.patch
new file mode 100644
index 000000000000..59db54bb9858
--- /dev/null
+++ b/net-proxy/dante/files/dante-1.1.15-getipnodebyname.patch
@@ -0,0 +1,12 @@
+diff -Nru dante-1.1.15.orig/capi/socks.h dante-1.1.15/capi/socks.h
+--- dante-1.1.15.orig/capi/socks.h 2005-02-22 20:25:04.000000000 +0200
++++ dante-1.1.15/capi/socks.h 2005-02-22 20:25:33.368695168 +0200
+@@ -112,7 +112,7 @@
+ struct hostent *Rgethostbyname2 __P((const char *, int af));
+ int Rgetaddrinfo __P((const char *nodename, const char *servname,
+ const struct addrinfo *hints, struct addrinfo **res));
+-struct hostent *Rgetipnodebyname __P((const char *name, int af, int flags,
++struct hostent *Rgetipnodebyname __P((const char *name, int af, int flags, int *error_num));
+ ssize_t Rwrite __P((int d, const void *buf, size_t nbytes));
+ ssize_t Rwritev __P((int d, const struct iovec *iov, int iovcnt));
+ ssize_t Rsend __P((int s, const void *msg, size_t len, int flags));
diff --git a/net-proxy/dante/files/dante-1.1.15-optionalpam.patch b/net-proxy/dante/files/dante-1.1.15-optionalpam.patch
new file mode 100644
index 000000000000..deef84a2096e
--- /dev/null
+++ b/net-proxy/dante/files/dante-1.1.15-optionalpam.patch
@@ -0,0 +1,317 @@
+--- configure.ac.orig 2005-02-15 18:50:05.978366304 +0930
++++ configure.ac 2005-02-15 19:22:42.360580312 +0930
+@@ -1255,12 +1255,24 @@
+ #(programs which don't use it probably won't enjoy being linked with it)
+ AM_CONDITIONAL(WANT_LIBWRAP, test "x${want_libwrap}" != "x")
+
+-#look for PAM header and lib
+-AC_CHECK_HEADERS(security/pam_appl.h, [have_pam_header=t])
+-AC_SEARCH_LIBS(pam_start, pam, [have_libpam=t])
+
+-if test x"${have_pam_header}" != x -a x"${have_libpam}" != x; then
+- AC_DEFINE(HAVE_PAM, 1, [PAM support])
++AC_ARG_WITH(pam,
++ [ --without-pam disable pam support(default=detect)],
++ [PAM=$withval])
++
++if test "${PAM}" != no; then
++ #look for PAM header and lib
++ AC_CHECK_HEADERS(security/pam_appl.h, [have_pam_header=t])
++ AC_SEARCH_LIBS(pam_start, pam, [have_libpam=t])
++
++ if test x"${have_pam_header}" != x -a x"${have_libpam}" != x; then
++ AC_DEFINE(HAVE_PAM, 1, [PAM support])
++ PAM=OK
++ else
++ PAM="not found"
++ fi
++else
++ PAM="disabled"
+ fi
+
+
+@@ -1484,6 +1496,7 @@
+ else
+ echo "Routeinfo: OK"
+ fi
++echo "PAM support: ${PAM}"
+ echo ""
+ echo "This software should perform optimally when all the lines above report 'OK'."
+ echo "This is not possible on all platforms."
+--- configure.orig 2005-02-15 19:34:04.005808456 +0930
++++ configure 2005-02-15 19:31:44.538156792 +0930
+@@ -1059,6 +1059,7 @@
+ --with-sockd-conf=FILE change location of socks server configuration file
+ --with-pidfile=FILE change location of server pidfile
+ --with-libc=NAME manually set name of c library if necessary
++ --without-pam disable pam support(default=detect)
+
+ Some influential environment variables:
+ CC C compiler command
+@@ -3945,7 +3946,7 @@
+ ;;
+ *-*-irix6*)
+ # Find out which ABI we are using.
+- echo '#line 3948 "configure"' > conftest.$ac_ext
++ echo '#line 3949 "configure"' > conftest.$ac_ext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+ (eval $ac_compile) 2>&5
+ ac_status=$?
+@@ -5289,7 +5290,7 @@
+
+
+ # Provide some information about the compiler.
+-echo "$as_me:5292:" \
++echo "$as_me:5293:" \
+ "checking for Fortran 77 compiler version" >&5
+ ac_compiler=`set X $ac_compile; echo $2`
+ { (eval echo "$as_me:$LINENO: \"$ac_compiler --version </dev/null >&5\"") >&5
+@@ -6346,11 +6347,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:6349: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:6350: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:6353: \$? = $ac_status" >&5
++ echo "$as_me:6354: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings
+@@ -6589,11 +6590,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:6592: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:6593: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:6596: \$? = $ac_status" >&5
++ echo "$as_me:6597: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings
+@@ -6649,11 +6650,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:6652: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:6653: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:6656: \$? = $ac_status" >&5
++ echo "$as_me:6657: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -8834,7 +8835,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 8837 "configure"
++#line 8838 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -8932,7 +8933,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 8935 "configure"
++#line 8936 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -11125,11 +11126,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:11128: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:11129: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:11132: \$? = $ac_status" >&5
++ echo "$as_me:11133: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings
+@@ -11185,11 +11186,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:11188: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:11189: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:11192: \$? = $ac_status" >&5
++ echo "$as_me:11193: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -12546,7 +12547,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 12549 "configure"
++#line 12550 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -12644,7 +12645,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 12647 "configure"
++#line 12648 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -13481,11 +13482,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:13484: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:13485: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:13488: \$? = $ac_status" >&5
++ echo "$as_me:13489: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings
+@@ -13541,11 +13542,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:13544: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:13545: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:13548: \$? = $ac_status" >&5
++ echo "$as_me:13549: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -15576,11 +15577,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:15579: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:15580: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:15583: \$? = $ac_status" >&5
++ echo "$as_me:15584: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings
+@@ -15819,11 +15820,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:15822: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:15823: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:15826: \$? = $ac_status" >&5
++ echo "$as_me:15827: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings
+@@ -15879,11 +15880,11 @@
+ -e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:15882: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:15883: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:15886: \$? = $ac_status" >&5
++ echo "$as_me:15887: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -18064,7 +18065,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 18067 "configure"
++#line 18068 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -18162,7 +18163,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 18165 "configure"
++#line 18166 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -29971,7 +29972,16 @@
+ fi
+
+
+-#look for PAM header and lib
++
++
++# Check whether --with-pam or --without-pam was given.
++if test "${with_pam+set}" = set; then
++ withval="$with_pam"
++ PAM=$withval
++fi;
++
++if test "${PAM}" != no; then
++ #look for PAM header and lib
+
+ for ac_header in security/pam_appl.h
+ do
+@@ -30122,7 +30132,7 @@
+
+ done
+
+-echo "$as_me:$LINENO: checking for library containing pam_start" >&5
++ echo "$as_me:$LINENO: checking for library containing pam_start" >&5
+ echo $ECHO_N "checking for library containing pam_start... $ECHO_C" >&6
+ if test "${ac_cv_search_pam_start+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+@@ -30249,12 +30259,18 @@
+ fi
+
+
+-if test x"${have_pam_header}" != x -a x"${have_libpam}" != x; then
++ if test x"${have_pam_header}" != x -a x"${have_libpam}" != x; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_PAM 1
+ _ACEOF
+
++ PAM=OK
++ else
++ PAM="not found"
++ fi
++else
++ PAM="disabled"
+ fi
+
+
+@@ -35024,6 +35040,7 @@
+ else
+ echo "Routeinfo: OK"
+ fi
++echo "PAM support: ${PAM}"
+ echo ""
+ echo "This software should perform optimally when all the lines above report 'OK'."
+ echo "This is not possible on all platforms."
diff --git a/net-proxy/dante/files/dante-1.1.15_pre1-socksify.patch b/net-proxy/dante/files/dante-1.1.15_pre1-socksify.patch
new file mode 100644
index 000000000000..632deb1f9b58
--- /dev/null
+++ b/net-proxy/dante/files/dante-1.1.15_pre1-socksify.patch
@@ -0,0 +1,16 @@
+--- dante-1.1.15-pre1/bin/socksify.in.agriffis 2004-11-04 16:07:04.000000000 -0500
++++ dante-1.1.15-pre1/bin/socksify.in 2004-11-04 16:07:08.977460049 -0500
+@@ -60,7 +60,11 @@
+ @PRELOAD_VARIABLE@="${LIBRARY}${SOCKSIFY_PRELOAD_LIBS:+${PRELOAD_SEPERATOR}}${SOCKSIFY_PRELOAD_LIBS}${PRELOAD_POSTFIX:+${PRELOAD_SEPERATOR}}${PRELOAD_POSTFIX}"
+ export @PRELOAD_VARIABLE@
+
+-LD_LIBRARY_PATH="${LD_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}${LIBDIR}"
+-export LD_LIBRARY_PATH
++# There is no reason to set LD_LIBRARY_PATH, at least on Linux, where
++# LD_PRELOAD can contain a full path to the library. Setting the
++# following breaks socksify on Linux/Alpha at least with
++# binutils-2.14.90.0.7-r3 (08 Dec 2003 agriffis)
++#LD_LIBRARY_PATH="${LD_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}${LIBDIR}"
++#export LD_LIBRARY_PATH
+
+ exec "$@"
diff --git a/net-proxy/dante/files/dante-sockd-conf b/net-proxy/dante/files/dante-sockd-conf
new file mode 100644
index 000000000000..c810c2ed11bc
--- /dev/null
+++ b/net-proxy/dante/files/dante-sockd-conf
@@ -0,0 +1,14 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/files/dante-sockd-conf,v 1.1 2005/04/22 20:47:27 mrness Exp $
+
+# Number of processes to fork off
+# 1 is plenty for most users
+# increment SLOWLY for bigger demand
+SOCKD_FORKDEPTH=1
+
+# set this to 1 to enable debug
+SOCKD_DEBUG=0
+
+# disable TCP keepalive for better resource usage
+SOCKD_DISABLE_KEEPALIVE=1
diff --git a/net-proxy/dante/files/dante-sockd-init b/net-proxy/dante/files/dante-sockd-init
new file mode 100644
index 000000000000..b2f641142046
--- /dev/null
+++ b/net-proxy/dante/files/dante-sockd-init
@@ -0,0 +1,45 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/files/dante-sockd-init,v 1.1 2005/04/22 20:47:27 mrness Exp $
+
+SOCKD_OPT="-D"
+[ "${SOCKD_FORKDEPTH}" -gt 1 ] && SOCKD_OPT="${SOCKD_OPT} -N ${SOCKD_FORKDEPTH}"
+[ "${SOCKD_DEBUG}" -eq 1 ] && SOCKD_OPT="${SOCKD_OPT} -d"
+[ "${SOCKD_DISABLE_KEEPALIVE}" -eq 1 ] && SOCKD_OPT="${SOCKD_OPT} -n"
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ # first check that it exists
+ if [ ! -f /etc/socks/sockd.conf ] ; then
+ eerror "You need to setup /etc/socks/sockd.conf first"
+ eerror "Examples are in /usr/share/doc/dante[version]/example"
+ eerror "for info: info sockd.conf"
+ return 1
+ fi
+ /usr/sbin/sockd -V
+ ret=$?
+ if [ $ret -ne 0 ]; then
+ eerror "Something is wrong with your configuration file"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting dante sockd"
+ start-stop-daemon --start --quiet --pidfile /var/run/sockd.pid \
+ --make-pidfile --exec /usr/sbin/sockd -- ${SOCKD_OPT}
+ eend $? "Failed to start sockd"
+}
+
+stop() {
+ ebegin "Stopping dante sockd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/sockd.pid
+ eend $? "Failed to stop sockd"
+ # clean stale pidfile
+ [ -f /var/run/sockd.pid ] && rm -f /var/run/sockd.pid
+}
diff --git a/net-proxy/dante/files/digest-dante-1.1.15-r1 b/net-proxy/dante/files/digest-dante-1.1.15-r1
new file mode 100644
index 000000000000..88330bda9942
--- /dev/null
+++ b/net-proxy/dante/files/digest-dante-1.1.15-r1
@@ -0,0 +1 @@
+MD5 c737faf4ba6282777070d8c0580c3832 dante-1.1.15.tar.gz 839660