summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-29 01:47:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-29 01:47:22 +0000
commit276771022afc1dfc16ab02bf98268cb1b708e86a (patch)
treecf1863f9488289ef107d2e554f577e48b4ef50d0 /net-proxy/squidclamav
parentadd mozilla herd (diff)
downloadgentoo-2-276771022afc1dfc16ab02bf98268cb1b708e86a.tar.gz
gentoo-2-276771022afc1dfc16ab02bf98268cb1b708e86a.tar.bz2
gentoo-2-276771022afc1dfc16ab02bf98268cb1b708e86a.zip
Version bump.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/squidclamav')
-rw-r--r--net-proxy/squidclamav/ChangeLog7
-rw-r--r--net-proxy/squidclamav/squidclamav-6.9.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-proxy/squidclamav/ChangeLog b/net-proxy/squidclamav/ChangeLog
index 31c8bba46fdb..8220da7f48fe 100644
--- a/net-proxy/squidclamav/ChangeLog
+++ b/net-proxy/squidclamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/squidclamav
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.26 2012/08/01 09:49:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.27 2012/08/29 01:47:22 flameeyes Exp $
+
+*squidclamav-6.9 (29 Aug 2012)
+
+ 29 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +squidclamav-6.9.ebuild:
+ Version bump.
01 Aug 2012; Agostino Sarubbo <ago@gentoo.org> -squidclamav-6.4.ebuild,
-squidclamav-6.6.ebuild:
diff --git a/net-proxy/squidclamav/squidclamav-6.9.ebuild b/net-proxy/squidclamav/squidclamav-6.9.ebuild
new file mode 100644
index 000000000000..7d0b84818d3a
--- /dev/null
+++ b/net-proxy/squidclamav/squidclamav-6.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/squidclamav-6.9.ebuild,v 1.1 2012/08/29 01:47:22 flameeyes Exp $
+
+EAPI=4
+
+inherit libtool autotools
+
+DESCRIPTION="HTTP Antivirus for Squid based on ClamAv and ICAP"
+HOMEPAGE="http://squidclamav.darold.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-proxy/c-icap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # version 6.3 causes maintainer-mode rebuild from tarball, and
+ # contains acinclude.m4 with libtool macros which cause trouble.
+ rm acinclude.m4 || die
+ eautoreconf
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+
+ # delete its own documentation installed
+ rm -r "${D}"/usr/share/${PN} || die
+
+ dodoc README AUTHORS ChangeLog
+
+ # Fix configuration file to adapt to the Gentoo configuration
+ sed -i \
+ -e '/clamd_local/s:\.ctl:.sock:' \
+ "${D}"/etc/squidclamav.conf || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 6, Squid Clamav is now a module for the c-icap"
+ elog "server, which is called from squid, rather than being a redirector"
+ elog "directly."
+ elog ""
+ elog "To enable the service, you should add this to your c-icap.conf file:"
+ elog ""
+ elog " Service clamav squidclamav.so"
+ elog ""
+ elog "And then this to squid.conf (for a local ICAP server):"
+ elog ""
+ elog " icap_enable on"
+ elog ""
+ elog " # not strictly needed, but useful for special access"
+ elog " icap_send_client_ip on"
+ elog " icap_send_client_username on"
+ elog ""
+ elog " icap_service clamav respmod_precache bypass=0 icap://localhost:1344/clamav"
+ elog " adaptation_access clamav allow all"
+}