summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-10-12 07:53:36 +0000
committerAlin Năstac <mrness@gentoo.org>2008-10-12 07:53:36 +0000
commit2bda06d49195cf2cde6aa6e49bb85eca83710e2f (patch)
tree1d34d70c0a6d12f6ccc7db3ccc7e1e0c16fbf182 /net-proxy/squidclamav
parentRemove obsolete versions. Remove squid run-time dependency (#241212). (diff)
downloadgentoo-2-2bda06d49195cf2cde6aa6e49bb85eca83710e2f.tar.gz
gentoo-2-2bda06d49195cf2cde6aa6e49bb85eca83710e2f.tar.bz2
gentoo-2-2bda06d49195cf2cde6aa6e49bb85eca83710e2f.zip
Version bump. Remove squid run-time dependency (#241212).
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-proxy/squidclamav')
-rw-r--r--net-proxy/squidclamav/ChangeLog8
-rw-r--r--net-proxy/squidclamav/files/squidclamav-3.6-gentoo.patch28
-rw-r--r--net-proxy/squidclamav/squidclamav-3.6.ebuild43
3 files changed, 78 insertions, 1 deletions
diff --git a/net-proxy/squidclamav/ChangeLog b/net-proxy/squidclamav/ChangeLog
index a747198b8760..e5f3109fd108 100644
--- a/net-proxy/squidclamav/ChangeLog
+++ b/net-proxy/squidclamav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squidclamav
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.7 2008/07/13 14:29:24 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.8 2008/10/12 07:53:36 mrness Exp $
+
+*squidclamav-3.6 (12 Oct 2008)
+
+ 12 Oct 2008; Alin Năstac <mrness@gentoo.org>
+ +files/squidclamav-3.6-gentoo.patch, +squidclamav-3.6.ebuild:
+ Version bump. Remove squid run-time dependency (#241212).
13 Jul 2008; Alin Năstac <mrness@gentoo.org>
-files/squidclamav-3.2-gentoo.patch, -squidclamav-3.2.ebuild:
diff --git a/net-proxy/squidclamav/files/squidclamav-3.6-gentoo.patch b/net-proxy/squidclamav/files/squidclamav-3.6-gentoo.patch
new file mode 100644
index 000000000000..6283013dfb9b
--- /dev/null
+++ b/net-proxy/squidclamav/files/squidclamav-3.6-gentoo.patch
@@ -0,0 +1,28 @@
+diff -ur squidclamav-3.6.orig/squidclamav.conf.dist squidclamav-3.6/squidclamav.conf.dist
+--- squidclamav-3.6.orig/squidclamav.conf.dist 2008-09-30 11:44:23.000000000 +0000
++++ squidclamav-3.6/squidclamav.conf.dist 2008-10-12 07:49:55.000000000 +0000
+@@ -29,7 +29,7 @@
+ #
+ # stat 0|1
+ #
+-# squidguard /usr/local/squidGuard/bin/squidGuard
++# squidguard /usr/bin/squidGuard
+ #
+ # whitelist this.trustdomain.com
+ # whitelist .*\.domain\.*
+@@ -39,12 +39,12 @@
+ #proxy http://127.0.0.1:3128/
+ #logfile /var/log/squidclamav.log
+ #redirect http://proxy.domain.com/cgi-bin/clwarn.cgi
+-#squidguard /usr/local/squidGuard/bin/squidGuard
++#squidguard /usr/bin/squidGuard
+ #debug 0
+ #force 1
+ #stat 1
+-#clamd_local /tmp/clamd
+-#clamd_ip 192.168.1.5
++#clamd_local /var/run/clamav/clamd.sock
++#clamd_ip 127.0.0.1
+ #clamd_port 3310
+ #timeout 60
+ #abort ^.*\.gz$
diff --git a/net-proxy/squidclamav/squidclamav-3.6.ebuild b/net-proxy/squidclamav/squidclamav-3.6.ebuild
new file mode 100644
index 000000000000..5b16b98bc8b8
--- /dev/null
+++ b/net-proxy/squidclamav/squidclamav-3.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/squidclamav-3.6.ebuild,v 1.1 2008/10/12 07:53:36 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="A Squid redirector to allow easy antivirus file scanning, using ClamAV"
+HOMEPAGE="http://www.samse.fr/GPL/"
+SRC_URI="http://www.samse.fr/GPL/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-misc/curl
+ dev-libs/openssl
+ sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_install() {
+ dosbin squidclamav || die "dosbin failed"
+ insinto /etc
+ newins squidclamav.conf.dist squidclamav.conf
+ keepdir /var/log/squidclamav
+ fowners squid:squid /var/log/squidclamav
+ dodoc ChangeLog README squidclamav.conf.dist clwarn.cgi*
+}
+
+pkg_postinst() {
+ einfo "To enable squidclam, add the following lines to /etc/squid/squid.conf:"
+ einfo " url_rewrite_program /usr/sbin/squidclamav"
+ einfo " url_rewrite_children 15"
+ einfo " url_rewrite_access deny localhost # prevent loops"
+ einfo " url_rewrite_access deny SSL_ports # SSL URLs cannot be scanned"
+}