summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-07-06 22:43:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-07-06 22:43:27 +0000
commitb4163c1ebd5a6249245b2f153261de80da332f3b (patch)
tree7a3457280b73fa1baa689d51c30c88931384903c /net-proxy/squidclamav
parentmask pgo and methodjit to prevent breakage with mozilla products on hardened. (diff)
downloadgentoo-2-b4163c1ebd5a6249245b2f153261de80da332f3b.tar.gz
gentoo-2-b4163c1ebd5a6249245b2f153261de80da332f3b.tar.bz2
gentoo-2-b4163c1ebd5a6249245b2f153261de80da332f3b.zip
Version bump.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/squidclamav')
-rw-r--r--net-proxy/squidclamav/ChangeLog10
-rw-r--r--net-proxy/squidclamav/squidclamav-6.3.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/net-proxy/squidclamav/ChangeLog b/net-proxy/squidclamav/ChangeLog
index 95e68245384c..2a9111ceb952 100644
--- a/net-proxy/squidclamav/ChangeLog
+++ b/net-proxy/squidclamav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squidclamav
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.12 2010/12/12 15:43:43 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.13 2011/07/06 22:43:27 flameeyes Exp $
+
+*squidclamav-6.3 (06 Jul 2011)
+
+ 06 Jul 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +squidclamav-6.3.ebuild:
+ Version bump.
12 Dec 2010; Christian Faulhammer <fauli@gentoo.org>
squidclamav-6.1.ebuild:
diff --git a/net-proxy/squidclamav/squidclamav-6.3.ebuild b/net-proxy/squidclamav/squidclamav-6.3.ebuild
new file mode 100644
index 000000000000..e8a488c08f5d
--- /dev/null
+++ b/net-proxy/squidclamav/squidclamav-6.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/squidclamav-6.3.ebuild,v 1.1 2011/07/06 22:43:27 flameeyes Exp $
+
+EAPI=4
+
+inherit libtool autotools
+
+DESCRIPTION="HTTP Antivirus for Squid based on ClamAv and ICAP"
+HOMEPAGE="http://squidclamav.darold.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-proxy/c-icap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # version 6.3 causes maintainer-mode rebuild from tarball, and
+ # contains acinclude.m4 with libtool macros which cause trouble.
+ rm acinclude.m4 || die
+ eautoreconf
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+
+ # delete its own documentation installed
+ rm -r "${D}"/usr/share/${PN} || die
+
+ dodoc README AUTHORS ChangeLog
+
+ # Fix configuration file to adapt to the Gentoo configuration
+ sed -i \
+ -e '/clamd_local/s:/tmp/clamd:/var/run/clamav/clamd.sock:' \
+ "${D}"/etc/squidclamav.conf || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 6, Squid Clamav is now a module for the c-icap"
+ elog "server, which is called from squid, rather than being a redirector"
+ elog "directly."
+ elog ""
+ elog "To enable the service, you should add this to your c-icap.conf file:"
+ elog ""
+ elog " Service clamav squidclamav.so"
+ elog ""
+ elog "And then this to squid.conf (for a local ICAP server):"
+ elog ""
+ elog " icap_enable on"
+ elog ""
+ elog " # not strictly needed, but useful for special access"
+ elog " icap_send_client_ip on"
+ elog " icap_send_client_username on"
+ elog ""
+ elog " icap_service clamav respmod_precache bypass=0 icap://localhost:1344/clamav"
+ elog " adaptation_access clamav allow all"
+}