summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-21 23:56:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-21 23:56:20 +0000
commit68af83e2b70f6dee8dd84e26127721d75a82d6ea (patch)
treed6ad5699b62e4fbf2244d12a0a28cab6a5d98f21 /net-proxy
parentAllow compilation with networkmanager-0.9, bug 387235 (diff)
downloadgentoo-2-68af83e2b70f6dee8dd84e26127721d75a82d6ea.tar.gz
gentoo-2-68af83e2b70f6dee8dd84e26127721d75a82d6ea.tar.bz2
gentoo-2-68af83e2b70f6dee8dd84e26127721d75a82d6ea.zip
Revision bump to use a more OpenRC-designed init script.
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/c-icap/ChangeLog8
-rw-r--r--net-proxy/c-icap/c-icap-0.1.7-r1.ebuild113
-rw-r--r--net-proxy/c-icap/files/c-icap.init.219
3 files changed, 139 insertions, 1 deletions
diff --git a/net-proxy/c-icap/ChangeLog b/net-proxy/c-icap/ChangeLog
index 85223837063d..5fb562c481c9 100644
--- a/net-proxy/c-icap/ChangeLog
+++ b/net-proxy/c-icap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/c-icap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.9 2011/10/11 17:24:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.10 2011/10/21 23:56:20 flameeyes Exp $
+
+*c-icap-0.1.7-r1 (21 Oct 2011)
+
+ 21 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +c-icap-0.1.7-r1.ebuild, +files/c-icap.init.2:
+ Revision bump to use a more OpenRC-designed init script.
*c-icap-0.1.7 (11 Oct 2011)
diff --git a/net-proxy/c-icap/c-icap-0.1.7-r1.ebuild b/net-proxy/c-icap/c-icap-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..1395d8516ebd
--- /dev/null
+++ b/net-proxy/c-icap/c-icap-0.1.7-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/c-icap-0.1.7-r1.ebuild,v 1.1 2011/10/21 23:56:20 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils multilib flag-o-matic autotools
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="C Implementation of an ICAP server"
+HOMEPAGE="http://c-icap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb ldap ipv6 ldap"
+
+RDEPEND="berkdb? ( sys-libs/db )
+ ldap? ( net-nds/openldap )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ sys-apps/openrc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.1.3-asneeded.patch"
+ epatch "${FILESDIR}/${PN}-0.1.3-implicit.patch"
+ epatch "${FILESDIR}/${PN}-0.1.3+db-5.0.patch"
+ epatch "${FILESDIR}/${PN}-0.1.4-crosscompile.patch"
+ epatch "${FILESDIR}/${PN}-0.1.6-implicit.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # some void *** pointers get casted around and can be troublesome to
+ # fix properly.
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --sysconfdir=/etc/${PN} \
+ --disable-dependency-tracking \
+ --disable-maintainer-mode \
+ --disable-static \
+ --enable-large-files \
+ $(use_enable ipv6) \
+ $(use_with berkdb bdb) \
+ $(use_with ldap)
+}
+
+src_compile() {
+ emake LOGDIR="/var/log" || die
+}
+
+src_install() {
+ emake \
+ LOGDIR="/var/log" \
+ DESTDIR="${D}" install || die
+
+ find "${D}" -name '*.la' -delete || die
+
+ # Move the daemon out of the way
+ dodir /usr/libexec
+ mv "${D}"/usr/bin/c-icap "${D}"/usr/libexec || die
+
+ # Remove the default configuration files since we have etc-update to
+ # take care of it for us.
+ rm "${D}"/etc/${PN}/c-icap.*.default || die
+
+ # Fix the configuration file; for some reason it's a bit messy
+ # around.
+ sed -i \
+ -e 's:/usr/var/:/var/:g' \
+ -e 's:/var/log/:/var/log/c-icap/:g' \
+ -e 's:/usr/etc/:/etc/c-icap/:g' \
+ -e 's:/usr/local/c-icap/etc/:/etc/c-icap/:g' \
+ -e 's:/usr/lib/:/usr/'$(get_libdir)'/:g' \
+ "${D}"/etc/${PN}/c-icap.conf \
+ || die
+
+ dodoc AUTHORS README TODO ChangeLog || die
+
+ newinitd "${FILESDIR}/${PN}.init.2" ${PN} || die
+ keepdir /var/log/c-icap || die
+
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+}
+
+pkg_postinst() {
+ elog "To enable Squid to call the ICAP modules from a local server you should set"
+ elog "the following in your squid.conf:"
+ elog ""
+ elog " icap_enable on"
+ elog ""
+ elog " # not strictly needed, but some modules might make use of these"
+ elog " icap_send_client_ip on"
+ elog " icap_send_client_username on"
+ elog ""
+ elog " icap_service service_req reqmod_precache bypass=1 icap://localhost:1344/service"
+ elog " adaptation_access service_req allow all"
+ elog ""
+ elog " icap_service service_resp respmod_precache bypass=0 icap://localhost:1344/service"
+ elog " adaptation_access service_resp allow all"
+ elog ""
+ elog "You obviously will have to replace \"service\" with the actual ICAP service to"
+ elog "use."
+}
diff --git a/net-proxy/c-icap/files/c-icap.init.2 b/net-proxy/c-icap/files/c-icap.init.2
new file mode 100644
index 000000000000..a649e7c8b206
--- /dev/null
+++ b/net-proxy/c-icap/files/c-icap.init.2
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/files/c-icap.init.2,v 1.1 2011/10/21 23:56:20 flameeyes Exp $
+
+pidfile=$(awk '$1 == "PidFile" { print $2 }' /etc/c-icap/c-icap.conf)
+
+command="/usr/libexec/c-icap"
+command_arguments="${EXTRA_OPTS}"
+
+depend() {
+ need localmount net
+}
+
+start_pre() {
+ cmdsocket=$(awk '$1 == "CommandsSocket" { print $2 }' /etc/c-icap/c-icap.conf)
+
+ checkpath -d "$(dirname "${cmdsocket}")" "$(dirname "${pidfile}")"
+}