summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavlos Ratis <dastergon@gentoo.org>2013-10-08 19:55:38 +0000
committerPavlos Ratis <dastergon@gentoo.org>2013-10-08 19:55:38 +0000
commit895171122786b2f5fd8ff27f74c81683b8ec43d8 (patch)
treeac547c678c4d991aed75f4ec088c393bc8ecf2cf /net-proxy
parentDropped vulnerable versions (CVE-2012-3544,CVE-2013-{2067,2071}) for security... (diff)
downloadgentoo-2-895171122786b2f5fd8ff27f74c81683b8ec43d8.tar.gz
gentoo-2-895171122786b2f5fd8ff27f74c81683b8ec43d8.tar.bz2
gentoo-2-895171122786b2f5fd8ff27f74c81683b8ec43d8.zip
Revision bump: EAPI 5 and added new configure option
(Portage version: 2.1.13.1/cvs/Linux x86_64, signed Manifest commit with key 0x3A051746)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/privoxy/ChangeLog8
-rw-r--r--net-proxy/privoxy/privoxy-3.0.21-r1.ebuild3
-rw-r--r--net-proxy/privoxy/privoxy-3.0.21-r2.ebuild65
3 files changed, 74 insertions, 2 deletions
diff --git a/net-proxy/privoxy/ChangeLog b/net-proxy/privoxy/ChangeLog
index 0256ea2a2bf7..e74eedc351ee 100644
--- a/net-proxy/privoxy/ChangeLog
+++ b/net-proxy/privoxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/privoxy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/ChangeLog,v 1.84 2013/09/03 20:17:02 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/ChangeLog,v 1.85 2013/10/08 19:55:38 dastergon Exp $
+
+*privoxy-3.0.21-r2 (08 Oct 2013)
+
+ 08 Oct 2013; Pavlos Ratis <dastergon@gentoo.org> +privoxy-3.0.21-r2.ebuild,
+ privoxy-3.0.21-r1.ebuild:
+ Revision bump: EAPI 5 and added new configure option
*privoxy-3.0.21-r1 (03 Sep 2013)
diff --git a/net-proxy/privoxy/privoxy-3.0.21-r1.ebuild b/net-proxy/privoxy/privoxy-3.0.21-r1.ebuild
index c839be995e30..6330ce7c3ffb 100644
--- a/net-proxy/privoxy/privoxy-3.0.21-r1.ebuild
+++ b/net-proxy/privoxy/privoxy-3.0.21-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/privoxy-3.0.21-r1.ebuild,v 1.1 2013/09/03 20:17:02 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/privoxy-3.0.21-r1.ebuild,v 1.2 2013/10/08 19:55:38 dastergon Exp $
EAPI="4"
@@ -39,6 +39,7 @@ src_prepare() {
}
src_configure() {
+
econf \
$(use_enable zlib) \
$(use_enable threads pthread) \
diff --git a/net-proxy/privoxy/privoxy-3.0.21-r2.ebuild b/net-proxy/privoxy/privoxy-3.0.21-r2.ebuild
new file mode 100644
index 000000000000..43ca09078d85
--- /dev/null
+++ b/net-proxy/privoxy/privoxy-3.0.21-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/privoxy/privoxy-3.0.21-r2.ebuild,v 1.1 2013/10/08 19:55:38 dastergon Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs autotools systemd user
+
+[ "${PV##*_}" = "beta" ] &&
+ PRIVOXY_STATUS="beta" ||
+ PRIVOXY_STATUS="stable"
+
+HOMEPAGE="http://www.privoxy.org http://sourceforge.net/projects/ijbswa/"
+DESCRIPTION="A web proxy with advanced filtering capabilities for protecting privacy against Internet junk"
+SRC_URI="mirror://sourceforge/ijbswa/${P%_*}-${PRIVOXY_STATUS}-src.tar.gz"
+
+IUSE="selinux threads zlib"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+
+DEPEND="dev-libs/libpcre
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-privoxy )"
+
+S="${WORKDIR}/${P%_*}-${PRIVOXY_STATUS}"
+
+pkg_setup() {
+ enewgroup privoxy
+ enewuser privoxy -1 -1 /etc/privoxy privoxy
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.19-gentoo.patch
+ # autoreconf needs to be called even if we don't modify any autotools source files
+ # See main makefile
+ eautoreconf
+}
+
+src_configure() {
+
+ econf \
+ $(use_enable zlib) \
+ $(use_enable threads pthread) \
+ $(usex zlib --enable-compression "") \
+ --enable-dynamic-pcre \
+ --with-user=privoxy \
+ --with-group=privoxy \
+ --sysconfdir=/etc/privoxy \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}/privoxy.initd" privoxy
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/privoxy.logrotate" privoxy
+
+ diropts -m 0750 -g privoxy -o privoxy
+ keepdir /var/log/privoxy
+}