summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-05-11 21:26:00 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-05-11 21:26:00 +0000
commit96643349086e735a48de474dfd95083cda5c8e94 (patch)
tree4c70a2702db4a60438fc5dd9a8e623718589ccaa /net-proxy
parentfix herd (diff)
downloadgentoo-2-96643349086e735a48de474dfd95083cda5c8e94.tar.gz
gentoo-2-96643349086e735a48de474dfd95083cda5c8e94.tar.bz2
gentoo-2-96643349086e735a48de474dfd95083cda5c8e94.zip
version bump.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/ziproxy/ChangeLog10
-rw-r--r--net-proxy/ziproxy/files/digest-ziproxy-2.2.23
-rw-r--r--net-proxy/ziproxy/files/ziproxy-2.2.confd18
-rw-r--r--net-proxy/ziproxy/files/ziproxy-2.2.initd26
-rw-r--r--net-proxy/ziproxy/ziproxy-2.2.2.ebuild82
5 files changed, 137 insertions, 2 deletions
diff --git a/net-proxy/ziproxy/ChangeLog b/net-proxy/ziproxy/ChangeLog
index 00e029baeb5b..5f50f11d607e 100644
--- a/net-proxy/ziproxy/ChangeLog
+++ b/net-proxy/ziproxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/ziproxy
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ChangeLog,v 1.8 2006/10/01 20:49:57 sbriesen Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ChangeLog,v 1.9 2007/05/11 21:26:00 sbriesen Exp $
+
+*ziproxy-2.2.2 (11 May 2007)
+
+ 11 May 2007; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/ziproxy-2.2.confd, +files/ziproxy-2.2.initd, +ziproxy-2.2.2.ebuild:
+ version bump.
01 Oct 2006; Stefan Briesenick <sbriesen@gentoo.org>
-files/ziproxy-2.0.confd, -files/ziproxy-2.0.initd, -ziproxy-2.0.0.ebuild:
diff --git a/net-proxy/ziproxy/files/digest-ziproxy-2.2.2 b/net-proxy/ziproxy/files/digest-ziproxy-2.2.2
new file mode 100644
index 000000000000..fa30ae93a380
--- /dev/null
+++ b/net-proxy/ziproxy/files/digest-ziproxy-2.2.2
@@ -0,0 +1,3 @@
+MD5 b2c1e1b7efa4db50b97d69b126815bba ziproxy-2.2.2.tar.bz2 145733
+RMD160 10442335f5cf64e8205c93a707dd3e9ab233b6b6 ziproxy-2.2.2.tar.bz2 145733
+SHA256 6fbf4134e84311d4590f907b37b5ae2ee0af5dc5d8fc6457edf4129635dc7bb9 ziproxy-2.2.2.tar.bz2 145733
diff --git a/net-proxy/ziproxy/files/ziproxy-2.2.confd b/net-proxy/ziproxy/files/ziproxy-2.2.confd
new file mode 100644
index 000000000000..793b8c666739
--- /dev/null
+++ b/net-proxy/ziproxy/files/ziproxy-2.2.confd
@@ -0,0 +1,18 @@
+# configuraton file for /etc/init.d/ziproxy
+#
+# you can symlink /etc/init.d/ziproxy to a different name
+# and then copy this config to a new file with the same name
+# as the symlinked init-script to run multiple instances of
+# ziproxy. You have to change the location for CONFIG then
+# of course... ;-)
+
+# Full path to ziproxy.conf file (instead of default one).
+#
+#CONFIG="/etc/ziproxy.conf"
+
+# Limit incoming connections only from the specified address(es).
+# This option has the same meaning, but higher precedence as
+# "OnlyFrom=" option in configuration file. Uncomment it
+# if you want to set it.
+#
+#ONLYFROM="<IP.address or hostname>"
diff --git a/net-proxy/ziproxy/files/ziproxy-2.2.initd b/net-proxy/ziproxy/files/ziproxy-2.2.initd
new file mode 100644
index 000000000000..3c843a7ecf64
--- /dev/null
+++ b/net-proxy/ziproxy/files/ziproxy-2.2.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/files/ziproxy-2.2.initd,v 1.1 2007/05/11 21:26:00 sbriesen Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ local OPT="-d"
+ ebegin "Starting ${myservice}"
+
+ [ -n "${CONFIG}" ] && OPT="${OPT} -c ${CONFIG}"
+ [ -n "${ONLYFROM}" ] && OPT="${OPT} -f ${ONLYFROM}"
+
+ start-stop-daemon --quiet --start --pidfile /var/run/${myservice}.pid \
+ --chuid ziproxy:ziproxy --exec /usr/sbin/ziproxy -- ${OPT} > /var/run/${myservice}.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ziproxy"
+ start-stop-daemon --stop --quiet --pidfile /var/run/${myservice}.pid
+ eend $?
+}
diff --git a/net-proxy/ziproxy/ziproxy-2.2.2.ebuild b/net-proxy/ziproxy/ziproxy-2.2.2.ebuild
new file mode 100644
index 000000000000..be4ec04697d7
--- /dev/null
+++ b/net-proxy/ziproxy/ziproxy-2.2.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ziproxy-2.2.2.ebuild,v 1.1 2007/05/11 21:26:00 sbriesen Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils
+
+DESCRIPTION="A forwarding, non-caching, compressing web proxy server"
+HOMEPAGE="http://ziproxy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="jpeg2k xinetd"
+
+DEPEND="dev-libs/confuse
+ media-libs/giflib
+ media-libs/libpng
+ media-libs/jpeg
+ sys-libs/zlib
+ jpeg2k? ( media-libs/jasper )
+ xinetd? ( virtual/inetd )"
+
+
+pkg_setup() {
+ enewgroup ziproxy
+ enewuser ziproxy -1 -1 -1 ziproxy
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix sample config file
+ sed -i -e "s:/usr/local/ziproxy/\(ziproxy.passwd\):/etc/\1:g" \
+ -e "s:/var/ziproxy/:/var/lib/ziproxy/:g" etc/ziproxy.conf
+
+ # fix sample xinetd config
+ sed -i -e "s:/usr/bin/:/usr/sbin/:g" \
+ -e "s:\(.*port.*\):\1\n\ttype\t\t\t= UNLISTED:g" \
+ -e "s:root:ziproxy:g" etc/xinetd.d/ziproxy
+}
+
+src_compile() {
+ local myconf="--enable-shared-confuse --with-cfgfile=/etc/ziproxy.conf" # --enable-testprogs
+ use jpeg2k && myconf="${myconf} --with-jasper" # use_with doesn't work
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodir /usr/sbin
+ mv -f "${D}usr/bin/ziproxy" "${D}usr/sbin/ziproxy"
+
+ newbin stats.awk ${PN}_stats.awk
+ dobin src/tools/ziproxy_genhtml_stats.sh
+
+ newinitd "${FILESDIR}/${PN}-${PV%.*}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}-${PV%.*}.confd" ${PN}
+
+ dodoc ChangeLog CREDITS README README.tools
+ use jpeg2k && dodoc JPEG2000.txt
+
+ insinto /etc
+ doins etc/ziproxy.conf
+
+ insinto /var/lib/ziproxy/error
+ doins var/ziproxy/error/*.html
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ doins etc/xinetd.d/ziproxy
+ fi
+
+ diropts -m0750 -o ziproxy -g ziproxy
+ keepdir /var/log/ziproxy
+}