summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-31 17:11:45 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-31 17:11:45 +0000
commit9827c932ca66c7d47cfec5f2f76572dce190298c (patch)
tree28c6cb15d97333d46f1094fab19e4d1a27bae66b /net-proxy
parentnew plugin package (diff)
downloadgentoo-2-9827c932ca66c7d47cfec5f2f76572dce190298c.tar.gz
gentoo-2-9827c932ca66c7d47cfec5f2f76572dce190298c.tar.bz2
gentoo-2-9827c932ca66c7d47cfec5f2f76572dce190298c.zip
Fixed building of the fastfilereader extension. Added necessary dev-ruby/cgi_multipart_eof_fix and www-servers/mongrel dependencies. Made testing phase empty since there is no Rakefile.
(Portage version: 2.1.11.59/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/swiftiply/ChangeLog11
-rw-r--r--net-proxy/swiftiply/files/swiftiply-0.6.1.1-ffr-stderror.patch12
-rw-r--r--net-proxy/swiftiply/swiftiply-0.6.1.1-r1.ebuild49
-rw-r--r--net-proxy/swiftiply/swiftiply-0.6.1.1.ebuild21
4 files changed, 71 insertions, 22 deletions
diff --git a/net-proxy/swiftiply/ChangeLog b/net-proxy/swiftiply/ChangeLog
index 23c255c1f6f3..5931940230ac 100644
--- a/net-proxy/swiftiply/ChangeLog
+++ b/net-proxy/swiftiply/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-proxy/swiftiply
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/ChangeLog,v 1.1 2013/03/31 15:21:44 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/ChangeLog,v 1.2 2013/03/31 17:11:45 tomwij Exp $
+
+*swiftiply-0.6.1.1-r1 (31 Mar 2013)
+
+ 31 Mar 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/swiftiply-0.6.1.1-ffr-stderror.patch, +swiftiply-0.6.1.1-r1.ebuild,
+ -swiftiply-0.6.1.1.ebuild:
+ Fixed building of the fastfilereader extension. Added necessary dev-
+ ruby/cgi_multipart_eof_fix and www-servers/mongrel dependencies. Made testing
+ phase empty since there is no Rakefile.
*swiftiply-0.6.1.1 (31 Mar 2013)
diff --git a/net-proxy/swiftiply/files/swiftiply-0.6.1.1-ffr-stderror.patch b/net-proxy/swiftiply/files/swiftiply-0.6.1.1-ffr-stderror.patch
new file mode 100644
index 000000000000..d1c263e4de72
--- /dev/null
+++ b/net-proxy/swiftiply/files/swiftiply-0.6.1.1-ffr-stderror.patch
@@ -0,0 +1,12 @@
+--- a/ext/fastfilereader/mapper.cpp 2013-03-31 18:07:09.938898478 +0200
++++ b/ext/fastfilereader/mapper.cpp 2013-03-31 18:08:40.822223762 +0200
+@@ -32,7 +32,9 @@
+ #include <errno.h>
+
+ #include <iostream>
++#include "unistd.h"
+ #include <string>
++#include <cstring>
+ #include <stdexcept>
+ using namespace std;
+
diff --git a/net-proxy/swiftiply/swiftiply-0.6.1.1-r1.ebuild b/net-proxy/swiftiply/swiftiply-0.6.1.1-r1.ebuild
new file mode 100644
index 000000000000..bf6c3da0c593
--- /dev/null
+++ b/net-proxy/swiftiply/swiftiply-0.6.1.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/swiftiply-0.6.1.1-r1.ebuild,v 1.1 2013/03/31 17:11:45 tomwij Exp $
+
+EAPI="5"
+
+USE_RUBY="ruby18"
+inherit ruby-ng ruby-fakegem
+
+MY_COMPANY="swiftcore"
+DESCRIPTION="A clustering proxy server for web applications."
+HOMEPAGE="http://${PN}.${MY_COMPANY}.org/"
+SRC_URI="http://${PN}.${MY_COMPANY}.org/files/${P}.gem"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-ruby/cgi_multipart_eof_fix
+ >=dev-ruby/eventmachine-0.9.0
+ www-servers/mongrel"
+
+RUBY_FAKEGEM_EXTRAINSTALL="src"
+RUBY_PATCHES=( "${FILESDIR}"/swiftiply-0.6.1.1-ffr-stderror.patch )
+
+QA_PRESTRIPPED="usr/lib/fastfilereaderext.so
+ usr/lib32/fastfilereaderext.so
+ usr/lib64/fastfilereaderext.so"
+
+all_ruby_compile() {
+ sed -i '/build_ext/q' setup.rb || die 'Rewrite of extension build script failed.'
+ echo '}' >> setup.rb || die 'Rewrite of extension build script failed.'
+
+ ruby setup.rb
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Conflict with www-servers/mongrel.
+ rm "${ED}"/usr/bin/mongrel_rails
+
+ dolib ext/fastfilereader/fastfilereaderext.so
+}
+
+# There is no rakefile, don't test.
+src_test() {
+ :
+}
diff --git a/net-proxy/swiftiply/swiftiply-0.6.1.1.ebuild b/net-proxy/swiftiply/swiftiply-0.6.1.1.ebuild
deleted file mode 100644
index a0798d8f956a..000000000000
--- a/net-proxy/swiftiply/swiftiply-0.6.1.1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/swiftiply/swiftiply-0.6.1.1.ebuild,v 1.1 2013/03/31 15:21:44 tomwij Exp $
-
-EAPI="5"
-
-USE_RUBY="ruby18 ruby19"
-inherit ruby-ng ruby-fakegem
-
-MY_COMPANY="swiftcore"
-DESCRIPTION="A clustering proxy server for web applications."
-HOMEPAGE="http://${PN}.${MY_COMPANY}.org/"
-SRC_URI="http://${PN}.${MY_COMPANY}.org/files/${P}.gem"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=dev-ruby/eventmachine-0.9.0"
-
-RUBY_FAKEGEM_EXTRAINSTALL="src"