summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2011-09-10 07:24:04 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2011-09-10 07:24:04 +0000
commitf15f6818446c215b8b9af5859d0fbb3349ccac58 (patch)
treef6c460d6cb867acf5d321799fd2ebea9207d2a63 /net-wireless/crda/files
parentInstall icon and desktop file. Bug 198680 by Sebastian. (diff)
downloadgentoo-2-f15f6818446c215b8b9af5859d0fbb3349ccac58.tar.gz
gentoo-2-f15f6818446c215b8b9af5859d0fbb3349ccac58.tar.bz2
gentoo-2-f15f6818446c215b8b9af5859d0fbb3349ccac58.zip
Added support for libnl-3.1
(Portage version: 2.2.0_alpha54/cvs/Linux i686)
Diffstat (limited to 'net-wireless/crda/files')
-rw-r--r--net-wireless/crda/files/libnl31-support.diff58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-wireless/crda/files/libnl31-support.diff b/net-wireless/crda/files/libnl31-support.diff
new file mode 100644
index 000000000000..caa28997096f
--- /dev/null
+++ b/net-wireless/crda/files/libnl31-support.diff
@@ -0,0 +1,58 @@
+diff -aurp a/crda.c b/crda.c
+--- a/crda.c 2011-09-09 23:36:23.742094512 +0000
++++ b/crda.c 2011-09-09 23:36:02.109096391 +0000
+@@ -21,7 +21,7 @@
+ #include "regdb.h"
+ #include "reglib.h"
+
+-#if !defined(CONFIG_LIBNL20) && !defined(CONFIG_LIBNL30)
++#if !defined(CONFIG_LIBNL20) && !defined(CONFIG_LIBNL30) && !defined(CONFIG_LIBNL31)
+ /* libnl 2.0 compatibility code */
+ static inline struct nl_handle *nl_socket_alloc(void)
+ {
+@@ -44,7 +44,7 @@ static inline int __genl_ctrl_alloc_cach
+
+ #define genl_ctrl_alloc_cache __genl_ctrl_alloc_cache
+ #define nl_sock nl_handle
+-#endif /* CONFIG_LIBNL20 && CONFIG_LIBNL30 */
++#endif /* CONFIG_LIBNL20 && CONFIG_LIBNL30 && CONFIG_LIBNL31 */
+
+ struct nl80211_state {
+ struct nl_sock *nl_sock;
+diff -aurp a/Makefile b/Makefile
+--- a/Makefile 2011-09-09 23:36:23.743094561 +0000
++++ b/Makefile 2011-09-09 23:36:02.109096391 +0000
+@@ -48,19 +48,26 @@ INSTALL ?= install
+ NL1FOUND := $(shell pkg-config --atleast-version=1 libnl-1 && echo Y)
+ NL2FOUND := $(shell pkg-config --atleast-version=2 libnl-2.0 && echo Y)
+ NL3FOUND := $(shell pkg-config --atleast-version=3 libnl-3.0 && echo Y)
++NL31FOUND := $(shell pkg-config --atleast-version=3 libnl-3.1 && echo Y)
+
+-ifeq ($(NL3FOUND),Y)
++ifeq ($(NL31FOUND),Y)
+ CFLAGS += -DCONFIG_LIBNL30
+ NLLIBS += -lnl-genl
+-NLLIBNAME = libnl-3.0
++NLLIBNAME = libnl-3.1
+ else
+- ifeq ($(NL2FOUND),Y)
+- CFLAGS += -DCONFIG_LIBNL20
++ ifeq ($(NL3FOUND),Y)
++ CFLAGS += -DCONFIG_LIBNL30
+ NLLIBS += -lnl-genl
+- NLLIBNAME = libnl-2.0
++ NLLIBNAME = libnl-3.0
+ else
+- ifeq ($(NL1FOUND),Y)
+- NLLIBNAME = libnl-1
++ ifeq ($(NL2FOUND),Y)
++ CFLAGS += -DCONFIG_LIBNL20
++ NLLIBS += -lnl-genl
++ NLLIBNAME = libnl-2.0
++ else
++ ifeq ($(NL1FOUND),Y)
++ NLLIBNAME = libnl-1
++ endif
+ endif
+ endif
+ endif