summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-11-01 08:20:50 +0000
committerRoy Marples <uberlord@gentoo.org>2006-11-01 08:20:50 +0000
commit0af21f8ee76c4e14c2a4f0f689c8a31745823b27 (patch)
tree08819ce32492fac247ad2663ee763a018b1a334f /net-wireless
parentFix broken digest (diff)
downloadgentoo-2-0af21f8ee76c4e14c2a4f0f689c8a31745823b27.tar.gz
gentoo-2-0af21f8ee76c4e14c2a4f0f689c8a31745823b27.tar.bz2
gentoo-2-0af21f8ee76c4e14c2a4f0f689c8a31745823b27.zip
Add support for BROADCOM and HERMES drivers.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog6
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index 63e9a7a0d8db..c2a4afbcf353 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.79 2006/10/02 15:39:18 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.80 2006/11/01 08:20:50 uberlord Exp $
+
+ 01 Nov 2006; Roy Marples <uberlord@gentoo.org>
+ wpa_supplicant-0.5.5.ebuild:
+ Add support for BROADCOM and HERMES drivers.
02 Oct 2006; Roy Marples <uberlord@gentoo.org> +files/wpa_supplicant.conf,
wpa_supplicant-0.5.5.ebuild:
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
index b9c5804364c6..e3313ac393b8 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild,v 1.8 2006/10/02 15:39:18 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild,v 1.9 2006/11/01 08:20:50 uberlord Exp $
inherit eutils toolchain-funcs
@@ -62,6 +62,8 @@ src_unpack() {
echo "CONFIG_BACKEND=file" >> .config
# basic authentication methods
+ # NOTE: we don't set GPSK or SAKE as they conflict
+ # with the below options
echo "CONFIG_EAP_GTC=y" >> .config
echo "CONFIG_EAP_MD5=y" >> .config
echo "CONFIG_EAP_OTP=y" >> .config
@@ -101,6 +103,8 @@ src_unpack() {
if use kernel_linux ; then
# Linux specific drivers
echo "CONFIG_DRIVER_ATMEL=y" >> .config
+ echo "CONFIG_DRIVER_BROADCOM=y" >> .config
+ echo "CONFIG_DRIVER_HERMES=y" >> .config
echo "CONFIG_DRIVER_HOSTAP=y" >> .config
echo "CONFIG_DRIVER_IPW=y" >> .config
echo "CONFIG_DRIVER_NDISWRAPPER=y" >> .config