summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-12 16:37:00 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-12 16:37:00 +0000
commitc2d3d276239e05e66a9e569d5ad1e33610f1dd50 (patch)
tree8ad6d1366e8a4132e6cbf4081d889bad7f5cca63 /net-wireless
parentMoving EANT_GENTOO_CLASSPATH handling to eant implementation so that it can b... (diff)
downloadgentoo-2-c2d3d276239e05e66a9e569d5ad1e33610f1dd50.tar.gz
gentoo-2-c2d3d276239e05e66a9e569d5ad1e33610f1dd50.tar.bz2
gentoo-2-c2d3d276239e05e66a9e569d5ad1e33610f1dd50.zip
Changing src_install to utilize fowners/fperms, switching the order of chmod/chown in pkg_postinst (thanks to Jan Kundrát in #161290).
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/ipw3945d/ChangeLog6
-rw-r--r--net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild12
2 files changed, 11 insertions, 7 deletions
diff --git a/net-wireless/ipw3945d/ChangeLog b/net-wireless/ipw3945d/ChangeLog
index 8bd26a04bfb7..8bbb2ba775b6 100644
--- a/net-wireless/ipw3945d/ChangeLog
+++ b/net-wireless/ipw3945d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/ipw3945d
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ChangeLog,v 1.13 2007/01/11 18:37:24 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ChangeLog,v 1.14 2007/01/12 16:37:00 phreak Exp $
+
+ 12 Jan 2007; Christian Heim <phreak@gentoo.org> ipw3945d-1.7.22-r4.ebuild:
+ Changing src_install to utilize fowners/fperms, switching the order of
+ chmod/chown in pkg_postinst (thanks to Jan Kundrát in #161290).
11 Jan 2007; Christian Heim <phreak@gentoo.org> ipw3945d-1.7.22-r4.ebuild:
Fixing src_install (was munging with stuff outside , which came from the
diff --git a/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild b/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild
index 70b1c3f5bda7..edae837caac0 100644
--- a/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild
+++ b/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild,v 1.5 2007/01/11 18:37:24 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild,v 1.6 2007/01/12 16:37:00 phreak Exp $
inherit eutils
@@ -30,11 +30,11 @@ src_install() {
use amd64 && dosbin x86_64/ipw3945d
# Give the ipw3945d access to the binary
- chown ipw3945d:root "${D}/sbin/ipw3945d"
- chmod 04450 "${D}/sbin/ipw3945d"
+ fowners ipw3945d:root /sbin/ipw3945d
+ fperms 04450 /sbin/ipw3945d
keepdir /var/run/ipw3945d
- chown ipw3945d:root "${D}/var/run/ipw3945d"
+ fowners ipw3945d:root /var/run/ipw3945d
newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
newinitd "${FILESDIR}/${PN}-init.d" ${PN}
@@ -57,13 +57,13 @@ pkg_postinst() {
# These nasty live-filesystem fixes are needed, because if the files are
# already there, the permissions applied in src_install() won't get
- # transferred to the live filesystem. Once portage is fixed with regard to
+ # merged to the live filesystem. Once portage is fixed with regard to
# this, these hacks can go away.
# Fix the permissions of /sbin/ipw3945d
ebegin "Fixing permissions of ${ROOT}sbin/ipw3945d"
- chmod 04450 "${ROOT}sbin/ipw3945d"
chown ipw3945d:root "${ROOT}sbin/ipw3945d"
+ chmod 04450 "${ROOT}sbin/ipw3945d"
eend $?
# Fixing ownership of /var/run/ipw3945d