summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-23 14:36:24 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-23 14:36:24 +0000
commitc0ddccc68015b5c46d0ad87edf300cdba91767c1 (patch)
tree654fbdbc1af0297c23d14fc68ef52f743a06a351 /net-www/gnash/gnash-0.8.0.ebuild
parentstable x86, bug 186180 (diff)
downloadgentoo-2-c0ddccc68015b5c46d0ad87edf300cdba91767c1.tar.gz
gentoo-2-c0ddccc68015b5c46d0ad87edf300cdba91767c1.tar.bz2
gentoo-2-c0ddccc68015b5c46d0ad87edf300cdba91767c1.zip
Fix building with --as-needed and swscaler enabled ffmpeg-20070616-r1 for bug 183714.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'net-www/gnash/gnash-0.8.0.ebuild')
-rw-r--r--net-www/gnash/gnash-0.8.0.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/net-www/gnash/gnash-0.8.0.ebuild b/net-www/gnash/gnash-0.8.0.ebuild
index a9c0aead945e..11ffc62186e0 100644
--- a/net-www/gnash/gnash-0.8.0.ebuild
+++ b/net-www/gnash/gnash-0.8.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.8.0.ebuild,v 1.5 2007/07/22 07:44:54 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.8.0.ebuild,v 1.6 2007/07/23 14:36:24 drac Exp $
+
+WANT_AUTOMAKE="1.9"
inherit nsplugins kde-functions qt3 multilib flag-o-matic autotools
-set-kdedir
+set-kdedir eutils
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
@@ -49,6 +51,9 @@ RDEPEND="
agg? ( x11-libs/agg )"
#cairo? ( x11-libs/cairo )
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
pkg_setup() {
if use agg && use kde; then
eerror "Building klash with the agg based renderer is not supported"
@@ -75,13 +80,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
- #as-needed breaks, see bug 183714
- #
- # TODO - does not work for me
- #epatch ${FILESDIR}/gnash-no-asneeded.patch
- #filter-ldflags -Wl,--as-needed --as-needed
- #eautoconf
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ffmpeg.patch
+ eautoconf
+ eautomake
}
src_compile() {