summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-02-06 02:27:28 +0000
committerDean Bailey <alron@gentoo.org>2003-02-06 02:27:28 +0000
commit6ced13795ee6cefaf4a185f301162e54ca20d41d (patch)
tree383cef33134b35b287928f5dd3250232454306c6 /net-www/horde-imp
parentpatch for 15/24 bit display endian problems on ppc (diff)
downloadgentoo-2-6ced13795ee6cefaf4a185f301162e54ca20d41d.tar.gz
gentoo-2-6ced13795ee6cefaf4a185f301162e54ca20d41d.tar.bz2
gentoo-2-6ced13795ee6cefaf4a185f301162e54ca20d41d.zip
added version 3.2_rc1 of horde-IMP due to security issues. it is masked with a -x86 and such as it is still a RC.
Diffstat (limited to 'net-www/horde-imp')
-rw-r--r--net-www/horde-imp/ChangeLog7
-rw-r--r--net-www/horde-imp/files/digest-horde-imp-3.2_rc11
-rw-r--r--net-www/horde-imp/horde-imp-3.2_rc1.ebuild91
3 files changed, 98 insertions, 1 deletions
diff --git a/net-www/horde-imp/ChangeLog b/net-www/horde-imp/ChangeLog
index f3902561f9ec..987b8e4f9897 100644
--- a/net-www/horde-imp/ChangeLog
+++ b/net-www/horde-imp/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-www/horde-imp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/ChangeLog,v 1.4 2002/12/17 19:46:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/ChangeLog,v 1.5 2003/02/06 02:27:28 alron Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*horde-imp-3.2_rc1 (05 Feb 2003)
+ 05 Feb 2003; Dean Bailey <alron@gentoo.org> horde-imp-3.2_rc1 :
+ Added 3.2-RC1 of IMP. Masked as -x86 so on. This version fixes a bunch of bugs/security issues. Mostly
+ dealing with temp files for attachment uploads, and sessions.
+
*horde-imp-3.1 (31 Oct 2002)
31 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> horde-imp-2.1.ebuild files/digest-horde-imp-3.1 :
diff --git a/net-www/horde-imp/files/digest-horde-imp-3.2_rc1 b/net-www/horde-imp/files/digest-horde-imp-3.2_rc1
new file mode 100644
index 000000000000..8619b6790810
--- /dev/null
+++ b/net-www/horde-imp/files/digest-horde-imp-3.2_rc1
@@ -0,0 +1 @@
+MD5 6f7f01124ff3d4282c08cd0ef37093bd imp-3.2-RC1.tar.gz 1247519
diff --git a/net-www/horde-imp/horde-imp-3.2_rc1.ebuild b/net-www/horde-imp/horde-imp-3.2_rc1.ebuild
new file mode 100644
index 000000000000..18b49a298b86
--- /dev/null
+++ b/net-www/horde-imp/horde-imp-3.2_rc1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2_rc1.ebuild,v 1.1 2003/02/06 02:27:28 alron Exp $
+
+DESCRIPTION="IMP ${PV} provides webmail access"
+HOMEPAGE="http://www.horde.org"
+P=imp-3.2
+SRC_URI="ftp://ftp.horde.org/pub/imp/tarballs/imp-3.2-RC1.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="-x86 -ppc -sparc -alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.1"
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep imap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREP}" != "" ]; then
+ return 0
+ else
+ eerror "Missing IMAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ # FIXME: With time, apache's GID should be static
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+
+ dodir ${HTTPD_ROOT}/horde/imp
+ cp -r . ${D}/${HTTPD_ROOT}/horde/imp
+
+ # protecting files
+ chown -R root.${GID} ${D}/${HTTPD_ROOT}/horde/imp
+ find ${D}/${HTTPD_ROOT}/horde/imp/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/imp/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+
+ find_http_root
+
+ # add module in horde
+ sed -e "/^\/\/.*\(\$this->applications\['imp'\].*\)/ \
+ { : next ; N ; /\;/ { s/\/\///g ; b } ; b next }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+
+ # end
+ einfo "Please read ${HTTPD_ROOT}/horde/imp/docs/INSTALL !"
+}
+
+pkg_prerm() {
+ find_http_root
+
+ # rm module from horde
+ sed -e "/\(\$this->applications\['imp'\].*\)/ \
+ { s/\(.*\)/\/\/\1/g; : suite ; N ; /\;/ { s/\n/\n\/\//g ; b } ; \
+ b suite }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+}