summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-02 09:06:09 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-02 09:06:09 +0000
commit18edbc35db05e834132d74ab8dfd549a506c4cf0 (patch)
tree78d3ed85d3a9a4677239e4bc1dd89c98aad347a9 /net-www/mozilla
parentChanged SRC_URI to use sf mirror (diff)
downloadgentoo-2-18edbc35db05e834132d74ab8dfd549a506c4cf0.tar.gz
gentoo-2-18edbc35db05e834132d74ab8dfd549a506c4cf0.tar.bz2
gentoo-2-18edbc35db05e834132d74ab8dfd549a506c4cf0.zip
fix extension support
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/ChangeLog7
-rw-r--r--net-www/mozilla/mozilla-1.2.ebuild12
2 files changed, 14 insertions, 5 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 02d89f907e6b..f25469a8ee72 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.55 2002/12/02 01:05:01 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.56 2002/12/02 09:06:09 azarah Exp $
+
+ 02 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.ebuild :
+
+ Change --with-extensions to --enable-extensions. Add "mznoirc"
+ USE flag. This closes 11452.
02 Dec 2002; Maik Schreiber <blizzy@gentoo.org> files/digest-mozilla-1.2:
Fixed digest.
diff --git a/net-www/mozilla/mozilla-1.2.ebuild b/net-www/mozilla/mozilla-1.2.ebuild
index 6ba337cbb47d..6884c211e6a3 100644
--- a/net-www/mozilla/mozilla-1.2.ebuild
+++ b/net-www/mozilla/mozilla-1.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.2.ebuild,v 1.4 2002/12/01 23:39:25 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.2.ebuild,v 1.5 2002/12/02 09:06:09 azarah Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome"
# Internal USE flags that I do not really want to advertise ...
-IUSE="${IUSE} mozsvg mozcalendar mozaccess mozinterfaceinfo mozp3p mozxmlterm moznomail moznocompose"
+IUSE="${IUSE} mozsvg mozcalendar mozaccess mozinterfaceinfo mozp3p mozxmlterm moznoirc moznomail moznocompose"
inherit flag-o-matic gcc makeedit eutils nsplugins
@@ -277,7 +277,7 @@ src_compile() {
# is just here for completeness. Please do not use if you
# do not know what you are doing!
#
- # The defaults are (as of 1.0rc1, according to configure (line ~11445)):
+ # The defaults are (as of 1.2, according to configure (line ~11445)):
# cookie, wallet, content-packs, xml-rpc, xmlextras, help, pref, transformiix,
# venkman, inspector, irc, universalchardet, typeaheadfind
# Non-defaults are:
@@ -299,6 +299,10 @@ src_compile() {
then
myext="${myext},interfaceinfo"
fi
+ if [ -n "`use moznoirc`" ]
+ then
+ myext="${myext},-irc"
+ fi
if [ -n "`use mozsvg`" ]
then
@@ -412,7 +416,7 @@ src_compile() {
--enable-crypto \
--with-java-supplement \
--with-pthreads \
- --with-extensions="${myext}" \
+ --enable-extensions="${myext}" \
--enable-optimize="-O2" \
--with-default-mozilla-five-home=/usr/lib/mozilla \
${myconf} || die