summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-26 18:30:32 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-26 18:30:32 +0000
commit803ba767df7b86390ea9a9cc9373b7f506339c6d (patch)
treedf2afb6301bfd319c86dc80a06011f44ad584eba /net-www/mozilla
parent<geoman-campus> that CFLAG information that was discussed on #gentoo-mips was... (diff)
downloadgentoo-2-803ba767df7b86390ea9a9cc9373b7f506339c6d.tar.gz
gentoo-2-803ba767df7b86390ea9a9cc9373b7f506339c6d.tar.bz2
gentoo-2-803ba767df7b86390ea9a9cc9373b7f506339c6d.zip
Fix bug 47870 (mozilla fails to compile with gcc 3.4) with one-line patch. The patch doesn't seem to apply to 1.7, hopefully the problem is already fixed there
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/ChangeLog8
-rw-r--r--net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch11
-rw-r--r--net-www/mozilla/mozilla-1.6-r1.ebuild6
3 files changed, 23 insertions, 2 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 1a33f7454617..6f460a3a0400 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mozilla
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.162 2004/04/26 15:27:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.163 2004/04/26 18:30:32 agriffis Exp $
+
+ 26 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+ +files/mozilla-1.6-gcc-3.4.patch, mozilla-1.6-r1.ebuild:
+ Fix bug 47870 (mozilla fails to compile with gcc 3.4) with one-line patch. The
+ patch doesn't seem to apply to 1.7, hopefully the problem is already fixed
+ there
26 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+files/mozilla-1.7-amd64.patch, mozilla-1.7_beta-r1.ebuild,
diff --git a/net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch b/net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch
new file mode 100644
index 000000000000..9de10a1fae8c
--- /dev/null
+++ b/net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch
@@ -0,0 +1,11 @@
+--- gfx/public/nsRegion.h.old 2003-03-25 02:57:42.000000000 +0000
++++ gfx/public/nsRegion.h 2004-04-23 02:25:09.606368256 +0100
+@@ -234,7 +234,7 @@
+ void MoveInto (nsRegion& aDestRegion)
+ { MoveInto (aDestRegion, mRectListHead.next); }
+
+- nsRegion (const nsRegion& aRegion); // Prevent copying of regions
++ public:nsRegion (const nsRegion& aRegion); // Prevent copying of regions
+ nsRegion& operator = (const nsRegion& aRegion);
+ };
+
diff --git a/net-www/mozilla/mozilla-1.6-r1.ebuild b/net-www/mozilla/mozilla-1.6-r1.ebuild
index e617033d3aca..421b8ce31d90 100644
--- a/net-www/mozilla/mozilla-1.6-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.6-r1.ebuild,v 1.9 2004/04/26 04:38:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.6-r1.ebuild,v 1.10 2004/04/26 18:30:32 agriffis Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome debug xinerama"
# Internal USE flags that I do not really want to advertise ...
@@ -148,6 +148,10 @@ src_unpack() {
# <azarah@gentoo.org> (23 Feb 2003)
epatch ${FILESDIR}/1.3/${PN}-1.3-fix-RAW-target.patch
+ # Fix compilation with gcc-3.4, bug 47870
+ # (26 Apr 2004 agriffis)
+ epatch ${FILESDIR}/mozilla-1.6-gcc-3.4.patch
+
export WANT_AUTOCONF=2.1
autoconf &> /dev/null
unset WANT_AUTOCONF