summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2004-05-20 20:37:53 +0000
committerJoel Martin <kanaka@gentoo.org>2004-05-20 20:37:53 +0000
commitb27967bea4cda7125538662c1009696455704ea3 (patch)
treebd35d5779d5bc00c7820ef10202c3dce1bc272a9 /net-www/mplayerplug-in/mplayerplug-in-0.91.ebuild
parentFixed BUG #51439, ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-b27967bea4cda7125538662c1009696455704ea3.tar.gz
gentoo-2-b27967bea4cda7125538662c1009696455704ea3.tar.bz2
gentoo-2-b27967bea4cda7125538662c1009696455704ea3.zip
Yeah, so it would be good not to remove the only stable version 0.91
Diffstat (limited to 'net-www/mplayerplug-in/mplayerplug-in-0.91.ebuild')
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-0.91.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-www/mplayerplug-in/mplayerplug-in-0.91.ebuild b/net-www/mplayerplug-in/mplayerplug-in-0.91.ebuild
new file mode 100644
index 000000000000..7d2d64aa81c3
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-0.91.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-0.91.ebuild,v 1.6 2004/05/20 20:37:53 kanaka Exp $
+
+IUSE=""
+
+inherit nsplugins
+
+S="${WORKDIR}/${PN}"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+DESCRIPTION="mplayer plug-in for Mozilla"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/mini.tar.bz2"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc"
+
+DEPEND=">=media-video/mplayer-0.91"
+
+src_compile() {
+ [ -z "${CC}" ] && CC="gcc"
+ emake CC="${CC}" OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so
+
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /usr/share/mplayer/Skin/mini
+ doins ${WORKDIR}/mini/*
+
+ dodir /etc
+ # For some reason this does not work yet for mplayer options, and
+ # setting 'vo' cause it for 'mozilla file:///space/movies/foo.avi'
+ # at least to not work...
+ cat > ${D}/etc/mplayerplug-in.conf <<END
+# Should it handle embedded movies ?
+noembed=0
+
+# Set to 'mini' if you want the seek bar
+use-gui=no
+
+# Normal mplayer style config options
+#vo=x11
+fs=no
+zoom=yes
+
+# Disable some video formats
+#enable-real=0
+#enable-qt=0
+#enable-wm=0
+#enable-mpeg=0
+END
+
+ dodoc TODO ChangeLog INSTALL README
+}