summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Coles <sj7trunks@gentoo.org>2003-12-01 20:09:08 +0000
committerBenjamin Coles <sj7trunks@gentoo.org>2003-12-01 20:09:08 +0000
commit07dbcec560d0ee17f1cafe071f9031aaa97e3bc3 (patch)
treef0eac1068b0d5e1f83ae72fe35fb767bd46f14f6 /net-www
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-07dbcec560d0ee17f1cafe071f9031aaa97e3bc3.tar.gz
gentoo-2-07dbcec560d0ee17f1cafe071f9031aaa97e3bc3.tar.bz2
gentoo-2-07dbcec560d0ee17f1cafe071f9031aaa97e3bc3.zip
Fixed whitespace
Diffstat (limited to 'net-www')
-rw-r--r--net-www/bugzilla/bugzilla-2.17.6-r1.ebuild82
1 files changed, 41 insertions, 41 deletions
diff --git a/net-www/bugzilla/bugzilla-2.17.6-r1.ebuild b/net-www/bugzilla/bugzilla-2.17.6-r1.ebuild
index 96c70a4e8de6..e0272b5b2433 100644
--- a/net-www/bugzilla/bugzilla-2.17.6-r1.ebuild
+++ b/net-www/bugzilla/bugzilla-2.17.6-r1.ebuild
@@ -59,63 +59,63 @@ src_install () {
}
pkg_config() {
- # moved here as it doesn't work in a sandbox
- cd /var/www/bugzilla || die
- if ( test -a localconfig ) ; then
- die "The following does not work on previous installations, please run checksetup.pl in /var/www/bugzilla followed by a chown -R apache:apache /var/www/bugzilla."
- fi
+ # moved here as it doesn't work in a sandbox
+ cd /var/www/bugzilla || die
+ if ( test -a localconfig ) ; then
+ die "The following does not work on previous installations, please run checksetup.pl in /var/www/bugzilla followed by a chown -R apache:apache /var/www/bugzilla."
+ fi
- einfo "Finalizing the installation of bugzilla in /var/www/bugzilla"
+ einfo "Finalizing the installation of bugzilla in /var/www/bugzilla"
- echo -n "mysql root dbuser password: "; read myrootpwd
- if (test -z $myrootpwd) ; then eerror "No root db password" ; die ; fi
+ echo -n "mysql root dbuser password: "; read myrootpwd
+ if (test -z $myrootpwd) ; then eerror "No root db password" ; die ; fi
- echo -n "mysql bugs db name [bugs]: "; read mybugsdb
- if (test -z $mybugsdb) ; then mybugsdb="bugs" ; fi
+ echo -n "mysql bugs db name [bugs]: "; read mybugsdb
+ if (test -z $mybugsdb) ; then mybugsdb="bugs" ; fi
- echo -n "mysql bugs db host [localhost]: "; read mybugshost
- if (test -z $mybugshost) ; then mybugshost="localhost" ; fi
+ echo -n "mysql bugs db host [localhost]: "; read mybugshost
+ if (test -z $mybugshost) ; then mybugshost="localhost" ; fi
- echo -n "mysql bugs dbuser name [bugs]: "; read mybugsuser
- if (test -z $mybugsuser) ; then mybugsuser="bugs" ; fi
+ echo -n "mysql bugs dbuser name [bugs]: "; read mybugsuser
+ if (test -z $mybugsuser) ; then mybugsuser="bugs" ; fi
- echo -n "mysql bugs dbuser password: "; read mybugspwd
- if (test -z $mybugspwd) ; then eerror "No dbuser password" ; die ; fi
+ echo -n "mysql bugs dbuser password: "; read mybugspwd
+ if (test -z $mybugspwd) ; then eerror "No dbuser password" ; die ; fi
- cat bz.cfg.templ | sed -e "s/tmpdbname/${mybugsdb}/" > bz.cfg.templ.1
- cat bz.cfg.templ.1 | sed -e "s/tmphost/${mybugshost}/" > bz.cfg.templ.2
- cat bz.cfg.templ.2 | sed -e "s/tmpdbuser/${mybugsuser}/" > bz.cfg.templ.3
- cat bz.cfg.templ.3 | sed -e "s/tmpdbpass/${mybugspwd}/" > bz.cfg.pl
+ cat bz.cfg.templ | sed -e "s/tmpdbname/${mybugsdb}/" > bz.cfg.templ.1
+ cat bz.cfg.templ.1 | sed -e "s/tmphost/${mybugshost}/" > bz.cfg.templ.2
+ cat bz.cfg.templ.2 | sed -e "s/tmpdbuser/${mybugsuser}/" > bz.cfg.templ.3
+ cat bz.cfg.templ.3 | sed -e "s/tmpdbpass/${mybugspwd}/" > bz.cfg.pl
- if [ ! -f bz.cfg.pl ] ; then eerror "No template for db vars" ; die ; fi
+ if [ ! -f bz.cfg.pl ] ; then eerror "No template for db vars" ; die ; fi
- rm bz.cfg.templ.[0-9]* || die
+ rm bz.cfg.templ.[0-9]* || die
- einfo "Setting correct privelegies"
- mysql --password=${myrootpwd} mysql --exec="GRANT SELECT,INSERT,UPDATE,DELETE,INDEX, ALTER,CREATE,DROP,REFERENCES ON ${mybugsdb}.* TO ${mybugsuser}@${mybugshost} IDENTIFIED BY '${mybugspwd}'; FLUSH PRIVILEGES;" || die
+ einfo "Setting correct privelegies"
+ mysql --password=${myrootpwd} mysql --exec="GRANT SELECT,INSERT,UPDATE,DELETE,INDEX, ALTER,CREATE,DROP,REFERENCES ON ${mybugsdb}.* TO ${mybugsuser}@${mybugshost} IDENTIFIED BY '${mybugspwd}'; FLUSH PRIVILEGES;" || die
- einfo "Setting the template for localconfig variables"
- ./checksetup.pl bz.cfg.pl || die
- chown -R apache:apache /var/www/bugzilla || die
+ einfo "Setting the template for localconfig variables"
+ ./checksetup.pl bz.cfg.pl || die
+ chown -R apache:apache /var/www/bugzilla || die
- einfo "Final step: setting all html templates and db tables"
- chmod 750 /var/www/bugzilla/firstcheck.sh
- ./firstcheck.sh || die
+ einfo "Final step: setting all html templates and db tables"
+ chmod 750 /var/www/bugzilla/firstcheck.sh
+ ./firstcheck.sh || die
- echo -n "Do you want to set a crontab [y/N]" ; read cronyes
- chmod 750 /var/www/bugzilla/cronset.sh
- if ( test $cronyes = "y") ; then su - apache -c /var/www/bugzilla/cronset.sh ; fi
+ echo -n "Do you want to set a crontab [y/N]" ; read cronyes
+ chmod 750 /var/www/bugzilla/cronset.sh
+ if ( test $cronyes = "y") ; then su - apache -c /var/www/bugzilla/cronset.sh ; fi
- chown -R apache:apache /var/www/bugzilla || die
+ chown -R apache:apache /var/www/bugzilla || die
- einfo "Then you just have to :"
- einfo "append to apache/conf: Include conf/bugzilla.conf"
- einfo "Restart Apache"
- einfo "login on http://yourhost/bugzilla/index.cgi and edit global parameters click *parameters* at the bottom"
- einfo "enjoy bugzilla!"
+ einfo "Then you just have to :"
+ einfo "append to apache/conf: Include conf/bugzilla.conf"
+ einfo "Restart Apache"
+ einfo "login on http://yourhost/bugzilla/index.cgi and edit global parameters click *parameters* at the bottom"
+ einfo "enjoy bugzilla!"
}
pkg_postinst() {
- einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
-}
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ }