summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-12 19:50:32 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-12 19:50:32 +0000
commit601cbc3807e7fe4dc063e5ce17d9833c842eb16f (patch)
tree9099d70413d1434d668493bd3245a0a75c285358 /net-www
parentadd /etc/default/ to fix adduser -D (diff)
downloadgentoo-2-601cbc3807e7fe4dc063e5ce17d9833c842eb16f.tar.gz
gentoo-2-601cbc3807e7fe4dc063e5ce17d9833c842eb16f.tar.bz2
gentoo-2-601cbc3807e7fe4dc063e5ce17d9833c842eb16f.zip
svg support
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/mozilla-1.0-r3.ebuild10
-rw-r--r--net-www/mozilla/mozilla-1.0.1-r1.ebuild10
-rw-r--r--net-www/mozilla/mozilla-1.1-r1.ebuild10
3 files changed, 21 insertions, 9 deletions
diff --git a/net-www/mozilla/mozilla-1.0-r3.ebuild b/net-www/mozilla/mozilla-1.0-r3.ebuild
index 5a9688bf9bdf..a9be4d494d62 100644
--- a/net-www/mozilla/mozilla-1.0-r3.ebuild
+++ b/net-www/mozilla/mozilla-1.0-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0-r3.ebuild,v 1.15 2002/10/11 18:50:20 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0-r3.ebuild,v 1.16 2002/10/12 19:50:32 azarah Exp $
-IUSE="moznomail java mozp3p mozaccess gtk2 mozinterfaceinfo ssl ldap mozxmlterm mozctl gnome"
+IUSE="moznomail java mozp3p mozaccess gtk2 mozinterfaceinfo ssl ldap mozxmlterm mozctl gnome mozsvg"
inherit makeedit
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
@@ -179,6 +179,11 @@ src_compile() {
myext="${myext},interfaceinfo"
fi
+ if [ -n "`use mozsvg`" ] ; then
+ myconf="${myconf} --enable-svg"
+ else
+ myconf="${myconf} --disable-svg"
+ fi
if [ -n "`use moznomail`" ] || \
[ "${NO_MAIL}" = "YES" ] || [ "${NO_MAIL}" = "yes" ]
@@ -205,7 +210,6 @@ src_compile() {
./configure --prefix=/usr/lib/mozilla \
--disable-pedantic \
- --disable-svg \
--enable-mathml \
--without-system-nspr \
--enable-nspr-autoconf \
diff --git a/net-www/mozilla/mozilla-1.0.1-r1.ebuild b/net-www/mozilla/mozilla-1.0.1-r1.ebuild
index 93558e8d5678..ca8437453c9e 100644
--- a/net-www/mozilla/mozilla-1.0.1-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.0.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0.1-r1.ebuild,v 1.6 2002/10/11 18:50:20 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0.1-r1.ebuild,v 1.7 2002/10/12 19:50:32 azarah Exp $
-IUSE="mozxmlterm moznomail java mozp3p crypt ipv6 gtk2 mozinterfaceinfo ssl ldap mozaccess mozctl gnome"
+IUSE="mozxmlterm moznomail java mozp3p crypt ipv6 gtk2 mozinterfaceinfo ssl ldap mozaccess mozctl gnome mozsvg"
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
inherit flag-o-matic gcc makeedit
@@ -168,6 +168,11 @@ src_compile() {
myext="${myext},interfaceinfo"
fi
+ if [ -n "`use mozsvg`" ] ; then
+ myconf="${myconf} --enable-svg"
+ else
+ myconf="${myconf} --disable-svg"
+ fi
if [ -n "`use moznomail`" ] || \
[ "${NO_MAIL}" = "YES" -o "${NO_MAIL}" = "yes" ]
@@ -198,7 +203,6 @@ src_compile() {
./configure --prefix=/usr/lib/mozilla \
--disable-pedantic \
- --disable-svg \
--enable-mathml \
--without-system-nspr \
--enable-nspr-autoconf \
diff --git a/net-www/mozilla/mozilla-1.1-r1.ebuild b/net-www/mozilla/mozilla-1.1-r1.ebuild
index 414aed7ceabc..b81262afeeeb 100644
--- a/net-www/mozilla/mozilla-1.1-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1-r1.ebuild,v 1.6 2002/10/11 18:50:20 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1-r1.ebuild,v 1.7 2002/10/12 19:50:32 azarah Exp $
-IUSE="moznomail java mozp3p crypt ldap gtk2 mozinterfaceinfo ssl mozaccess mozxmlterm mozctl gnome"
+IUSE="moznomail java mozp3p crypt ldap gtk2 mozinterfaceinfo ssl mozaccess mozxmlterm mozctl gnome mozsvg"
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
inherit makeedit
@@ -160,6 +160,11 @@ src_compile() {
myext="${myext},interfaceinfo"
fi
+ if [ -n "`use mozsvg`" ] ; then
+ myconf="${myconf} --enable-svg"
+ else
+ myconf="${myconf} --disable-svg"
+ fi
if [ -n "`use moznomail`" ] || \
[ "${NO_MAIL}" = "YES" ] || [ "${NO_MAIL}" = "yes" ]
@@ -190,7 +195,6 @@ src_compile() {
./configure --prefix=/usr/lib/mozilla \
--disable-pedantic \
- --disable-svg \
--enable-mathml \
--without-system-nspr \
--enable-nspr-autoconf \