summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-03 21:46:01 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-03 21:46:01 +0000
commita90260cf5e772a5f78c9227f42e39b80a38d997d (patch)
tree5b9ae7783869dc1693cffd81da1adce4e875f26c /net-www
parentA missing but required patch (diff)
downloadgentoo-2-a90260cf5e772a5f78c9227f42e39b80a38d997d.tar.gz
gentoo-2-a90260cf5e772a5f78c9227f42e39b80a38d997d.tar.bz2
gentoo-2-a90260cf5e772a5f78c9227f42e39b80a38d997d.zip
Update
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/apache-1.3.22-r6.ebuild102
-rw-r--r--net-www/apache/files/digest-apache-1.3.22-r62
2 files changed, 104 insertions, 0 deletions
diff --git a/net-www/apache/apache-1.3.22-r6.ebuild b/net-www/apache/apache-1.3.22-r6.ebuild
new file mode 100644
index 000000000000..e61b52103d99
--- /dev/null
+++ b/net-www/apache/apache-1.3.22-r6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.22-r6.ebuild,v 1.1 2001/11/03 21:46:01 achim Exp $
+
+AV="1.3.22"
+MSV="2.8.5"
+
+A="apache_${AV}.tar.gz mod_ssl-${MSV}-${AV}.tar.gz"
+S=${WORKDIR}/apache_${AV}
+DESCRIPTION="The Apache Web Server"
+HOMEPAGE="http://www.apache.org http://www.modssl.org"
+SRC_URI="http://httpd.apache.org/dist/httpd/apache_${AV}.tar.gz
+ ftp://ftp.modssl.org/source/mod_ssl-${MSV}-${AV}.tar.gz"
+
+DEPEND="virtual/glibc
+ >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_compile() {
+
+ local myconf
+ export SSL_BASE=SYSTEM
+ export CFLAGS="${CFLAGS} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ export RULE_EXPAT=NO
+
+ if [ "`use ssl`" ]; then
+ myconf="${myconf} --enable-module=ssl"
+ cd ${S}/../mod_ssl-${MSV}-${AV}
+ ./configure --with-apache=${S} --with-ssl=SYSTEM || die
+ cd ${S}
+ fi
+
+ ./configure --prefix=/usr/local/httpd --bindir=/usr/bin \
+ --sbindir=/usr/sbin --datadir=/usr/local/httpd \
+ --sysconfdir=/etc/httpd --libexecdir=/usr/lib/apache \
+ --mandir=/usr/share/man --logfiledir=/var/log/apache --localstatedir=/var/lock \
+ --proxycachedir=/var/cache/httpd --includedir=/usr/include/apache \
+ --enable-module=all \
+ --enable-shared=max --suexec-caller=wwwrun \
+ --suexec-userdir=public_html --suexec-uidmin=96 \
+ --suexec-gidmin=96 --suexec-safepath="/bin:/usr/bin" \
+ --disable-rule=EXPAT --with-perl=/usr/bin/perl ${myconf}
+ assert "bad configure"
+
+ make || die "compile problem"
+ use ssl && ( make certificate TYPE=dummy || die "make ssl certificate failed" )
+}
+
+src_install() {
+
+ make install-quiet root=${D} || die
+ dodoc ABOUT_APACHE Announcement INSTALL* KEYS LICENSE* README* WARNING* ${FILESDIR}/httpd.conf
+ dosed "s:^PIDFILE.*:PIDFILE=/var/run/httpd.pid:" /usr/sbin/apachectl
+ dosed "s:/usr/local/bin/perl5:/usr/bin/perl:" \
+ /usr/local/httpd/htdocs/manual/search/manual-index.cgi
+
+ if [ "`use ssl`" ] ; then
+ cd ../mod_ssl-${MSV}-${AV}
+ docinto mod_ssl
+ dodoc ANNOUNCE CHANGES CREDITS INSTALL* LICENSE NEWS README*
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/httpd.rc6 httpd
+ insinto /etc/httpd
+ doins ${FILESDIR}/httpd.conf
+}
+
+pkg_config() {
+
+ #${ROOT}/sbin/rc-update add httpd default
+
+ if [ "$ServerName" = "" ] ; then
+ ServerName=`uname -n`
+ fi
+ if [ "$ServerAdmin" = "" ] ; then
+ ServerAdmin="webmaster\@$ServerName"
+ fi
+
+ mv ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
+ sed -e "s/^\#ServerName.*/ServerName $ServerName/" \
+ -e "s/^ServerName.*/ServerName $ServerName/" \
+ -e "s/^ServerAdmin.*/ServerAdmin $ServerAdmin/" \
+ ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
+}
+
+pkg_prerm() {
+
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/httpd ] ; then
+ /etc/init.d/httpd stop
+ fi
+ return # dont fail
+}
+
+pkg_preinst() {
+
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/httpd ] ; then
+ /etc/init.d/httpd stop
+ fi
+ return # dont fail
+}
diff --git a/net-www/apache/files/digest-apache-1.3.22-r6 b/net-www/apache/files/digest-apache-1.3.22-r6
new file mode 100644
index 000000000000..33b061a3d9a0
--- /dev/null
+++ b/net-www/apache/files/digest-apache-1.3.22-r6
@@ -0,0 +1,2 @@
+MD5 77d34c0ac49c3af2416b786228007f90 apache_1.3.22.tar.gz 2179072
+MD5 5139c874e759b8410a29f9dcb4b578e5 mod_ssl-2.8.5-1.3.22.tar.gz 753664