summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-11 17:04:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-11 17:04:14 +0000
commitb728ec8d1af8eb08a57c9d762606613cbad5d8be (patch)
treef906b18603f806bf65261633f2bc64f8c3454769 /net-www
parentVersion Bump (diff)
downloadgentoo-2-b728ec8d1af8eb08a57c9d762606613cbad5d8be.tar.gz
gentoo-2-b728ec8d1af8eb08a57c9d762606613cbad5d8be.tar.bz2
gentoo-2-b728ec8d1af8eb08a57c9d762606613cbad5d8be.zip
Version Bump
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phpBB/ChangeLog7
-rw-r--r--net-www/phpBB/Manifest4
-rw-r--r--net-www/phpBB/files/digest-phpBB-2.0.61
-rw-r--r--net-www/phpBB/phpBB-2.0.6.ebuild48
4 files changed, 57 insertions, 3 deletions
diff --git a/net-www/phpBB/ChangeLog b/net-www/phpBB/ChangeLog
index 99e13fcd41ee..eae1fc975855 100644
--- a/net-www/phpBB/ChangeLog
+++ b/net-www/phpBB/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/phpBB
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.3 2003/06/20 08:53:37 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.4 2003/08/11 17:04:09 robbat2 Exp $
+
+*phpBB-2.0.6 (11 Aug 2003)
+
+ 11 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> phpBB-2.0.6.ebuild:
+ Version Bump
*phpBB-2.0.5 (20 Jun 2003)
diff --git a/net-www/phpBB/Manifest b/net-www/phpBB/Manifest
index 7a4a7b8776e5..4f1a4b0f5272 100644
--- a/net-www/phpBB/Manifest
+++ b/net-www/phpBB/Manifest
@@ -1,7 +1,7 @@
MD5 d0f8dbc40d92b0ca4ca910a8f957aae3 phpBB-2.0.5.ebuild 1353
MD5 237a0ea1f90ae13d2aa9d080943bcb36 phpBB-2.0.4.ebuild 1388
-MD5 d0f8dbc40d92b0ca4ca910a8f957aae3 phpBB-2.0.6.ebuild 1353
-MD5 32872ab3ffa28c206638b05d5c6a66f9 ChangeLog 644
+MD5 bc7f000ff51e8314b25394f3fa5492e4 phpBB-2.0.6.ebuild 1354
+MD5 2f8cda34a25fc39f18cdd2be409fc626 ChangeLog 644
MD5 1c9cf1de5be80b37285838551452ebf4 files/digest-phpBB-2.0.4 63
MD5 b0e9ee3a18db6416eedbe05a7c409b36 files/digest-phpBB-2.0.5 63
MD5 d8c04c96ab7db9b65effac516a92b8ae files/digest-phpBB-2.0.6 63
diff --git a/net-www/phpBB/files/digest-phpBB-2.0.6 b/net-www/phpBB/files/digest-phpBB-2.0.6
new file mode 100644
index 000000000000..686427c8dabf
--- /dev/null
+++ b/net-www/phpBB/files/digest-phpBB-2.0.6
@@ -0,0 +1 @@
+MD5 9fcaa3148203159db03947998a3cba9d phpBB-2.0.6.tar.gz 544080
diff --git a/net-www/phpBB/phpBB-2.0.6.ebuild b/net-www/phpBB/phpBB-2.0.6.ebuild
new file mode 100644
index 000000000000..ea1b63f1af6a
--- /dev/null
+++ b/net-www/phpBB/phpBB-2.0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tim Raedisch <tim.raedisch@udo.edu>
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.6.ebuild,v 1.1 2003/08/11 17:04:09 robbat2 Exp $
+
+S=${WORKDIR}/${PN}2
+DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="http://belnet.dl.sourceforge.net/sourceforge/phpbb/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/php"
+
+inherit webapp-apache
+webapp-detect || NO_WEBSERVER=1
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+
+ if [ -d ${HTTPD_ROOT}/phpbb ] ; then
+ ewarn "You need to unmerge your old phpBB version first."
+ ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+
+ einfo "Installing for ${WEBAPP_SERVER}"
+}
+
+src_compile() {
+ #we need to have this empty function ... default compile hangs
+ echo "Nothing to compile"
+}
+
+src_install() {
+ cd ${S}
+ dodir "${HTTPD_ROOT}/phpbb"
+ cp -a * "${D}/${HTTPD_ROOT}/phpbb"
+ dodoc ${S}/docs/*
+
+ cd "${D}/${HTTPD_ROOT}"
+ chown -R "${HTTPD_USER}.${HTTPD_GROUP}" "${D}/${HTTPD_ROOT}/phpbb"
+}
+
+