summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2007-01-07 16:29:45 +0000
committerBryan Østergaard <kloeri@gentoo.org>2007-01-07 16:29:45 +0000
commitcf1fc3beb663cd61437e5fe5e4a2f7176b5fede7 (patch)
treea6811ba6e9609c11bca8a4a8c7de67a72c66488e /net-www
parentStable on Alpha. (diff)
downloadgentoo-2-cf1fc3beb663cd61437e5fe5e4a2f7176b5fede7.tar.gz
gentoo-2-cf1fc3beb663cd61437e5fe5e4a2f7176b5fede7.tar.bz2
gentoo-2-cf1fc3beb663cd61437e5fe5e4a2f7176b5fede7.zip
Version bump, fixes bug 148158.
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_auth_kerb/ChangeLog10
-rw-r--r--net-www/mod_auth_kerb/files/digest-mod_auth_kerb-5.33
-rw-r--r--net-www/mod_auth_kerb/mod_auth_kerb-5.3.ebuild40
3 files changed, 51 insertions, 2 deletions
diff --git a/net-www/mod_auth_kerb/ChangeLog b/net-www/mod_auth_kerb/ChangeLog
index 7b1782b727db..4e634167674c 100644
--- a/net-www/mod_auth_kerb/ChangeLog
+++ b/net-www/mod_auth_kerb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_auth_kerb
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.14 2006/06/05 19:24:00 chtekk Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.15 2007/01/07 16:29:45 kloeri Exp $
+
+*mod_auth_kerb-5.3 (07 Jan 2007)
+
+ 07 Jan 2007; Bryan Østergaard <kloeri@gentoo.org>
+ +mod_auth_kerb-5.3.ebuild:
+ Version bump, fixes bug 148158.
05 Jun 2006; Luca Longinotti <chtekk@gentoo.org>
-files/4.11-r1/11_mod_auth_kerb.conf, files/11_mod_auth_kerb.conf,
diff --git a/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-5.3 b/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-5.3
new file mode 100644
index 000000000000..a8b1de375280
--- /dev/null
+++ b/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-5.3
@@ -0,0 +1,3 @@
+MD5 a363588578050b3d320a2ceccf3ed666 mod_auth_kerb-5.3.tar.gz 73530
+RMD160 c1ba0dc27470ad4b355d795ba51374726ce57f03 mod_auth_kerb-5.3.tar.gz 73530
+SHA256 89cd779a94405521770cbcb169af5af61e7f2aad91c4f4b82efaae35df7595ec mod_auth_kerb-5.3.tar.gz 73530
diff --git a/net-www/mod_auth_kerb/mod_auth_kerb-5.3.ebuild b/net-www/mod_auth_kerb/mod_auth_kerb-5.3.ebuild
new file mode 100644
index 000000000000..0d60c1b2b52f
--- /dev/null
+++ b/net-www/mod_auth_kerb/mod_auth_kerb-5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.3.ebuild,v 1.1 2007/01/07 16:29:45 kloeri Exp $
+
+MY_PV="${PV/_rc/rc}"
+
+inherit eutils apache-module
+
+DESCRIPTION="An Apache2 authentication DSO using Kerberos."
+HOMEPAGE="http://modauthkerb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/modauthkerb/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~x86"
+IUSE="apache2"
+SLOT="0"
+
+DEPEND="virtual/krb5"
+RDEPEND=""
+
+APACHE1_MOD_CONF="11_${PN}"
+APACHE1_MOD_DEFINE="AUTH_KERB"
+
+APACHE2_MOD_CONF="11_${PN}"
+APACHE2_MOD_DEFINE="AUTH_KERB"
+
+DOCFILES="INSTALL README"
+
+need_apache
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ if use apache2 ; then
+ CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ else
+ CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+ fi
+ emake || die "make failed"
+}