summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-13 03:37:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-13 03:37:38 +0000
commitf3a678fed918fb8d3a92ecbe47d9a1f0dad516cb (patch)
tree02cb3a1947b879f39b7101c6346dfc11c312b683 /net-zope/zope-password/zope-password-3.5.1.ebuild
parentInitial addition. (diff)
downloadgentoo-2-f3a678fed918fb8d3a92ecbe47d9a1f0dad516cb.tar.gz
gentoo-2-f3a678fed918fb8d3a92ecbe47d9a1f0dad516cb.tar.bz2
gentoo-2-f3a678fed918fb8d3a92ecbe47d9a1f0dad516cb.zip
Initial addition.
(Portage version: 15059-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-password/zope-password-3.5.1.ebuild')
-rw-r--r--net-zope/zope-password/zope-password-3.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-zope/zope-password/zope-password-3.5.1.ebuild b/net-zope/zope-password/zope-password-3.5.1.ebuild
new file mode 100644
index 000000000000..22e01b5e82b7
--- /dev/null
+++ b/net-zope/zope-password/zope-password-3.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-password/zope-password-3.5.1.ebuild,v 1.1 2009/12/13 03:37:38 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Password encoding and checking utilities"
+HOMEPAGE="http://pypi.python.org/pypi/zope.password"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-component
+ net-zope/zope-interface
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"