summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-02-26 11:34:58 +0000
committerTorsten Veller <tove@gentoo.org>2009-02-26 11:34:58 +0000
commit9f035a857fb4821ae50523e4b38f33e043efe712 (patch)
tree21f545c032638cba3608a35bac759b1d2e0544e1 /perl-core/Module-Build
parentCleanup, getting ready for stabilization, ppc64 went for ~ppc64 because of gn... (diff)
downloadgentoo-2-9f035a857fb4821ae50523e4b38f33e043efe712.tar.gz
gentoo-2-9f035a857fb4821ae50523e4b38f33e043efe712.tar.bz2
gentoo-2-9f035a857fb4821ae50523e4b38f33e043efe712.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'perl-core/Module-Build')
-rw-r--r--perl-core/Module-Build/ChangeLog7
-rw-r--r--perl-core/Module-Build/Module-Build-0.32.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/perl-core/Module-Build/ChangeLog b/perl-core/Module-Build/ChangeLog
index bf016889920a..0e42551595b4 100644
--- a/perl-core/Module-Build/ChangeLog
+++ b/perl-core/Module-Build/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for perl-core/Module-Build
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.6 2009/01/14 14:31:44 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.7 2009/02/26 11:34:58 tove Exp $
+
+*Module-Build-0.32 (26 Feb 2009)
+
+ 26 Feb 2009; Torsten Veller <tove@gentoo.org> +Module-Build-0.32.ebuild:
+ Version bump
*Module-Build-0.31.012 (14 Jan 2009)
diff --git a/perl-core/Module-Build/Module-Build-0.32.ebuild b/perl-core/Module-Build/Module-Build-0.32.ebuild
new file mode 100644
index 000000000000..2f16e44a4b15
--- /dev/null
+++ b/perl-core/Module-Build/Module-Build-0.32.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/Module-Build-0.32.ebuild,v 1.1 2009/02/26 11:34:58 tove Exp $
+
+inherit versionator
+MODULE_AUTHOR=EWILHELM
+MY_P=${PN}-$(delete_version_separator 2)
+S=${WORKDIR}/${MY_P}
+inherit perl-module
+
+DESCRIPTION="Build and install Perl modules"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=virtual/perl-ExtUtils-CBuilder-0.15
+ >=virtual/perl-ExtUtils-ParseXS-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=virtual/perl-Archive-Tar-1.09
+ >=virtual/perl-Test-Harness-3.16"
+
+SRC_TEST="do"