summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-14 06:46:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-14 06:46:36 +0000
commit3002fcc79266622fb528141151ebe2d8f9de37bb (patch)
tree31557656b2f8f9be6a837f63a2292831b16b27e6 /perl-core
parentAdding maintainer notes from perl-exp overlay (diff)
downloadgentoo-2-3002fcc79266622fb528141151ebe2d8f9de37bb.tar.gz
gentoo-2-3002fcc79266622fb528141151ebe2d8f9de37bb.tar.bz2
gentoo-2-3002fcc79266622fb528141151ebe2d8f9de37bb.zip
Bump
(Portage version: 2.2.0/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/ExtUtils-MakeMaker/ChangeLog8
-rw-r--r--perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.720.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/perl-core/ExtUtils-MakeMaker/ChangeLog b/perl-core/ExtUtils-MakeMaker/ChangeLog
index c60544845849..bf9c7f53a3e5 100644
--- a/perl-core/ExtUtils-MakeMaker/ChangeLog
+++ b/perl-core/ExtUtils-MakeMaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/ExtUtils-MakeMaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.53 2013/04/20 17:00:35 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.54 2013/08/14 06:46:36 patrick Exp $
+
+*ExtUtils-MakeMaker-6.720.0 (14 Aug 2013)
+
+ 14 Aug 2013; Patrick Lauer <patrick@gentoo.org>
+ +ExtUtils-MakeMaker-6.720.0.ebuild:
+ Bump
20 Apr 2013; Matt Turner <mattst88@gentoo.org>
ExtUtils-MakeMaker-6.640.0.ebuild:
diff --git a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.720.0.ebuild b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.720.0.ebuild
new file mode 100644
index 000000000000..62b41176b31b
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.720.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.720.0.ebuild,v 1.1 2013/08/14 06:46:36 patrick Exp $
+
+EAPI=4
+MODULE_AUTHOR=BINGOS
+MODULE_VERSION=6.72
+inherit eutils perl-module
+
+DESCRIPTION="Create a module Makefile"
+HOMEPAGE="http://makemaker.org ${HOMEPAGE}"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-ExtUtils-Command-1.160.0
+ >=virtual/perl-ExtUtils-Install-1.540.0
+ >=virtual/perl-ExtUtils-Manifest-1.600.0
+ >=virtual/perl-File-Spec-0.800.0
+"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ >=virtual/perl-CPAN-Meta-2.112.621
+ >=virtual/perl-Parse-CPAN-Meta-1.440.100
+"
+
+PATCHES=(
+ "${FILESDIR}/6.62-delete_packlist_podlocal.patch"
+ "${FILESDIR}/6.58-RUNPATH.patch"
+)
+SRC_TEST=do
+
+src_prepare() {
+ edos2unix "${S}/lib/ExtUtils/MM_Unix.pm"
+ edos2unix "${S}/lib/ExtUtils/MM_Any.pm"
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # remove all the bundled distributions
+ pushd "${D}" >/dev/null
+ find ".${VENDOR_LIB}" -mindepth 1 -maxdepth 1 -not -name "ExtUtils" -exec rm -rf {} \+
+ popd >/dev/null
+}