summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-10-24 11:38:38 +0000
committerBen de Groot <yngwin@gentoo.org>2012-10-24 11:38:38 +0000
commit2e7ddb403b9f87c209467d40f58c766e222b01c7 (patch)
tree5a0b96df9947c4ce796edaf653466265b4a1ca87 /razorqt-base/razorqt-policykit/razorqt-policykit-0.5.1.ebuild
parentVersion bump (diff)
downloadgentoo-2-2e7ddb403b9f87c209467d40f58c766e222b01c7.tar.gz
gentoo-2-2e7ddb403b9f87c209467d40f58c766e222b01c7.tar.bz2
gentoo-2-2e7ddb403b9f87c209467d40f58c766e222b01c7.zip
Version bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'razorqt-base/razorqt-policykit/razorqt-policykit-0.5.1.ebuild')
-rw-r--r--razorqt-base/razorqt-policykit/razorqt-policykit-0.5.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/razorqt-base/razorqt-policykit/razorqt-policykit-0.5.1.ebuild b/razorqt-base/razorqt-policykit/razorqt-policykit-0.5.1.ebuild
new file mode 100644
index 000000000000..cfbd06ae50d1
--- /dev/null
+++ b/razorqt-base/razorqt-policykit/razorqt-policykit-0.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-policykit/razorqt-policykit-0.5.1.ebuild,v 1.1 2012/10/24 11:38:38 yngwin Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="A lightweight Qt-based PolicyKit agent"
+HOMEPAGE="http://razor-qt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Razor-qt/razor-qt.git"
+ EGIT_BRANCH="master"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/downloads/Razor-qt/razor-qt/razorqt-${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/razorqt-${PV}"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ razorqt-base/razorqt-libs
+ sys-auth/polkit-qt"
+RDEPEND="${DEPEND}
+ razorqt-base/razorqt-data"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSPLIT_BUILD=On
+ -DMODULE_POLICYKIT=On
+ )
+ cmake-utils_src_configure
+}