summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-01-31 00:10:58 +0000
committerJim Ramsay <lack@gentoo.org>2007-01-31 00:10:58 +0000
commitfdc1cedc45dabf0cc8d352b834c8635dcc0a2505 (patch)
tree47eedfed74287904c9789c0c3a1382c1db5fef6c /rox-extra/musicbox/musicbox-027-r1.ebuild
parentApply xprop/gtk d'n'd patch; thanks to Roland Kammerer. (bug #164429) (diff)
downloadgentoo-2-fdc1cedc45dabf0cc8d352b834c8635dcc0a2505.tar.gz
gentoo-2-fdc1cedc45dabf0cc8d352b834c8635dcc0a2505.tar.bz2
gentoo-2-fdc1cedc45dabf0cc8d352b834c8635dcc0a2505.zip
Added APPCATEGORY so a .desktop file will be installed
(Portage version: 2.1.2-r4)
Diffstat (limited to 'rox-extra/musicbox/musicbox-027-r1.ebuild')
-rw-r--r--rox-extra/musicbox/musicbox-027-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/rox-extra/musicbox/musicbox-027-r1.ebuild b/rox-extra/musicbox/musicbox-027-r1.ebuild
new file mode 100644
index 000000000000..9d77e04e6edd
--- /dev/null
+++ b/rox-extra/musicbox/musicbox-027-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/musicbox-027-r1.ebuild,v 1.1 2007/01/31 00:10:58 lack Exp $
+
+ROX_LIB_VER=2.0.0
+inherit rox eutils
+
+DESCRIPTION="MusicBox - an MP3/OGG Player for the ROX Desktop"
+HOMEPAGE="http://www.hayber.us/rox/MusicBox/"
+SRC_URI="http://www.hayber.us/rox/musicbox/MusicBox-027.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="mp3 vorbis flac alsa"
+
+DEPEND="
+ >=dev-python/pyao-0.81
+ alsa? ( >=dev-python/pyalsaaudio-0.2 )
+ mp3? (
+ >=dev-python/pymad-0.4.1
+ >=dev-python/pyid3lib-0.5.1 )
+ vorbis? ( >=dev-python/pyvorbis-1.1 )
+ flac? (
+ ~media-libs/flac-1.1.2
+ >=dev-lang/swig-1.3.25 )"
+
+RDEPEND="
+ >=dev-python/pyao-0.81
+ alsa? ( >=dev-python/pyalsaaudio-0.2 )
+ mp3? (
+ >=dev-python/pymad-0.4.1
+ >=dev-python/pyid3lib-0.5.1 )
+ vorbis? ( >=dev-python/pyvorbis-1.1 )
+ flac? ( >=media-libs/flac-1.1.2 )"
+
+APPNAME=MusicBox
+APPCATEGORY="AudioVideo;Audio;Player"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if use flac; then
+ if ! built_with_use dev-lang/swig python; then
+ einfo "MusicBox flac support requires swig with python support."
+ einfo "Please rebuild swig with USE=\"python\"."
+ die "swig python support missing"
+ fi
+ epatch ${FILESDIR}/${P}-fPIC.patch
+ fi
+ epatch ${FILESDIR}/${P}-mime.patch
+}
+
+# Special compilation needed for flac support
+src_compile() {
+ if use flac; then
+ cd "${S}/${APPNAME}/plugins/flac"
+ make || die "flac plugin compile failed."
+ fi
+ rox_src_compile
+}
+