summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-02-03 17:05:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-02-03 17:05:40 +0000
commit0f04d6501438e936486471965ff346ef06fae91f (patch)
tree1b30d8789535a9bbd8861c16466415975dfe912b /sci-astronomy/celestia/files
parentRemove trailing white space and shorten DESCRIPTION. (diff)
downloadgentoo-2-0f04d6501438e936486471965ff346ef06fae91f.tar.gz
gentoo-2-0f04d6501438e936486471965ff346ef06fae91f.tar.bz2
gentoo-2-0f04d6501438e936486471965ff346ef06fae91f.zip
celestia-1.4.1-r1: fixed bugs #128218, #130091, #142786, and #162777
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sci-astronomy/celestia/files')
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-cfg.patch11
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch32
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-lua.patch62
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch75
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-strictalias.patch13
-rw-r--r--sci-astronomy/celestia/files/digest-celestia-1.4.1-r13
6 files changed, 196 insertions, 0 deletions
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-cfg.patch b/sci-astronomy/celestia/files/celestia-1.4.1-cfg.patch
new file mode 100644
index 000000000000..61e9419c2d89
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-cfg.patch
@@ -0,0 +1,11 @@
+--- celestia.cfg.orig 2006-09-19 11:05:24.000000000 +0100
++++ celestia.cfg 2006-09-19 11:05:50.000000000 +0100
+@@ -150,7 +150,7 @@
+ # or
+ # ExtrasDirectories [ "D:\\celestia-extras" ]
+ #------------------------------------------------------------------------
+- ExtrasDirectories [ "extras" ]
++ ExtrasDirectories [ "extras" "~/.celestia" ]
+
+
+ #------------------------------------------------------------------------
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch b/sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch
new file mode 100644
index 000000000000..48912f2e2c15
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-kde-datadir.patch
@@ -0,0 +1,32 @@
+diff -Nur ../celestia-1.4.1.orig/Makefile.am ./Makefile.am
+--- ../celestia-1.4.1.orig/Makefile.am 2006-02-03 18:04:33.000000000 +0000
++++ ./Makefile.am 2007-02-03 12:46:33.000000000 +0000
+@@ -66,11 +66,11 @@
+ )
+
+ install-data-hook:
+- if [ "$(kde_datadir)" -a -d $(kde_datadir)/@PACKAGE@ -a ! -h $(kde_datadir)/@PACKAGE@ ] ; then \
+- mv -f -b $(kde_datadir)/@PACKAGE@/* $(datadir)/@PACKAGE@/ ; \
+- rmdir $(kde_datadir)/@PACKAGE@ ; \
++ if [ "$(DESTDIR)$(kde_datadir)" -a -d $(DESTDIR)$(kde_datadir)/@PACKAGE@ -a ! -h $(DESTDIR)$(kde_datadir)/@PACKAGE@ ] ; then \
++ mv -f -b $(DESTDIR)$(kde_datadir)/@PACKAGE@/* $(DESTDIR)$(datadir)/@PACKAGE@/ ; \
++ rmdir $(DESTDIR)$(kde_datadir)/@PACKAGE@ ; \
+ fi
+- if [ "$(kde_datadir)" -a ! -h $(kde_datadir)/@PACKAGE@ ] ; then \
+- ln -s $(datadir)/@PACKAGE@ $(kde_datadir)/@PACKAGE@ ; \
++ if [ "$(DESTDIR)$(kde_datadir)" -a ! -h $(DESTDIR)$(kde_datadir)/@PACKAGE@ ] ; then \
++ ln -s $(datadir)/@PACKAGE@ $(DESTDIR)$(kde_datadir)/@PACKAGE@ ; \
+ fi
+
+diff -Nur ../celestia-1.4.1.orig/src/celestia/kde/data/Makefile.am ./src/celestia/kde/data/Makefile.am
+--- ../celestia-1.4.1.orig/src/celestia/kde/data/Makefile.am 2006-01-07 11:15:48.000000000 +0000
++++ ./src/celestia/kde/data/Makefile.am 2007-02-03 12:49:04.000000000 +0000
+@@ -14,7 +14,7 @@
+ mimedir = $(kde_mimedir)/application
+ mime_DATA = x-celestia-script.desktop
+
+-appsdir = $(kde_appsdir)/Edutainment/Science
++appsdir = $(datadir)/applications/kde
+ apps_DATA = celestia.desktop
+
+ KDE_ICON = celestia
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-lua.patch b/sci-astronomy/celestia/files/celestia-1.4.1-lua.patch
new file mode 100644
index 000000000000..ed31b8ee0d0c
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-lua.patch
@@ -0,0 +1,62 @@
+--- src/celestia/celx.cpp.orig 2006-09-19 11:08:10.000000000 +0100
++++ src/celestia/celx.cpp 2006-09-19 11:07:03.000000000 +0100
+@@ -32,9 +32,7 @@
+
+ #include "celx.h"
+ #include "celestiacore.h"
+-extern "C" {
+-#include "lualib.h"
+-}
++#include "lua.hpp"
+
+ using namespace std;
+
+@@ -532,6 +530,8 @@
+
+ status = lua_resume(co, narg);
+ if (status == 0)
++ return 0;
++ else if (status == LUA_YIELD)
+ {
+ int nres = lua_gettop(co);
+ #if 0
+@@ -543,7 +543,7 @@
+ }
+ else
+ {
+- lua_xmove(co, L, 1); // move error message
++ lua_xmove(co, L, -1); // move error message
+ return -1; // error flag
+ }
+ }
+@@ -598,7 +598,7 @@
+ int stackTop = lua_gettop(costate);
+ if (strcmp(c_p, "y") == 0)
+ {
+- lua_iolibopen(costate);
++ luaL_openlibs(costate);
+ ioMode = IOAllowed;
+ }
+ else
+@@ -713,7 +713,8 @@
+ // no other errors, and execution terminates normally. There
+ // should be a better way to figure out whether the script ended
+ // normally . . .
+- if (strcmp(errorMessage, "cannot resume dead coroutine") != 0)
++ if (errorMessage
++ && strcmp(errorMessage, "cannot resume dead coroutine") != 0)
+ {
+ cout << "Error: " << errorMessage << '\n';
+ CelestiaCore* appCore = getAppCore(co);
+@@ -4577,10 +4578,7 @@
+ initMaps();
+
+ // Import the base and math libraries
+- lua_baselibopen(state);
+- lua_mathlibopen(state);
+- lua_tablibopen(state);
+- lua_strlibopen(state);
++ luaL_openlibs(state);
+
+ // Add an easy to use wait function, so that script writers can
+ // live in ignorance of coroutines. There will probably be a significant
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch b/sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch
new file mode 100644
index 000000000000..7c02999116fe
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-lua51.patch
@@ -0,0 +1,75 @@
+diff -Nur celestia-1.4.1.orig/configure.in celestia-1.4.1/configure.in
+--- celestia-1.4.1.orig/configure.in 2006-02-03 18:09:54.000000000 +0000
++++ celestia-1.4.1/configure.in 2006-09-19 10:04:57.000000000 +0100
+@@ -383,7 +383,7 @@
+ AC_MSG_CHECKING([whether to enable Celestia Extension Language])
+ if (test "$enable_lua" != "no"); then
+ CXXFLAGS="$CXXFLAGS -DCELX"
+- LDFLAGS="$LDFLAGS -llualib -llua"
++ LDFLAGS="$LDFLAGS -llua"
+
+ if (test "$lua_includes" != "no"); then
+ CXXFLAGS="$CXXFLAGS -I$lua_includes"
+diff -Nur celestia-1.4.1.orig/src/celestia/celx.cpp celestia-1.4.1/src/celestia/celx.cpp
+--- celestia-1.4.1.orig/src/celestia/celx.cpp 2006-01-07 00:01:51.000000000 +0000
++++ celestia-1.4.1/src/celestia/celx.cpp 2006-09-19 10:05:06.000000000 +0100
+@@ -32,9 +32,7 @@
+
+ #include "celx.h"
+ #include "celestiacore.h"
+-extern "C" {
+-#include "lualib.h"
+-}
++#include "lua.hpp"
+
+ using namespace std;
+
+@@ -532,6 +530,8 @@
+
+ status = lua_resume(co, narg);
+ if (status == 0)
++ return 0;
++ else if (status == LUA_YIELD)
+ {
+ int nres = lua_gettop(co);
+ #if 0
+@@ -543,7 +543,7 @@
+ }
+ else
+ {
+- lua_xmove(co, L, 1); // move error message
++ lua_xmove(co, L, -1); // move error message
+ return -1; // error flag
+ }
+ }
+@@ -598,7 +598,7 @@
+ int stackTop = lua_gettop(costate);
+ if (strcmp(c_p, "y") == 0)
+ {
+- lua_iolibopen(costate);
++ luaL_openlibs(costate);
+ ioMode = IOAllowed;
+ }
+ else
+@@ -713,7 +713,8 @@
+ // no other errors, and execution terminates normally. There
+ // should be a better way to figure out whether the script ended
+ // normally . . .
+- if (strcmp(errorMessage, "cannot resume dead coroutine") != 0)
++ if (errorMessage
++ && strcmp(errorMessage, "cannot resume dead coroutine") != 0)
+ {
+ cout << "Error: " << errorMessage << '\n';
+ CelestiaCore* appCore = getAppCore(co);
+@@ -4577,10 +4578,7 @@
+ initMaps();
+
+ // Import the base and math libraries
+- lua_baselibopen(state);
+- lua_mathlibopen(state);
+- lua_tablibopen(state);
+- lua_strlibopen(state);
++ luaL_openlibs(state);
+
+ // Add an easy to use wait function, so that script writers can
+ // live in ignorance of coroutines. There will probably be a significant
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-strictalias.patch b/sci-astronomy/celestia/files/celestia-1.4.1-strictalias.patch
new file mode 100644
index 000000000000..3ff59b31686a
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-strictalias.patch
@@ -0,0 +1,13 @@
+--- celestia-1.4.1/src/celengine/modelfile.cpp.strictalias 2006-11-22 14:04:15.000000000 +0100
++++ celestia-1.4.1/src/celengine/modelfile.cpp 2006-11-22 14:01:27.000000000 +0100
+@@ -1080,7 +1080,9 @@
+ static float readFloat(istream& in)
+ {
+ int i = readUint(in);
+- return *((float*) &i);
++ float f;
++ memcpy(&f, &i, sizeof(float));
++ return f;
+ }
+
+
diff --git a/sci-astronomy/celestia/files/digest-celestia-1.4.1-r1 b/sci-astronomy/celestia/files/digest-celestia-1.4.1-r1
new file mode 100644
index 000000000000..b75d1f3ff9d0
--- /dev/null
+++ b/sci-astronomy/celestia/files/digest-celestia-1.4.1-r1
@@ -0,0 +1,3 @@
+MD5 be1d36fc97a13b9a276249dbc0efac41 celestia-1.4.1.tar.gz 23966886
+RMD160 c66c2540e329613dace12e5b12b2dae2a4c679e0 celestia-1.4.1.tar.gz 23966886
+SHA256 f9dc34dbc0d53e98534000545802b5ab4a471c3cb3fa08a9c958cbbbeb28d8b5 celestia-1.4.1.tar.gz 23966886