summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-12-07 17:14:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-12-07 17:14:23 +0000
commit95bf30efa0abf0d42152369d09796c460c2e33e2 (patch)
tree0264becee3df899e9c9bb84b45b148890e7143ea /sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild
parentRestrict python-3 (diff)
downloadgentoo-2-95bf30efa0abf0d42152369d09796c460c2e33e2.tar.gz
gentoo-2-95bf30efa0abf0d42152369d09796c460c2e33e2.tar.bz2
gentoo-2-95bf30efa0abf0d42152369d09796c460c2e33e2.zip
Really fixing bug #446263, thanks Peter Weilbacher
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild')
-rw-r--r--sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild b/sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild
new file mode 100644
index 000000000000..3336bf67caf1
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild,v 1.1 2012/12/07 17:14:23 bicatali Exp $
+
+EAPI=4
+inherit eutils java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( ${HOMEPAGE}/${PDOC}.pdf )"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND="
+ >=virtual/jre-1.6
+ dev-java/gnu-regexp
+ dev-java/junit
+ dev-java/jal"
+
+src_prepare() {
+ sed -i \
+ -e "s:^BASE=\`pwd\`:BASE=${EPREFIX}/usr/share/${PN}:" \
+ -e 's:$BASE/share/:$BASE/lib/:g' \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/*
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}
+ doins -r config
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ use doc && newdoc "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+}