summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-09-11 13:58:00 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-09-11 13:58:00 +0000
commit0ec416acc183caa4c7fb63aca85d4d0cdae5442c (patch)
tree9f3f03f34286fe7d1f369ee8d1d186f2dc08aea7 /sci-astronomy/pyephem
parentdev-lang/mono-1.2.5-r1: fixed issues with remoting (bug #192120) (diff)
downloadgentoo-2-0ec416acc183caa4c7fb63aca85d4d0cdae5442c.tar.gz
gentoo-2-0ec416acc183caa4c7fb63aca85d4d0cdae5442c.tar.bz2
gentoo-2-0ec416acc183caa4c7fb63aca85d4d0cdae5442c.zip
Version bump. Added src_test and longdescription in metadata.xml. Tested on amd64 as well. Closing bug #191883
(Portage version: 2.1.2.12)
Diffstat (limited to 'sci-astronomy/pyephem')
-rw-r--r--sci-astronomy/pyephem/ChangeLog9
-rw-r--r--sci-astronomy/pyephem/files/digest-pyephem-3.7.2a3
-rw-r--r--sci-astronomy/pyephem/metadata.xml10
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.2a.ebuild36
4 files changed, 57 insertions, 1 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index cd04ab4fddc8..40da0c49be02 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/pyephem
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.2 2007/02/09 05:19:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.3 2007/09/11 13:57:59 bicatali Exp $
+
+*pyephem-3.7.2a (11 Sep 2007)
+
+ 11 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +pyephem-3.7.2a.ebuild:
+ Version bump. Added src_test and longdescription in metadata.xml. Tested on
+ amd64 as well. Closing bug #191883
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sci-astronomy/pyephem/files/digest-pyephem-3.7.2a b/sci-astronomy/pyephem/files/digest-pyephem-3.7.2a
new file mode 100644
index 000000000000..61c6e0a8ab1b
--- /dev/null
+++ b/sci-astronomy/pyephem/files/digest-pyephem-3.7.2a
@@ -0,0 +1,3 @@
+MD5 92d035abe09b9dba39780bc66738ce23 pyephem-3.7.2a.tar.gz 300709
+RMD160 1318b491b8e5816ccec13cf3fffa764afe2ae100 pyephem-3.7.2a.tar.gz 300709
+SHA256 5e7e4a23544d9ef232913d3dc9fac3a9a6a2ced4892ce6c4d197ecbb23f89dcd pyephem-3.7.2a.tar.gz 300709
diff --git a/sci-astronomy/pyephem/metadata.xml b/sci-astronomy/pyephem/metadata.xml
index b229aec85b8f..b0e5c790aa6d 100644
--- a/sci-astronomy/pyephem/metadata.xml
+++ b/sci-astronomy/pyephem/metadata.xml
@@ -2,4 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+PyEphem provides astronomical computations for the Python programming
+language. Given a date and location on the Earth's surface, it can
+compute the positions of the Sun and Moon, of the planets and their
+moons, and of any asteroids, comets, or earth satellites whose orbital
+elements the user can provide. Additional functions are provided to
+compute the angular separation between two objects in the sky, to
+determine the constellation in which an object lies, and to find the
+times at which an object rises, transits, and sets on a particular day.
+</longdescription>
</pkgmetadata>
diff --git a/sci-astronomy/pyephem/pyephem-3.7.2a.ebuild b/sci-astronomy/pyephem/pyephem-3.7.2a.ebuild
new file mode 100644
index 000000000000..e865067b0b0d
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-3.7.2a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.2a.ebuild,v 1.1 2007/09/11 13:57:59 bicatali Exp $
+
+inherit distutils
+
+DESCRIPTION="PyEphem provides scientific-grade astronomical computations for the python programming language."
+LICENSE="GPL-2"
+HOMEPAGE="http://www.rhodesmill.org/brandon/projects/pyephem.html"
+SRC_URI="http://www.rhodesmill.org/brandon/projects/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/python"
+
+src_test() {
+ cd "${S}"/build/lib*
+ for t in "${S}"/test/test_*.py ; do
+ einfo "Testing $(basename ${t})"
+ PYTHONPATH=. "${python}" ${t} 2>&1 | tee test.log
+ grep -q '^OK' test.log || die "${t} failed"
+ rm -f test.log
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ # install docs and examples
+ dohtml doc/* || die "Failed to install html docs"
+
+ insinto /usr/share/${PN}/examples
+ doins examples/* || die "Failed to install examples"
+}