summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-09-25 03:19:56 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-09-25 03:19:56 +0000
commit73fa10531024bca6d518ec5d01ec05708d5e560e (patch)
treed4d7835b3c17dcf45af14f2ae2cd61e49ec3f096 /sci-astronomy/skycat/files
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-73fa10531024bca6d518ec5d01ec05708d5e560e.tar.gz
gentoo-2-73fa10531024bca6d518ec5d01ec05708d5e560e.tar.bz2
gentoo-2-73fa10531024bca6d518ec5d01ec05708d5e560e.zip
Link against libwcs and cfitsio systemlibs instead of included ones (fixes bug #253273). Also added a patch to fix parallel make and multiple QA issues.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/skycat/files')
-rw-r--r--sci-astronomy/skycat/files/skycat-3.0.2-makefile-qa.patch119
-rw-r--r--sci-astronomy/skycat/files/skycat-3.0.2-systemlibs.patch107
2 files changed, 226 insertions, 0 deletions
diff --git a/sci-astronomy/skycat/files/skycat-3.0.2-makefile-qa.patch b/sci-astronomy/skycat/files/skycat-3.0.2-makefile-qa.patch
new file mode 100644
index 000000000000..3d74f6a0e126
--- /dev/null
+++ b/sci-astronomy/skycat/files/skycat-3.0.2-makefile-qa.patch
@@ -0,0 +1,119 @@
+diff -Naur skycat-3.0.2/astrotcl/Makefile.in skycat-3.0.2.new/astrotcl/Makefile.in
+--- skycat-3.0.2/astrotcl/Makefile.in 2006-02-01 15:08:34.000000000 -0500
++++ skycat-3.0.2.new/astrotcl/Makefile.in 2009-09-24 22:23:15.000000000 -0400
+@@ -114,7 +114,7 @@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS_DEFAULT)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
+diff -Naur skycat-3.0.2/cat/Makefile.in skycat-3.0.2.new/cat/Makefile.in
+--- skycat-3.0.2/cat/Makefile.in 2006-02-01 15:08:34.000000000 -0500
++++ skycat-3.0.2.new/cat/Makefile.in 2009-09-24 22:23:15.000000000 -0400
+@@ -124,7 +124,7 @@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS_DEFAULT)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
+@@ -436,7 +436,7 @@
+ cxxtests: $(CXX_TEST_APPS)
+
+ $(CXX_TEST_APPS): FORCE
+- $(CXXCOMPILE) -o $@ $(srcdir)/tests/$@.C $(TEST_LIBS) $(LIBS)
++ $(CXXCOMPILE) $(LDFLAGS_DEFAULT) -o $@ $(srcdir)/tests/$@.C $(TEST_LIBS) $(LIBS)
+ cp $(srcdir)/tests/test.table .
+ -@@LD_LIBRARY_PATH_VAR@=@exec_prefix@/lib; export @LD_LIBRARY_PATH_VAR@ ;\
+ $@ > $@.result 2>&1 ;\
+diff -Naur skycat-3.0.2/rtd/Makefile.in skycat-3.0.2.new/rtd/Makefile.in
+--- skycat-3.0.2/rtd/Makefile.in 2006-02-01 15:08:34.000000000 -0500
++++ skycat-3.0.2.new/rtd/Makefile.in 2009-09-24 22:25:10.000000000 -0400
+@@ -123,7 +123,7 @@
+ CLEANFILES = @CLEANFILES@ $(TEST_APPS) *.o tests/*.o
+ EXEEXT = @EXEEXT@
+ LDFLAGS_DEFAULT = @LDFLAGS_DEFAULT@
+-MAKE_LIB = @MAKE_LIB@ $(MERGE_OBJECTS)
++MAKE_LIB = @MAKE_LIB@ $(MERGE_OBJECTS) $(SHLIB_LD_LIBS)
+ MAKE_SHARED_LIB = @MAKE_SHARED_LIB@
+ MAKE_STATIC_LIB = @MAKE_STATIC_LIB@
+ MAKE_STUB_LIB = @MAKE_STUB_LIB@
+@@ -131,7 +131,7 @@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS_DEFAULT)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
+@@ -442,14 +442,14 @@
+ $(AR) r $@ $(RTDEVT_OBJ)
+ $(RANLIB) $@
+
+-$(RTD_SERVER): $(RTD_SERVER_OBJS)
+- $(CXXCOMPILE) -o $@ $(RTD_SERVER_OBJS) $(RTDEVT_LIB) @LIBS@
++$(RTD_SERVER): $(RTD_SERVER_OBJS) $(RTDEVT_LIB)
++ $(CXXCOMPILE) $(LDFLAGS_DEFAULT) -o $@ $(RTD_SERVER_OBJS) $(RTDEVT_LIB) @LIBS@
+
+-rtdClient: rtdClient.o
+- $(CXXCOMPILE) -o $@ $? $(RTDEVT_LIB) @LIBS@
++rtdClient: rtdClient.o $(RTDEVT_LIB)
++ $(CXXCOMPILE) $(LDFLAGS_DEFAULT) -o $@ $? $(RTDEVT_LIB) @LIBS@
+
+-rtdCubeDisplay: rtdCubeDisplay.o
+- $(CXXCOMPILE) -o $@ $? $(RTDEVT_LIB) @LIBS@
++rtdCubeDisplay: rtdCubeDisplay.o $(RTDEVT_LIB)
++ $(CXXCOMPILE) $(LDFLAGS_DEFAULT) -o $@ $? $(RTDEVT_LIB) @LIBS@
+
+ #========================================================================
+ # RTD Remote access C library
+@@ -464,14 +464,14 @@
+ #========================================================================
+ test: binaries libraries $(TEST_APPS)
+
+-tImageEvent: tImageEvent.o
+- $(CXXCOMPILE) -o $@ $@.o $(RTDEVT_LIB) @LIBS@
++tImageEvent: tImageEvent.o $(RTDEVT_LIB)
++ $(CXXCOMPILE) $(LDFLAGS_DEFAULT) -o $@ $@.o $(RTDEVT_LIB) @LIBS@
+
+ trtdRemote: trtdRemote.o
+- $(COMPILE) -o $@ $@.o $(RTD_REMOTE_LIB) @LIBS@
++ $(COMPILE) $(LDFLAGS_DEFAULT) -o $@ $@.o $(RTD_REMOTE_LIB) @LIBS@
+
+-tRtd: tRtd.o tRtdEvt.o tRtdEvtData.o
+- $(CXXCOMPILE) -o $@ $@.o tRtdEvt.o tRtdEvtData.o \
++tRtd: tRtd.o tRtdEvt.o tRtdEvtData.o $(PKG_LIB_FILE)
++ $(CXXCOMPILE) $(LDFLAGS_DEFAULT) -o $@ $@.o tRtdEvt.o tRtdEvtData.o \
+ @rtd_BUILD_LIB_SPEC@ @TK_LIB_SPEC@ @TCL_LIB_SPEC@ ${LIBS}
+
+ #========================================================================
+diff -Naur skycat-3.0.2/skycat/Makefile.in skycat-3.0.2.new/skycat/Makefile.in
+--- skycat-3.0.2/skycat/Makefile.in 2006-02-04 10:32:15.000000000 -0500
++++ skycat-3.0.2.new/skycat/Makefile.in 2009-09-24 22:23:15.000000000 -0400
+@@ -120,7 +120,7 @@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS_DEFAULT)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
+diff -Naur skycat-3.0.2/tclutil/Makefile.in skycat-3.0.2.new/tclutil/Makefile.in
+--- skycat-3.0.2/tclutil/Makefile.in 2006-02-01 15:08:34.000000000 -0500
++++ skycat-3.0.2.new/tclutil/Makefile.in 2009-09-24 22:23:15.000000000 -0400
+@@ -116,7 +116,7 @@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS_DEFAULT)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
diff --git a/sci-astronomy/skycat/files/skycat-3.0.2-systemlibs.patch b/sci-astronomy/skycat/files/skycat-3.0.2-systemlibs.patch
new file mode 100644
index 000000000000..669d54a68ed0
--- /dev/null
+++ b/sci-astronomy/skycat/files/skycat-3.0.2-systemlibs.patch
@@ -0,0 +1,107 @@
+diff -Naur skycat-3.0.2/astrotcl/configure.in skycat-3.0.2.new/astrotcl/configure.in
+--- skycat-3.0.2/astrotcl/configure.in 2006-01-25 17:21:38.000000000 -0500
++++ skycat-3.0.2.new/astrotcl/configure.in 2009-09-24 20:48:27.000000000 -0400
+@@ -83,10 +83,10 @@
+ #-----------------------------------------------------------------------
+
+ changequote(<<, >>)
+-csources=`cd $srcdir; echo {generic,press,libwcs,cfitsio}/*.[Cc]`
++csources=`cd $srcdir; echo {generic,press}/*.[Cc]`
+ changequote([, ])
+-cheaders=`cd $srcdir; echo {generic,press,libwcs,cfitsio}/*.h`
+-cincludes="-I$srcdir/../tclutil/generic -I$srcdir/generic -I$srcdir/press -I$srcdir/libwcs -I$srcdir/cfitsio"
++cheaders=`cd $srcdir; echo {generic,press}/*.h`
++cincludes="-I$srcdir/../tclutil/generic -I$srcdir/generic -I$srcdir/press -I/usr/include/wcs -I/usr/include/"
+ tclsources=`cd $srcdir; echo library/*.tcl`
+
+ TEA_ADD_SOURCES([${csources}])
+diff -Naur skycat-3.0.2/cat/aclocal.m4 skycat-3.0.2.new/cat/aclocal.m4
+--- skycat-3.0.2/cat/aclocal.m4 2006-01-23 12:24:46.000000000 -0500
++++ skycat-3.0.2.new/cat/aclocal.m4 2009-09-24 20:31:00.000000000 -0400
+@@ -47,11 +47,11 @@
+ changequote([, ])
+
+ cat_headers=`cd $srcdir; echo generic/*.h`
+-astrotcl_headers=`cd $srcdir; echo ../astrotcl/{generic,press,libwcs,cfitsio}/*.h`
++astrotcl_headers=`cd $srcdir; echo ../astrotcl/{generic,press}/*.h`
+ tclutil_headers=`cd $srcdir; echo ../tclutil/generic/*.h`
+
+ cat_includes="-I$srcdir/generic -I$srcdir/bitmaps"
+-astrotcl_includes="-I$srcdir/../astrotcl/generic -I$srcdir/../astrotcl/cfitsio -I$srcdir/../astrotcl/libwcs"
++astrotcl_includes="-I$srcdir/../astrotcl/generic -I/usr/include -I/usr/include/wcs"
+ tclutil_includes="-I$srcdir/../tclutil/generic"
+ cincludes="${cat_includes} ${astrotcl_includes} ${tclutil_includes}"
+
+diff -Naur skycat-3.0.2/cat/configure.in skycat-3.0.2.new/cat/configure.in
+--- skycat-3.0.2/cat/configure.in 2006-02-03 05:29:48.000000000 -0500
++++ skycat-3.0.2.new/cat/configure.in 2009-09-24 20:51:56.000000000 -0400
+@@ -181,6 +181,9 @@
+ # and TEA_LOAD_TCLCONFIG macros above.
+ #--------------------------------------------------------------------
+
++# we need wcstools and cfitsio
++PKG_LIBS="${PKG_LIBS} -lwcstools -lcfitsio"
++
+ TEA_MAKE_LIB
+
+ #--------------------------------------------------------------------
+diff -Naur skycat-3.0.2/rtd/aclocal.m4 skycat-3.0.2.new/rtd/aclocal.m4
+--- skycat-3.0.2/rtd/aclocal.m4 2006-02-01 17:10:36.000000000 -0500
++++ skycat-3.0.2.new/rtd/aclocal.m4 2009-09-24 20:27:46.000000000 -0400
+@@ -50,11 +50,11 @@
+ changequote([, ])
+
+ rtd_headers=`cd $srcdir; echo generic/*.h rtdevt/rtdImageEvent.h rtdevt/rtdSem.h`
+-astrotcl_headers=`cd $srcdir; echo ../astrotcl/{generic,press,libwcs,cfitsio}/*.h`
++astrotcl_headers=`cd $srcdir; echo ../astrotcl/{generic,press}/*.h`
+ tclutil_headers=`cd $srcdir; echo ../tclutil/generic/*.h`
+
+ rtd_includes="-I$srcdir/generic -I$srcdir/rtdevt -I$srcdir/bitmaps"
+-astrotcl_includes="-I$srcdir/../astrotcl/generic -I$srcdir/../astrotcl/cfitsio -I$srcdir/../astrotcl/libwcs"
++astrotcl_includes="-I$srcdir/../astrotcl/generic -I/usr/include -I/usr/include/wcs"
+ tclutil_includes="-I$srcdir/../tclutil/generic"
+ cincludes="${rtd_includes} ${astrotcl_includes} ${tclutil_includes}"
+
+diff -Naur skycat-3.0.2/rtd/configure.in skycat-3.0.2.new/rtd/configure.in
+--- skycat-3.0.2/rtd/configure.in 2006-02-01 17:10:36.000000000 -0500
++++ skycat-3.0.2.new/rtd/configure.in 2009-09-24 20:49:11.000000000 -0400
+@@ -192,7 +192,7 @@
+ #--------------------------------------------------------------------
+
+ # rtd needs -lXext
+-PKG_LIBS="${PKG_LIBS} -lXext"
++PKG_LIBS="${PKG_LIBS} -lXext -lwcstools -lcfitsio"
+
+ TEA_MAKE_LIB
+
+diff -Naur skycat-3.0.2/skycat/aclocal.m4 skycat-3.0.2.new/skycat/aclocal.m4
+--- skycat-3.0.2/skycat/aclocal.m4 2006-01-26 17:47:20.000000000 -0500
++++ skycat-3.0.2.new/skycat/aclocal.m4 2009-09-24 20:33:31.000000000 -0400
+@@ -79,13 +79,13 @@
+ skycat_headers=`cd $srcdir; echo generic/*.h`
+ cat_headers=`cd $srcdir; echo ../cat/generic/*.h`
+ rtd_headers=`cd $srcdir; echo ../rtd/generic/*.h ../rtd/rtdevt/rtdImageEvent.h ../rtd/rtdevt/rtdSem.h`
+-astrotcl_headers=`cd $srcdir; echo ../astrotcl/{generic,press,libwcs,cfitsio}/*.h`
++astrotcl_headers=`cd $srcdir; echo ../astrotcl/{generic,press}/*.h`
+ tclutil_headers=`cd $srcdir; echo ../tclutil/generic/*.h`
+
+ skycat_includes="-I$srcdir/generic -I$srcdir/bitmaps"
+ cat_includes="-I$srcdir/../cat/generic"
+ rtd_includes="-I$srcdir/../rtd/generic -I$srcdir/../rtd/rtdevt"
+-astrotcl_includes="-I$srcdir/../astrotcl/generic -I$srcdir/../astrotcl/cfitsio -I$srcdir/../astrotcl/libwcs"
++astrotcl_includes="-I$srcdir/../astrotcl/generic -I/usr/include -I/usr/include/wcs"
+ tclutil_includes="-I$srcdir/../tclutil/generic"
+ cincludes="${skycat_includes} ${cat_includes} ${rtd_includes} ${astrotcl_includes} ${tclutil_includes}"
+
+diff -Naur skycat-3.0.2/skycat/configure.in skycat-3.0.2.new/skycat/configure.in
+--- skycat-3.0.2/skycat/configure.in 2008-06-11 11:04:25.000000000 -0400
++++ skycat-3.0.2.new/skycat/configure.in 2009-09-24 20:52:26.000000000 -0400
+@@ -182,7 +182,7 @@
+ #--------------------------------------------------------------------
+
+ # skycat needs -lXext
+-PKG_LIBS="${PKG_LIBS} -lXext"
++PKG_LIBS="${PKG_LIBS} -lXext -lwcstools -lcfitsio"
+
+ TEA_MAKE_LIB
+