summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-26 11:34:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-26 11:34:30 +0000
commitf1627e1fbcc640bf42d37f806aca506daa8e8c9f (patch)
treefe534c78e81560cefe177710bb01774be854bfb1 /sci-astronomy/skycat
parentstable amd64, bug 227375 (diff)
downloadgentoo-2-f1627e1fbcc640bf42d37f806aca506daa8e8c9f.tar.gz
gentoo-2-f1627e1fbcc640bf42d37f806aca506daa8e8c9f.tar.bz2
gentoo-2-f1627e1fbcc640bf42d37f806aca506daa8e8c9f.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-astronomy/skycat')
-rw-r--r--sci-astronomy/skycat/ChangeLog7
-rw-r--r--sci-astronomy/skycat/skycat-3.0.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sci-astronomy/skycat/ChangeLog b/sci-astronomy/skycat/ChangeLog
index ef30d4563c9b..fc36f84a0b75 100644
--- a/sci-astronomy/skycat/ChangeLog
+++ b/sci-astronomy/skycat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/skycat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.2 2008/06/17 08:57:32 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.3 2008/06/26 11:34:30 bicatali Exp $
+
+*skycat-3.0.2 (26 Jun 2008)
+
+ 26 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org> +skycat-3.0.2.ebuild:
+ Version bump
17 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
-files/skycat-3.0.1-gcc41.patch, +files/skycat-3.0.1-gcc43.patch,
diff --git a/sci-astronomy/skycat/skycat-3.0.2.ebuild b/sci-astronomy/skycat/skycat-3.0.2.ebuild
new file mode 100644
index 000000000000..154ddf670acf
--- /dev/null
+++ b/sci-astronomy/skycat/skycat-3.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.0.2.ebuild,v 1.1 2008/06/26 11:34:30 bicatali Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="ESO astronomical image visualizer with catalog access."
+HOMEPAGE="http://archive.eso.org/skycat"
+SRC_URI="ftp://ftp.eso.org/pub/archive/${PN}/Sources/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+DEPEND="x11-libs/libXext
+ >=dev-tcltk/tclx-2.4
+ >=dev-tcltk/blt-2.4
+ >=dev-tcltk/itcl-3.3
+ >=dev-tcltk/iwidgets-4.0.1
+ >=dev-tcltk/tkimg-1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fix buggy tcl.m4 for bash3
+ epatch "${FILESDIR}"/${PN}-3.0.1-m4.patch
+ # fix old style headers, set as error by new g++
+ epatch "${FILESDIR}"/${PN}-3.0.1-gcc43.patch
+ eautoconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable threads) \
+ || die "econf failed"
+ emake
+ # a second time to make sure every dir passed
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README CHANGES VERSION
+ for d in tclutil astrotcl rtd cat skycat; do
+ docinto ${d}
+ for f in README CHANGES VERSION; do
+ newdoc ${f} ${f}.${d}
+ done
+ done
+}