summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-21 15:46:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-21 15:46:50 +0000
commit70f80f846174795cd5d1bbcd4c349a6ad15bfc2b (patch)
tree70cbd50210de28cb40ec4a400c336b8f2ebe92fa /sci-astronomy
parentRemoving ferdy as a maintainer since he was retired. (diff)
downloadgentoo-2-70f80f846174795cd5d1bbcd4c349a6ad15bfc2b.tar.gz
gentoo-2-70f80f846174795cd5d1bbcd4c349a6ad15bfc2b.tar.bz2
gentoo-2-70f80f846174795cd5d1bbcd4c349a6ad15bfc2b.zip
Version bump and fixed a libtool file (bug #261077)
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ast/ChangeLog9
-rw-r--r--sci-astronomy/ast/ast-5.1.0.ebuild39
-rw-r--r--sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch21
-rw-r--r--sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch90
4 files changed, 156 insertions, 3 deletions
diff --git a/sci-astronomy/ast/ChangeLog b/sci-astronomy/ast/ChangeLog
index f363a54b7d48..c6cd5ccc3cfb 100644
--- a/sci-astronomy/ast/ChangeLog
+++ b/sci-astronomy/ast/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/ast
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.7 2009/02/25 17:12:26 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.8 2009/03/21 15:46:50 bicatali Exp $
+
+*ast-5.1.0 (21 Mar 2009)
+
+ 21 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ files/ast-4.6.2-makefile.in.patch, +files/ast-5.1.0-makefile.in.patch,
+ +ast-5.1.0.ebuild:
+ Version bump and fixed a libtool file (bug #261077)
25 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> -ast-4.6.2-r1.ebuild:
Removed buggy version
diff --git a/sci-astronomy/ast/ast-5.1.0.ebuild b/sci-astronomy/ast/ast-5.1.0.ebuild
new file mode 100644
index 000000000000..8b14b63fc44f
--- /dev/null
+++ b/sci-astronomy/ast/ast-5.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ast-5.1.0.ebuild,v 1.1 2009/03/21 15:46:50 bicatali Exp $
+
+EAPI=2
+inherit eutils versionator
+
+MYP="${PN}-$(replace_version_separator 2 '-')"
+
+DESCRIPTION="Library for handling World Coordinate Systems in astronomy"
+HOMEPAGE="http://www.starlink.ac.uk/~dsb/ast/ast.html"
+SRC_URI="http://www.starlink.ac.uk/~dsb/${PN}/${MYP}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND="sci-libs/pgplot"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # dont patch/sed Makefile.am because it requires special upstream automake
+ # not shipped
+ epatch "${FILESDIR}"/${P}-makefile.in.patch
+}
+
+#src_configure() {
+# PATH=".:${PATH}" econf
+#}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -rf "${D}"usr/{docs,help,manifests,news,share} || die
+ dodoc ast.news fac_1521_err
+ if use doc; then
+ dodoc *.ps || die "doc install failed"
+ fi
+}
diff --git a/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch b/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch
index 2a26aa66e808..e3291e277c6d 100644
--- a/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch
+++ b/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2008-09-10 11:59:21.000000000 +0100
-+++ Makefile.in 2009-02-23 17:01:16.196714977 +0000
+--- Makefile.in.orig 2009-03-21 11:48:33.829215706 +0000
++++ Makefile.in 2009-03-21 11:50:56.901572460 +0000
@@ -76,7 +76,14 @@
"$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"
libLTLIBRARIES_INSTALL = $(INSTALL)
@@ -71,3 +71,20 @@
else \
echo "Installation of component $(DESTDIR)$(STAR_MANIFEST_DIR)/$(PACKAGE) failed" >&2; \
fi; \
+@@ -2720,14 +2726,14 @@
+ $(mkdir_p) $(DESTDIR)$(libdir)
+ cd $(DESTDIR)$(libdir); \
+ for f in `ls libast.*`; do \
+- ff=`echo $$f | sed -e 's/libast/libast_pass2/'`; \
++ ff=`echo $$f | sed -e 's/libast\./libast_pass2\./'`; \
+ if test -f "$$ff"; then rm "$$ff"; fi; \
+ $(LN_S) $$f $$ff; \
+ $(MANIFEST) && echo "MANIFEST:$(DESTDIR)$(libdir)/$$ff" || :; \
+ done; \
+ if test -f "libast.la"; then \
+ if test -f "libast_pass2.la"; then rm "libast_pass2.la"; fi; \
+- sed -e 's/libast/libast_pass2/g' libast.la > libast_pass2.la; \
++ sed -e 's/libast\./libast_pass2\./g' libast.la > libast_pass2.la; \
+ fi
+ @PREDIST@version.h: version.h.in configure.ac
+ @PREDIST@ rm -f $@; $(predist_subs) version.h.in >$@
diff --git a/sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch b/sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch
new file mode 100644
index 000000000000..99203524b5ed
--- /dev/null
+++ b/sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch
@@ -0,0 +1,90 @@
+--- Makefile.in.orig 2009-03-20 20:05:18.314466717 +0000
++++ Makefile.in 2009-03-21 15:07:59.217879770 +0000
+@@ -77,7 +77,14 @@
+ "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libast_la_LIBADD =
++libast_la_LIBADD = \
++ libast_err.la \
++ libast_grf3d.la \
++ libast_grf_2.0.la \
++ libast_grf_3.2.la \
++ libast_pal.la \
++ libast_wcslib.la
++
+ am__objects_1 = libast_la-axis.lo libast_la-box.lo libast_la-c2f77.lo \
+ libast_la-channel.lo libast_la-circle.lo libast_la-cmpframe.lo \
+ libast_la-cmpmap.lo libast_la-cmpregion.lo \
+@@ -163,10 +170,10 @@
+ libast_pal_la_LIBADD =
+ am_libast_pal_la_OBJECTS = libast_pal_la-pal.lo
+ libast_pal_la_OBJECTS = $(am_libast_pal_la_OBJECTS)
+-libast_pgplot_la_LIBADD =
++libast_pgplot_la_LIBADD = -lpgplot
+ am_libast_pgplot_la_OBJECTS = libast_pgplot_la-grf_pgplot.lo
+ libast_pgplot_la_OBJECTS = $(am_libast_pgplot_la_OBJECTS)
+-libast_pgplot3d_la_LIBADD =
++libast_pgplot3d_la_LIBADD = -lpgplot
+ am_libast_pgplot3d_la_OBJECTS = libast_pgplot3d_la-grf3d_pgplot.lo
+ libast_pgplot3d_la_OBJECTS = $(am_libast_pgplot3d_la_OBJECTS)
+ libast_wcslib_la_LIBADD =
+@@ -682,7 +689,6 @@
+ nodist_include_HEADERS = ast.h AST_PAR
+ include_MESSAGES = AST_ERR ast_err.h
+ lib_LTLIBRARIES = \
+- libast.la \
+ libast_err.la \
+ libast_ems.la \
+ libast_drama.la \
+@@ -692,11 +698,12 @@
+ libast_pgplot.la \
+ libast_pgplot3d.la \
+ libast_pal.la \
+- libast_wcslib.la
++ libast_wcslib.la \
++ libast.la
+
+-stardocs_DATA = @STAR_LATEX_DOCUMENTATION@
+-dist_starnews_DATA = ast.news
+-dist_pkgdata_DATA = LICENCE
++stardocs_DATA =
++dist_starnews_DATA =
++dist_pkgdata_DATA =
+
+ # Make all library code position independent by default. This is handy for
+ # creating shareable libraries from the static ones (Java JNI libraries).
+@@ -813,7 +820,7 @@
+ #ast_test_LDADD = `ast_link`
+ # Expand ast_link to avoid libast_pass2, which causes problems for Solaris
+ ast_test_LDADD = libast.la libast_pal.la libast_grf_3.2.la libast_wcslib.la libast_grf_2.0.la libast_grf3d.la libast_err.la -lm
+-starfacs_DATA = fac_1521_err
++starfacs_DATA =
+ all: $(BUILT_SOURCES) config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
+@@ -2608,7 +2615,6 @@
+ echo "</files>"; \
+ echo "</manifest>"; \
+ ) >$$MF; \
+- $(INSTALL_DATA) $$MF $(DESTDIR)$(STAR_MANIFEST_DIR)/$(PACKAGE); \
+ else \
+ echo "Installation of component $(DESTDIR)$(STAR_MANIFEST_DIR)/$(PACKAGE) failed" >&2; \
+ fi; \
+@@ -2762,14 +2768,14 @@
+ $(mkdir_p) $(DESTDIR)$(libdir)
+ cd $(DESTDIR)$(libdir); \
+ for f in `ls libast.*`; do \
+- ff=`echo $$f | sed -e 's/libast/libast_pass2/'`; \
++ ff=`echo $$f | sed -e 's/libast\./libast_pass2\./'`; \
+ if test -f "$$ff"; then rm "$$ff"; fi; \
+ $(LN_S) $$f $$ff; \
+ $(MANIFEST) && echo "MANIFEST:$(DESTDIR)$(libdir)/$$ff" || :; \
+ done; \
+ if test -f "libast.la"; then \
+ if test -f "libast_pass2.la"; then rm "libast_pass2.la"; fi; \
+- sed -e 's/libast/libast_pass2/g' libast.la > libast_pass2.la; \
++ sed -e 's/libast\./libast_pass2\./g' libast.la > libast_pass2.la; \
+ fi
+ @PREDIST@version.h: version.h.in configure.ac
+ @PREDIST@ rm -f $@; $(predist_subs) version.h.in >$@