summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-09-12 04:48:13 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-09-12 04:48:13 +0000
commitea518d2ef26196d53d7393c07e1a7ad288da8fc7 (patch)
treee03cbc2ee6617f593db27de53d27fa90ebc7a8c3 /sci-biology/biopython/biopython-1.42.ebuild
parentStable x86 (diff)
downloadgentoo-2-ea518d2ef26196d53d7393c07e1a7ad288da8fc7.tar.gz
gentoo-2-ea518d2ef26196d53d7393c07e1a7ad288da8fc7.tar.bz2
gentoo-2-ea518d2ef26196d53d7393c07e1a7ad288da8fc7.zip
New upstream version
(Portage version: 2.1.1)
Diffstat (limited to 'sci-biology/biopython/biopython-1.42.ebuild')
-rw-r--r--sci-biology/biopython/biopython-1.42.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/biopython/biopython-1.42.ebuild b/sci-biology/biopython/biopython-1.42.ebuild
new file mode 100644
index 000000000000..eed550fd6d1f
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.42.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.42.ebuild,v 1.1 2006/09/12 04:48:13 ribosome Exp $
+
+inherit distutils
+
+IUSE=""
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+HOMEPAGE="http://www.biopython.org"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-python/numeric-19.0
+ >=dev-python/reportlab-1.11"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~ppc ~sparc ~x86 ~amd64"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="Doc/*.txt Doc/*.tex Doc/install/*.txt"
+ distutils_src_install
+
+ dohtml Doc/install/*.html
+ dohtml Doc/*.html
+ cp -r Doc/examples/ Doc/*.pdf ${D}/usr/share/doc/${PF}/
+}