summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-03 16:03:42 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-03 16:03:42 +0000
commit29a3e1443e35da8d6c379bd913c1088e104080e3 (patch)
tree00efc7d091c8b89aac2c60384fdc97ba89f90b7d /sci-biology/biopython
parentVersion Bump; add py3 and pypy support (diff)
downloadgentoo-2-29a3e1443e35da8d6c379bd913c1088e104080e3.tar.gz
gentoo-2-29a3e1443e35da8d6c379bd913c1088e104080e3.tar.bz2
gentoo-2-29a3e1443e35da8d6c379bd913c1088e104080e3.zip
Drop old
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog8
-rw-r--r--sci-biology/biopython/biopython-1.58.ebuild55
-rw-r--r--sci-biology/biopython/biopython-1.59.ebuild55
-rw-r--r--sci-biology/biopython/biopython-1.61.ebuild48
-rw-r--r--sci-biology/biopython/biopython-1.62-r1.ebuild48
-rw-r--r--sci-biology/biopython/biopython-1.62.ebuild46
-rw-r--r--sci-biology/biopython/biopython-1.63-r1.ebuild52
-rw-r--r--sci-biology/biopython/biopython-1.63.ebuild47
-rw-r--r--sci-biology/biopython/biopython-1.64.ebuild6
9 files changed, 10 insertions, 355 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index c7671622e36e..7daa655adb46 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.77 2015/03/03 16:01:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.78 2015/03/03 16:03:42 jlec Exp $
+
+ 03 Mar 2015; Justin Lecher <jlec@gentoo.org> -biopython-1.58.ebuild,
+ -biopython-1.59.ebuild, -biopython-1.61.ebuild, -biopython-1.62-r1.ebuild,
+ -biopython-1.62.ebuild, -biopython-1.63-r1.ebuild, -biopython-1.63.ebuild,
+ biopython-1.64.ebuild:
+ Drop old
*biopython-1.65 (03 Mar 2015)
diff --git a/sci-biology/biopython/biopython-1.58.ebuild b/sci-biology/biopython/biopython-1.58.ebuild
deleted file mode 100644
index 4433194ae75e..000000000000
--- a/sci-biology/biopython/biopython-1.58.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.58.ebuild,v 1.2 2012/12/14 10:00:10 ulm Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="mysql postgres"
-
-RDEPEND="
- dev-python/numpy
- dev-python/reportlab
- mysql? ( dev-python/mysql-python )
- postgres? ( dev-python/psycopg )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-DOCS="CONTRIB DEPRECATED NEWS README"
-PYTHON_MODNAME="Bio BioSQL"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-1.51-flex.patch"
-}
-
-src_test() {
- testing() {
- cd Tests
- PYTHONPATH="$(ls -d ../build/lib.*)" "$(PYTHON)" run_tests.py
- }
- python_execute_function --nonfatal -s testing
-}
-
-src_install() {
- distutils_src_install
-
- insinto /usr/share/doc/${PF}
- doins -r Doc/* || die "Installation of documentation failed"
- insinto /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}usr/share/${PN}" || die "Installation of shared files failed"
-}
diff --git a/sci-biology/biopython/biopython-1.59.ebuild b/sci-biology/biopython/biopython-1.59.ebuild
deleted file mode 100644
index 66e93c7c0abb..000000000000
--- a/sci-biology/biopython/biopython-1.59.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.59.ebuild,v 1.2 2012/12/14 10:00:10 ulm Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="mysql postgres"
-
-RDEPEND="
- dev-python/numpy
- dev-python/reportlab
- mysql? ( dev-python/mysql-python )
- postgres? ( dev-python/psycopg )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-DOCS="CONTRIB DEPRECATED NEWS README"
-PYTHON_MODNAME="Bio BioSQL"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-1.51-flex.patch"
-}
-
-src_test() {
- testing() {
- cd Tests
- PYTHONPATH="$(ls -d ../build/lib.*)" "$(PYTHON)" run_tests.py
- }
- python_execute_function --nonfatal -s testing
-}
-
-src_install() {
- distutils_src_install
-
- insinto /usr/share/doc/${PF}
- doins -r Doc/* || die "Installation of documentation failed"
- insinto /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}usr/share/${PN}" || die "Installation of shared files failed"
-}
diff --git a/sci-biology/biopython/biopython-1.61.ebuild b/sci-biology/biopython/biopython-1.61.ebuild
deleted file mode 100644
index 22ccbb08daef..000000000000
--- a/sci-biology/biopython/biopython-1.61.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.61.ebuild,v 1.3 2013/07/02 12:47:34 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="mysql postgres"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/reportlab[${PYTHON_USEDEP}]
- media-gfx/pydot[${PYTHON_USEDEP}]
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-DOCS=( CONTRIB DEPRECATED NEWS README )
-
-python_test() {
- cd Tests
- ${PYTHON} run_tests.py
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/doc/${PF}
- doins -r Doc/*
- insinto /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}
diff --git a/sci-biology/biopython/biopython-1.62-r1.ebuild b/sci-biology/biopython/biopython-1.62-r1.ebuild
deleted file mode 100644
index 433cffb9ad69..000000000000
--- a/sci-biology/biopython/biopython-1.62-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.62-r1.ebuild,v 1.1 2013/12/29 00:56:58 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="mysql postgres"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/reportlab[${PYTHON_USEDEP}]
- media-gfx/pydot[${PYTHON_USEDEP}]
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
-
-PATCHES=( "${FILESDIR}/${PN}-1.62-SffIO.patch" )
-
-python_test() {
- cd Tests || die
- ${PYTHON} run_tests.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodir /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}
diff --git a/sci-biology/biopython/biopython-1.62.ebuild b/sci-biology/biopython/biopython-1.62.ebuild
deleted file mode 100644
index 7d36020e90a7..000000000000
--- a/sci-biology/biopython/biopython-1.62.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.62.ebuild,v 1.1 2013/09/17 16:07:56 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="mysql postgres"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/reportlab[${PYTHON_USEDEP}]
- media-gfx/pydot[${PYTHON_USEDEP}]
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
-
-python_test() {
- cd Tests || die
- ${PYTHON} run_tests.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodir /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}
diff --git a/sci-biology/biopython/biopython-1.63-r1.ebuild b/sci-biology/biopython/biopython-1.63-r1.ebuild
deleted file mode 100644
index eeeb100d40fc..000000000000
--- a/sci-biology/biopython/biopython-1.63-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.63-r1.ebuild,v 1.1 2014/05/07 11:00:43 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="mysql postgres"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/reportlab[${PYTHON_USEDEP}]
- media-gfx/pydot[${PYTHON_USEDEP}]
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
-
-PATCHES=(
- "${FILESDIR}/SffIO_error_in_check_eof.patch"
- "${FILESDIR}/SffIO_broken_padding.patch"
- )
-
-python_test() {
- cd Tests || die
- ${PYTHON} run_tests.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodir /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}
diff --git a/sci-biology/biopython/biopython-1.63.ebuild b/sci-biology/biopython/biopython-1.63.ebuild
deleted file mode 100644
index f8079711ce31..000000000000
--- a/sci-biology/biopython/biopython-1.63.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.63.ebuild,v 1.1 2014/01/30 15:15:24 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="mysql postgres"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/reportlab[${PYTHON_USEDEP}]
- media-gfx/pydot[${PYTHON_USEDEP}]
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
-
-python_test() {
- cd Tests || die
- ${PYTHON} run_tests.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodir /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}
diff --git a/sci-biology/biopython/biopython-1.64.ebuild b/sci-biology/biopython/biopython-1.64.ebuild
index c1cad3f6d822..09e531bc734d 100644
--- a/sci-biology/biopython/biopython-1.64.ebuild
+++ b/sci-biology/biopython/biopython-1.64.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.64.ebuild,v 1.1 2014/06/03 06:54:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.64.ebuild,v 1.2 2015/03/03 16:03:42 jlec Exp $
EAPI=5
@@ -28,7 +28,7 @@ RDEPEND="${PYTHON_DEPS}
dev-python/reportlab[${PYTHON_USEDEP}]
media-gfx/pydot[${PYTHON_USEDEP}]
mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
sys-devel/flex"