summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-28 17:14:17 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-28 17:14:17 +0000
commitcf01eea994bd984023ff384227fe0c98e9095605 (patch)
tree678497c5eb25710f9d7b8ab6568d43e3483d1d95 /sci-biology/embassy-mse
parentImport latest changes from science overlay, thanks Ted Tanberry for the work;... (diff)
downloadgentoo-2-cf01eea994bd984023ff384227fe0c98e9095605.tar.gz
gentoo-2-cf01eea994bd984023ff384227fe0c98e9095605.tar.bz2
gentoo-2-cf01eea994bd984023ff384227fe0c98e9095605.zip
Import latest changes from science overlay, thanks Ted Tanberry for the work; fixes #335603
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/embassy-mse')
-rw-r--r--sci-biology/embassy-mse/ChangeLog11
-rw-r--r--sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild23
-rw-r--r--sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch133
-rw-r--r--sci-biology/embassy-mse/metadata.xml2
4 files changed, 166 insertions, 3 deletions
diff --git a/sci-biology/embassy-mse/ChangeLog b/sci-biology/embassy-mse/ChangeLog
index cd6f7078ef0a..08248221ea75 100644
--- a/sci-biology/embassy-mse/ChangeLog
+++ b/sci-biology/embassy-mse/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/embassy-mse
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/embassy-mse/ChangeLog,v 1.38 2011/10/20 08:52:56 xarthisius Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/embassy-mse/ChangeLog,v 1.39 2015/03/28 17:14:17 jlec Exp $
+
+*embassy-mse-3.0.0.650 (28 Mar 2015)
+
+ 28 Mar 2015; Justin Lecher <jlec@gentoo.org> +embassy-mse-3.0.0.650.ebuild,
+ +files/embassy-mse-3.0.0.650_fix-build-system.patch, metadata.xml:
+ Import latest changes from science overlay, thanks Ted Tanberry for the work;
+ fixes #335603
20 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org>
embassy-mse-1.0.0-r6.ebuild, embassy-mse-1.0.0-r7.ebuild:
diff --git a/sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild b/sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild
new file mode 100644
index 000000000000..6b5725be73c3
--- /dev/null
+++ b/sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/embassy-mse/embassy-mse-3.0.0.650.ebuild,v 1.1 2015/03/28 17:14:17 jlec Exp $
+
+EAPI=5
+
+EBO_DESCRIPTION="MSE - Multiple Sequence Screen Editor"
+EBO_EXTRA_ECONF="$(use_enable ncurses curses)"
+
+PATCHES=( "${FILESDIR}"/${P}_fix-build-system.patch )
+AUTOTOOLS_AUTORECONF=1
+inherit emboss-r1
+
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos"
+IUSE+=" ncurses"
+
+RDEPEND+=" ncurses? ( sys-libs/ncurses )"
+
+src_install() {
+ emboss-r1_src_install
+ insinto /usr/include/emboss/mse
+ doins h/*.h
+}
diff --git a/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch b/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch
new file mode 100644
index 000000000000..8b2f0574e3b0
--- /dev/null
+++ b/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch
@@ -0,0 +1,133 @@
+--- MSE-3.0.0.650/configure.ac
++++ MSE-3.0.0.650/configure.ac
+@@ -635,33 +635,6 @@
+
+
+
+-dnl PCRE library definitions - see the MAJOR and MINOR values
+-dnl to see which version's configure.in these lines come from
+-
+-dnl Provide the current PCRE version information. Do not use numbers
+-dnl with leading zeros for the minor version, as they end up in a C
+-dnl macro, and may be treated as octal constants. Stick to single
+-dnl digits for minor numbers less than 10. There are unlikely to be
+-dnl that many releases anyway.
+-
+-PCRE_MAJOR="7"
+-PCRE_MINOR="9"
+-PCRE_DATE="11-Apr-2009"
+-PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
+-
+-dnl Default values for miscellaneous macros
+-
+-POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
+-
+-dnl Provide versioning information for libtool shared libraries that
+-dnl are built by default on Unix systems.
+-
+-PCRE_LIB_VERSION="0:1:0"
+-PCRE_POSIXLIB_VERSION="0:0:0"
+-
+-
+-
+-
+ dnl FIXME: This does no longer seem required with Autoconf 2.67?
+ dnl Intel MacOSX 10.6 puts X11 in a non-standard place
+ dnl AS_IF([test "x${with_x}" != "xno"],
+@@ -737,21 +710,6 @@
+
+
+
+-dnl "Export" these variables for PCRE
+-
+-AC_SUBST([HAVE_MEMMOVE])
+-AC_SUBST([HAVE_STRERROR])
+-AC_SUBST([PCRE_MAJOR])
+-AC_SUBST([PCRE_MINOR])
+-AC_SUBST([PCRE_DATE])
+-AC_SUBST([PCRE_VERSION])
+-AC_SUBST([PCRE_LIB_VERSION])
+-AC_SUBST([PCRE_POSIXLIB_VERSION])
+-AC_SUBST([POSIX_MALLOC_THRESHOLD])
+-
+-
+-
+-
+ dnl Test if --enable-localforce given
+ locallink="no"
+ embprefix="/usr/local"
+@@ -874,6 +832,11 @@
+ AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+
+
++AS_IF([test "x${enable_systemlibs}" = "xyes"],
++[
++dnl using system libraries
++ PKG_CHECK_MODULES([PLPLOT], [plplotd])
++])
+
+
+ # Enable the purify tool: --enable-purify, sets CC and LIBTOOL
+@@ -1000,17 +963,13 @@
+
+
+
+-dnl emnu and mse only: uses curses
+-dnl Test if --with-curses is given
+-AC_ARG_WITH([curses],
+- [AS_HELP_STRING([--with-curses],
+- [curses (or ncurses)])])
+-if test "${with_curses}" ; then
+-AC_MSG_CHECKING([for curses])
+-CPPFLAGS="$CPPFLAGS -I${with_curses}/include -I${with_curses}/include/ncurses"
+-LDFLAGS="$LDFLAGS -L${with_curses}/lib"
+-fi
+-AC_CHECK_LIB(ncurses, main, LIBS="$LIBS -lncurses", LIBS="$LIBS -lcurses")
++dnl Test if --enable-curses is given
++AC_ARG_ENABLE([curses],
++[AS_HELP_STRING([--enable-curses], [curses])])
++
++AS_IF([test "x$enable_curses" = "xyes"], [
++ PKG_CHECK_MODULES([NCURSES], [ncurses])
++])
+
+
+
+--- MSE-3.0.0.650/src/Makefile.am
++++ MSE-3.0.0.650/src/Makefile.am
+@@ -18,9 +18,7 @@
+ -I../../../ajax/ensembl -I../../../ajax/ajaxdb \
+ -I../../../ajax/acd -I../../../plplot
+ else
+-AM_CPPFLAGS = -I../h -I${embprefix}/include \
+- -I${embprefix}/include/eplplot -I${embprefix}/include/epcre \
+- $(NLINCLUDES)
++AM_CPPFLAGS = -I$(top_srcdir)/h -I${embprefix}/include $(NLINCLUDES) $(PLPLOT_CFLAGS) $(NCURSES_CFLAGS)
+ endif
+
+ if ISSHARED
+@@ -60,5 +58,5 @@
+ $(XLIB)
+ else
+ LDADD = ../ckit/libckit.la -L${embprefix}/lib -lnucleus -lacd -lajaxdb \
+- -lensembl -lajaxg -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++ -lensembl -lajaxg -lajax $(NLADD) $(NCURSES_LIBS) $(XLIB)
+ endif
+--- MSE-3.0.0.650/ckit/Makefile.am
++++ MSE-3.0.0.650/ckit/Makefile.am
+@@ -2,7 +2,7 @@
+
+ lib_LTLIBRARIES = libckit.la
+
+-AM_CPPFLAGS = -I../h
++AM_CPPFLAGS = -I$(top_srcdir)/h
+
+ CKITSRC = datafiles.c next.c seqentry.c strings.c gcg.c pir.c \
+ seqspec.c ttyinterface.c nextseqentry.c \
+--- MSE-3.0.0.650/emboss_acd/Makefile.am
++++ MSE-3.0.0.650/emboss_acd/Makefile.am
+@@ -1,3 +1,3 @@
+
+-pkgdata_DATA = *.acd
++pkgdata_DATA = $(srcdir)/*.acd
+ pkgdatadir=$(prefix)/share/EMBOSS/acd
diff --git a/sci-biology/embassy-mse/metadata.xml b/sci-biology/embassy-mse/metadata.xml
index d4648212cbad..f17a827e3101 100644
--- a/sci-biology/embassy-mse/metadata.xml
+++ b/sci-biology/embassy-mse/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-biology</herd>
+ <herd>sci-biology</herd>
</pkgmetadata>